Bug 748048 - fluxbox.desktop in /usr/share/applications?
Summary: fluxbox.desktop in /usr/share/applications?
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: fluxbox
Version: el6
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-21 19:45 UTC by Robert Hamrick
Modified: 2011-11-21 22:56 UTC (History)
2 users (show)

Fixed In Version: fluxbox-1.3.2-2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-21 22:56:47 UTC
Type: ---


Attachments (Terms of Use)
simple fluxbox.desktop for /usr/share/applications (180 bytes, application/x-desktop)
2011-10-21 19:45 UTC, Robert Hamrick
no flags Details

Description Robert Hamrick 2011-10-21 19:45:38 UTC
Created attachment 529558 [details]
simple fluxbox.desktop for /usr/share/applications

Description of problem:

It'd be useful to be able to use fluxbox as a window manager in the gnome environment just by specifying "fluxbox" as the value for the gconf attribute /desktop/gnome/session/required_components/windowmanager (instead of "metacity").

It looks like all that's needed for this on the package side is a simple fluxbox.desktop file in /usr/share/applications.

Currently, the fluxbox rpm installs a fluxbox.desktop file in /usr/share/xsessions, but not /usr/share/applications.  It may be possible to use the same file in both locations.

Version-Release number of selected component (if applicable):

I'm looking at fluxbox-1.1.1-5.el6.x86_64 on rhel 6.1 workstation.

How reproducible:

always

Steps to Reproduce:
1. set gconf attribute /desktop/gnome/session/required_components/windowmanager to "fluxbox"
2. start gnome session
  
Actual results:

fluxbox isn't the window manager

Expected results:

fluxbox is window manager

Additional info:

Comment 1 Fedora Update System 2011-11-06 21:44:08 UTC
fluxbox-1.3.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/fluxbox-1.3.2-1.fc16

Comment 2 Fedora Update System 2011-11-06 21:52:15 UTC
fluxbox-1.3.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/fluxbox-1.3.2-1.fc15

Comment 3 Fedora Update System 2011-11-07 08:55:00 UTC
Package fluxbox-1.3.2-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fluxbox-1.3.2-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15524
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-11-21 22:53:20 UTC
fluxbox-1.3.2-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2011-11-21 22:56:47 UTC
fluxbox-1.3.2-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.