Bug 7481 - Installer partitions wrong disk! CAUSES DATA LOSS.
Installer partitions wrong disk! CAUSES DATA LOSS.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-01 09:54 EST by jah
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-01 14:24:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jah 1999-12-01 09:54:57 EST
I installed a new 1G SCSI (ID4/sdb) alongside my old 8G unit (ID0/sda)
which contained a root fs and a mirror of ftp.redhat.com. I wanted to
install 6.1 on the new disk.

I selected ``Local hard disk'' to install from and gave the installer a
path to the package files:

  sda:/home/ftp/Mirrors/ftp.redhat.com/pub/redhat/redhat-6.1/i386

So far, so good. The installer reads the package information OK.

I tell the installer I wish to install a ``Server distribution'' and let it
run. The installer then proceeds to repartition sda---the disk with the
package files on it!!! This is very brain-dead of it. Now I have lost my
original Red Hat installation *and* also the means to re-install it.

This may also happen on Sparc but I have no desire to test it.

Grrrr. /.J
Comment 1 Jay Turner 1999-12-01 10:23:59 EST
The Server installation will delete and make use of all drives and partitions
available to it, and therefore you lost the source files and the original
installation.  This behavior (reformatting all of the drives) is the expected
and programmed behavior of the Server-class installation.
Comment 2 jah 1999-12-01 10:43:59 EST
Excuse me, since when has the source media ever been a valid target for
installation????

This may be the ``programmed behaviour'', in which case your (sorry, Red Hat's)
logic is faulty. This behaviour makes the combination of Server-class install
from Local Hard Disk impossible.

The very least you could do would be to document this properly, but I suspect it
would be rather much easier to have the installer warn you of the dangers
instead.

/.J
Comment 3 Jay Turner 1999-12-01 14:24:59 EST
Page 20 of the 6.1 Installation Guide says that a sever-class installation will
remove "ALL existing partitions of ANY type on ALL existing hard drives on your
system."  Flipping a little further to page 40 shows "A server-class
installation will erase all partitions (both Linux and non-Linux) from every one
of your computer's hard drive(s)."

Yes, you are correct that this behavior prevents performing a server-class
installation from hard drive, but this is actually a better proposition.  The
point of a server installation is to prepare a system for use as a server, so
the server-class installation is designed to make use of all drive space on the
machine.  This was the desired behavior people wanted, so this is how the
server-class installation works.

The custom-class installation would allow you to preserve the source files as
you wish.

Note You need to log in before you can comment on or make changes to this bug.