Bug 748159 - rts5139: staging/rts5139: SD card reader not detected on ASUS notebook
rts5139: staging/rts5139: SD card reader not detected on ASUS notebook
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-22 12:40 EDT by Vincent Beers
Modified: 2016-05-27 10:30 EDT (History)
29 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-27 10:30:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsusb (545 bytes, text/plain)
2011-11-03 05:47 EDT, Teguh DC
no flags Details
lsusb -v (2.70 KB, text/plain)
2011-11-03 05:48 EDT, Teguh DC
no flags Details
lspci -v on Asus K93SV (9.38 KB, application/octet-stream)
2011-11-06 14:36 EST, Vincent Beers
no flags Details
screenshot 1 (62.69 KB, image/png)
2014-08-04 17:39 EDT, Paul Lambert
no flags Details
screenshot 2 (23.99 KB, image/png)
2014-08-04 17:39 EDT, Paul Lambert
no flags Details
Screen shots of formatting error (185.92 KB, application/zip)
2014-10-15 10:29 EDT, Paul Lambert
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Novell 890096 None None None Never

  None (edit)
Description Vincent Beers 2011-10-22 12:40:10 EDT
Description of problem:
Whenever I insert an SD card into my Asus K93SV notebook, absolutely nothing happens.

Version-Release number of selected component (if applicable):
Fedora 16 beta 2

Steps to Reproduce:
1. Insert an SD card into the slot.
OR
1. Already have an SD card inserted before boot.
  
Actual results:
Nothing happens.

Expected results:
Nautilus opens to show the SD card contents.

Additional info:
The SD card is formatted FAT32 and has worked on all of my other notebooks with Fedora installed on them. The SD card is still detected just fine on these computers.

Some outputs:
# tail -f /var/log/messages
Oct 22 18:01:01 vincent-asuslaptop systemd-logind[1006]: New session 6 of user root.
Oct 22 18:01:01 vincent-asuslaptop systemd-logind[1006]: Removed session 6.
Oct 22 18:05:26 vincent-asuslaptop dbus[1037]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Oct 22 18:05:26 vincent-asuslaptop dbus-daemon[1037]: dbus[1037]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Oct 22 18:05:26 vincent-asuslaptop dbus-daemon[1037]: Launching FprintObject
Oct 22 18:05:26 vincent-asuslaptop dbus[1037]: [system] Successfully activated service 'net.reactivated.Fprint'
Oct 22 18:05:26 vincent-asuslaptop dbus-daemon[1037]: dbus[1037]: [system] Successfully activated service 'net.reactivated.Fprint'
Oct 22 18:05:26 vincent-asuslaptop dbus-daemon[1037]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
Oct 22 18:05:26 vincent-asuslaptop dbus-daemon[1037]: ** Message: entering main loop
Oct 22 18:05:56 vincent-asuslaptop dbus-daemon[1037]: ** Message: No devices in use, exit


# udevadm monitor
Does not output anything whenever I insert or remove the SD card.


Similar problems seem to exist for previous Asus-based notebooks, too. Since nothing seems to be claiming the device, is a driver missing or something?

It is very important for me that this works (I keep all my school work on an SD card so it's portable and easily backuppable).
Comment 1 Victor Ion Munteanu 2011-10-22 15:06:35 EDT
I have an Asus G73JW laptop. I have the same problem as stated above. It did work on Ubuntu 10.10 but not on Ubuntu 11.04. Now I'm on Fedora 16 and it is not working. It's working perfectly under windows.

As far as I know, the SD Card is a Realtek one. If there is anything I can help solve this problem, please let me know.
Comment 2 Josh Boyer 2011-11-02 12:06:13 EDT
Can you provide the lspci output for the reader?  I doubt there's an upstream driver yet, but if we have that here we'll at least be able to watch for it in case it shows up.
Comment 3 Teguh DC 2011-11-03 05:47:31 EDT
Created attachment 531531 [details]
lsusb
Comment 4 Teguh DC 2011-11-03 05:48:20 EDT
Created attachment 531532 [details]
lsusb -v

lsusb -v
Comment 5 Teguh DC 2011-11-03 05:55:03 EDT
Maybe this link have solution for this sd card ...

http://ubuntuforums.org/showthread.php?t=1797202
Comment 6 Josh Boyer 2011-11-03 15:05:40 EDT
Good find.  Seems the rts5139 driver in the staging directory covers this device.  We'll move this bug to rawhide and enable it when it moves out of staging.
Comment 7 Vincent Beers 2011-11-06 14:36:40 EST
Created attachment 531941 [details]
lspci -v on Asus K93SV

There don't seem to be any signs of an SD card reader on my computer when running lsusb:

$ sudo lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 058f:a016 Alcor Micro Corp. 
Bus 002 Device 003: ID 046d:c52f Logitech, Inc. Wireless Mouse M305
Bus 002 Device 004: ID 1532:010b Razer USA, Ltd 
Bus 002 Device 005: ID 04e8:1f06 Samsung Electronics Co., Ltd 

For clarification, the Alcor device is the webcam and Razer is the USB keyboard.

sudo lspci -v gives me the contents of the attached file.
Comment 8 Josh Boyer 2012-02-02 09:25:53 EST
Moving this to ASSIGNED state so it doesn't keep showing up as new.
Comment 9 Rudd-O DragonFear 2012-02-02 20:41:15 EST
I have tested the card reader using kernel 3.3-rc2 and the staging driver enabled.

It works PROPERLY and FLAWLESSLY.

Who is responsible for upstreaming this from staging into the block driver tree?
Comment 10 Rudd-O DragonFear 2012-02-02 20:41:30 EST
Oh I failed to mention, Fedora 16 here.
Comment 11 Rudd-O DragonFear 2012-02-02 20:42:36 EST
Asus G73Sw-XT1 model.  Same card reader.
Comment 12 Victor Ion Munteanu 2012-02-03 01:28:17 EST
(In reply to comment #2)
> Can you provide the lspci output for the reader?  I doubt there's an upstream
> driver yet, but if we have that here we'll at least be able to watch for it in
> case it shows up.

Sorry for the late reply. The lspci output:

00:00.0 Host bridge: Intel Corporation Core Processor DMI (rev 11)
00:03.0 PCI bridge: Intel Corporation Core Processor PCI Express Root Port 1 (rev 11)
00:08.0 System peripheral: Intel Corporation Core Processor System Management Registers (rev 11)
00:08.1 System peripheral: Intel Corporation Core Processor Semaphore and Scratchpad Registers (rev 11)
00:08.2 System peripheral: Intel Corporation Core Processor System Control and Status Registers (rev 11)
00:08.3 System peripheral: Intel Corporation Core Processor Miscellaneous Registers (rev 11)
00:10.0 System peripheral: Intel Corporation Core Processor QPI Link (rev 11)
00:10.1 System peripheral: Intel Corporation Core Processor QPI Routing and Protocol Registers (rev 11)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
01:00.0 VGA compatible controller: nVidia Corporation GF106 [GeForce GTX 460M] (rev a1)
01:00.1 Audio device: nVidia Corporation GF106 High Definition Audio Controller (rev a1)
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 USB Controller: Fresco Logic Device 1400 (rev 01)
05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5209 (rev 01)
06:00.0 Ethernet controller: Atheros Communications AR8131 Gigabit Ethernet (rev c0)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-Core Registers (rev 04)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 04)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 04)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 04)
ff:03.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller (rev 04)
ff:03.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Target Address Decoder (rev 04)
ff:03.4 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Test Registers (rev 04)
ff:04.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Control Registers (rev 04)
ff:04.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Address Registers (rev 04)
ff:04.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Rank Registers (rev 04)
ff:04.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Thermal Control Registers (rev 04)
ff:05.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Control Registers (rev 04)
ff:05.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Address Registers (rev 04)
ff:05.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Rank Registers (rev 04)
ff:05.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Thermal Control Registers (rev 04)
Comment 13 Rudd-O DragonFear 2012-02-06 08:53:13 EST
My reader is an RTS 5139.
Comment 14 The Source 2012-03-24 03:05:20 EDT
rts5139 driver is in kernel for several minor versions now. But why it disabled in Fedora kernel config? (3.3.0-4). Please enable rts5139 driver.

Parameter:
CONFIG_RTS5139
Comment 15 Josh Boyer 2012-03-26 13:45:13 EDT
(In reply to comment #14)
> rts5139 driver is in kernel for several minor versions now. But why it disabled
> in Fedora kernel config? (3.3.0-4). Please enable rts5139 driver.
> 
> Parameter:
> CONFIG_RTS5139

See comment #6.  It's still in staging.
Comment 16 Karel Volný 2012-04-11 04:10:20 EDT
(In reply to comment #15)
> (In reply to comment #14)
> > rts5139 driver is in kernel for several minor versions now. But why it disabled
> > in Fedora kernel config? (3.3.0-4). Please enable rts5139 driver.
> > 
> > Parameter:
> > CONFIG_RTS5139
> 
> See comment #6.  It's still in staging.

is there an option to make an exception and enable this for Fedora 17?

- I've just purchased two machines (two different models of Lenovo B570e) that are hit by this issue ... seems there is pretty high demand for this feature, just see the CC list here or google the relevant reader ids and "linux" keyword ...

the driver is used "in the wild" for more than year, it has already undergone fixing in kernel tree and reports are that it is pretty stable (btw, it is available in Ubuntu 11.10 already)
Comment 17 Sergio Pascual 2012-04-11 05:46:51 EDT
(In reply to comment #16)
> 
> the driver is used "in the wild" for more than year, it has already undergone
> fixing in kernel tree and reports are that it is pretty stable (btw, it is
> available in Ubuntu 11.10 already)

You can install the kmod-staging package from rpmfusion.org 
It comes with the module of this car reader enabled. That's what I do to enable the card reader in my asus laptop
Comment 18 Josh Boyer 2012-04-11 08:47:38 EDT
(In reply to comment #17)
> (In reply to comment #16)
> > 
> > the driver is used "in the wild" for more than year, it has already undergone
> > fixing in kernel tree and reports are that it is pretty stable (btw, it is
> > available in Ubuntu 11.10 already)

There have been no significant changes towards making it suitable for inclusion in the mainline kernel since it was added.  The fixes mentioned are essentially style changes or small header changes to make it continue building.  The real work that needs to be done is contained in the TODO file in the driver directory.  In short, it's these two items:

- stop having thousands of lines of code duplicated with staging/rts_pstor
- This driver contains an entire SD/MMC stack -- it should use the stack in
  drivers/mmc instead, as a host driver e.g. drivers/mmc/host/realtek-usb.c;
  see drivers/mmc/host/ushc.c as an example.
- This driver presents cards as SCSI devices, but they should be MMC devices.

> You can install the kmod-staging package from rpmfusion.org 
> It comes with the module of this car reader enabled. That's what I do to enable
> the card reader in my asus laptop

This would be a solution to enabling it if you desire, yes.
Comment 19 Karel Volný 2012-04-13 09:09:50 EDT
(In reply to comment #18)
> (In reply to comment #17)
> > (In reply to comment #16)
> > > 
> > > the driver is used "in the wild" for more than year, it has already undergone
> > > fixing in kernel tree and reports are that it is pretty stable (btw, it is
> > > available in Ubuntu 11.10 already)
> 
> There have been no significant changes towards making it suitable for inclusion
> in the mainline kernel since it was added.  The fixes mentioned are essentially
> style changes or small header changes to make it continue building.

ah, sorry - I just saw some discussion about patches in kernel improving the driver while googling for this, so I thought this is it ... I'm no kernel expert to know that it was just "cosmetics", thanks for the explanation

> The real work that needs to be done is contained in the TODO file in the
> driver directory.

ok, whom can I buy a beer to do it? :-)

> - This driver presents cards as SCSI devices, but they should be MMC devices.

hm, isn't that an advantage, as there are dozens of tools that work with scsi/scsi-emulation while not recognising other stuff? (why did the kernel start to treat IDE burners as SCSI devices centuries ago?)

> > You can install the kmod-staging package from rpmfusion.org 
> > It comes with the module of this car reader enabled. That's what I do to enable
> > the card reader in my asus laptop
> 
> This would be a solution to enabling it if you desire, yes.

unfortunately, this is not a solution now, ATM, because kmod-staging is older than any kernel which is available for F17

I've tried to rebuild kernel srpm with CONFIG_RTS5139=m and CONFIG_RTS5139_DEBUG=n in config-local, and it works for me
(not setting debug explicitly led to some configure failure)
Comment 20 Rudd-O DragonFear 2012-08-10 16:30:38 EDT
Thanks for the rpmfusion tip.
Comment 21 Justin M. Forbes 2012-12-13 11:34:12 EST
*** Bug 886945 has been marked as a duplicate of this bug. ***
Comment 22 lnxslck 2013-02-11 17:39:18 EST
I also have the same problem. 

Fedora 18 64 bits

Hardware
Bus 001 Device 004: ID 0bda:0139 Realtek Semiconductor Corp. RTS5139 Card Reader Controller

Kernel

3.7.6-201.fc18.x86_64

Solution for this?
Comment 23 Karel Volný 2013-02-12 10:05:00 EST
(In reply to comment #22)
> Solution for this?

comment #17 doesn't help?
Comment 24 lnxslck 2013-02-13 18:27:31 EST
(In reply to comment #23)
> (In reply to comment #22)
> > Solution for this?
> 
> comment #17 doesn't help?

I haven't tried that. I solved my problem by downloading the rts5139 driver and manually installing it and loading it into the kernel. The thing is i will have to do it each time i install a new kernel :(
Comment 25 Juraj Jurco 2013-08-05 10:03:27 EDT
I have the same problem. At first comment #17 helped me. But after installing updates it is not working again. I already tried to reinstall kmod-staging but I already have the leatest version. 

xjuraj@localhost:~$ sudo yum install kmod-staging
Loaded plugins: langpacks, refresh-
              : packagekit
Package kmod-staging-3.9.2-2.fc19.9.x86_64 already installed and latest version
Nothing to do

When I try to enable module rts5139 I get a message: 
xjuraj@localhost:~$ sudo modprobe rts5139
modprobe: FATAL: Module rts5139 not found.

When I try to locate module RTS5139 I can see it is in my system:
xjuraj@localhost:~$ locate rts5139
/usr/lib/modules/3.9.9-302.fc19.x86_64/extra/staging/rts5139.ko
/usr/share/doc/staging-kmod-addons-3.9.2/rts5139-TODO
/usr/src/kernels/3.10.3-300.fc19.x86_64/drivers/staging/rts5139
/usr/src/kernels/3.10.3-300.fc19.x86_64/drivers/staging/rts5139/Kconfig
/usr/src/kernels/3.10.3-300.fc19.x86_64/drivers/staging/rts5139/Makefile
/usr/src/kernels/3.9.9-302.fc19.x86_64/drivers/staging/rts5139
/usr/src/kernels/3.9.9-302.fc19.x86_64/drivers/staging/rts5139/Kconfig
/usr/src/kernels/3.9.9-302.fc19.x86_64/drivers/staging/rts5139/Makefile

Here is output of lsbus:
Bus 002 Device 005: ID 0bda:0139 Realtek Semiconductor Corp. RTS5139 Card Reader Controller
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass       255 Vendor Specific Subclass
  bDeviceProtocol       255 Vendor Specific Protocol
  bMaxPacketSize0        64
  idVendor           0x0bda Realtek Semiconductor Corp.
  idProduct          0x0139 RTS5139 Card Reader Controller
  bcdDevice           39.60
  iManufacturer           1 
  iProduct                2 
  iSerial                 3 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           39
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          4 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      6 
      bInterfaceProtocol     80 
      iInterface              5 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0003  1x 3 bytes
        bInterval              10
Comment 26 Dylan R. Semler 2013-08-05 12:20:58 EDT
There are no kmod-staging packages for the latest two kernels (3.10.3-300 and 3.10.4-300).  If you boot into your old 3.9.2 kernel the card reader should be working.  Note that there is kmod-staging for 3.9.9-302, so it's strange that it's telling you that 3.9.2-2 is the latest version.
Comment 27 TL 2013-12-29 13:43:17 EST
Same problem.  I'm running Fedora 19, kernel 3.12.5-200.fc19.x86_64, Asus UX31A.  I tried various suggestions on this thread, including installing kmod-staging.  Still doesn't see the SD card/slot.  Anything I can do here?  Thanks, TL
Comment 28 DidierDN 2014-01-12 17:07:44 EST
Hi!

I experience a similar issue on my Lenovo Ideapad S300. 

The card reader is Realtek RTS5129: it's correctly listed via lsusb, but nothing happens when I insert / remove a memory card.

I'm running the latest kernel on Fedora 20 (3.12.6-300.fc20.x86_64).

Thanks for your help,
Didier
Comment 29 Roland Kuebert 2014-02-08 17:57:11 EST
Same issue here on a Lenovo Ideapad Z500.

The card reader is an RTS5129 and it is correctly listed via USB, but as for the other commentators, nothing happens when inserting or removing a card, dmesg is silent.

I am running Fedora 20, kernel is 3.12.8-300.fc20.x86_64.

Cheers

Roland
Comment 30 uce pit 2014-03-04 22:30:33 EST
Toshiba Satellite L730, Fedora 20 fully updated. Card reader not enabled, card insertion not detected.

1) Have the RPMfusion repositories configured on my system first.

2) Open a terminal and type:

sudo yum install kmod-staging

3) In the same terminal type:

sudo modprobe rts5139

And now my hardware (the card reader) is enabled and will work.

Why should I have to do this in 2014?
Comment 31 TL 2014-03-10 18:45:51 EDT
When I attempt to load the module rts5139 like Comment 30, I get "modprobe: ERROR: could not insert 'rts5139': Required key not available."  Does this mean that I have to disable SecureBoot altogether, or pass "enforcemodulesig=0" to the kernel?  Both seem overly drastic.  What is the solution here?  I'm running kernel 3.12.5-200.fc19.x86_64, Fedora 19, Asus UX31A.
Comment 32 Kostas 2014-03-27 14:03:13 EDT
Also affected on an K53SM. Comment 30 worked for me. Thanks!
 How is this still an issue 3 years after the first report?
Comment 33 Garrett Mitchener 2014-06-17 22:32:03 EDT
Also affected, Fedora 20, Asus UX31A, got Comment 30 instructions to work. I'd really like to see this fixed.
Comment 34 Paul Lambert 2014-08-04 17:38:00 EDT
Not getting SD card to mount on HP Pavillion dv7-1030US laptop runing 3.15.7-200.fc20.x86_64 #1 SMP Mon Jul 28 18:50:26 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

installed 

yum install kmod-staging
modprobe rts5139
(which module boot file does this need to be entered to enable on reboots?)

Here are some errors

[26509.727995] rts5139: module verification failed: signature and/or  required key missing - tainting kernel
[26509.729250] usbcore: registered new interface driver rts5139
(these appear after booting and running modprobe rts5139)

After rebooting and reinserting SD chip

no /dev/sd* entry in mount output
no /run/media folder
I do hear audio bell when I insert SD

dmesg file has lots of these
[28395.887233] mmcblk0: error -84 transferring data, sector 0, nr 8, cmd response 0x900, card status 0x0
[28395.887752] mmcblk0: error -84 transferring data, sector 1, nr 7, cmd response 0x900, card status 0x0
[28395.888207] mmcblk0: error -84 transferring data, sector 2, nr 6, cmd response 0x900, card status 0x0
[28395.888662] mmcblk0: error -84 transferring data, sector 3, nr 5, cmd response 0x900, card status 0x0
[28395.889150] mmcblk0: error -84 transferring data, sector 4, nr 4, cmd response 0x900, card status 0x0
[28395.889566] mmcblk0: error -84 transferring data, sector 5, nr 3, cmd response 0x900, card status 0x0
[28395.890194] mmcblk0: error -84 transferring data, sector 6, nr 2, cmd response 0x900, card status 0x0
[28395.890647] mmcblk0: error -84 transferring data, sector 7, nr 1, cmd response 0x900, card status 0x0
[28395.891133] mmcblk0: error -84 transferring data, sector 0, nr 8, cmd response 0x900, card status 0xb00
[28395.891135] mmcblk0: retrying using single block read

I believe this indicates the SD is not formatted.  I opened the desktop utility Disks and found the raw SD drive.  I initiated Ext4 formatting.  The formatting program did not complete successfully the first time and exited with a could not write superblock error which soon after resulted in a system crash.  

I have since the rebooted and attempted to reformat a coupld of times. The formattting program does not crash the system but returns with a error wrting to reserved sector.  See attachments for screenshots.
Comment 35 Paul Lambert 2014-08-04 17:39:03 EDT
Created attachment 924008 [details]
screenshot 1
Comment 36 Paul Lambert 2014-08-04 17:39:35 EDT
Created attachment 924009 [details]
screenshot 2
Comment 37 Raphael Groner 2014-08-13 15:51:18 EDT
FYI, the new driver in 3.16 is called rtsx_usb_sdmmc:

https://git.kernel.org/linus/1d14310abb74011dc5523baf0aee75b94070861a
Comment 38 Raphael Groner 2014-09-27 15:32:26 EDT
$ modprobe rtsx_usb

I need to do that command manually to get the card being detected with kernel 3.16.2. SUSE has fixed that for 3.16.3 and it works for me.

Lenovo Ideapad G505s
Bus 002 Device 002: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Comment 39 Paul Lambert 2014-10-15 10:29:41 EDT
Created attachment 947235 [details]
Screen shots of formatting error

I now have linux kernel 3.16.5 installed and installed the new rtsx_usb_sdmmc driver for my SDHC device.  modprobe executed with no erros.  I was able to open the Disk utility and found the mounted SDHC.  However, when I attempted to format the SDHC this operation failed for both FAT and EXT4 filesystems.  This is about the same place where the rts5139 driver failed.  I now question if the bug is actually in the driver or upstream somewhere.
Comment 40 Raphael Groner 2014-10-30 06:50:23 EDT
Fixed for me in latest kernels, see comment #38.
Comment 41 Paul Lambert 2014-11-05 11:55:57 EST
Fixed for me too in lastest kernel 3.16.6-203.fc20.x86_64 and rtsx_usb_sdmmc driver.

Note You need to log in before you can comment on or make changes to this bug.