Bug 748181 - Icons missing in desktop menu
Icons missing in desktop menu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: garcon (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker-xfce
  Show dependency treegraph
 
Reported: 2011-10-22 16:05 EDT by Christoph Wickert
Modified: 2011-10-24 23:37 EDT (History)
6 users (show)

See Also:
Fixed In Version: garcon-0.1.9-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 694897
Environment:
Last Closed: 2011-10-24 23:37:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2011-10-22 16:05:12 EDT
+++ This bug was initially created as a clone of Bug #694897 +++

Just like in F15 we have some untranslated menus and missing icons in the desktop menus. Cloning the relevant parts of bug 694897.

As this bug breaks https://fedoraproject.org/wiki/QA:Testcase_desktop_menus I propose it as F16-accepted. For Xfce it even is a blocker, however Xfce bugs by definition are only NTH instead of blockers.


--- Additional comment from massi.ergosum@gmail.com on 2011-09-20 07:48:06 EDT ---

In my F15 the Xfce menu "Preferences" is not translated (italian). Should I open a new bug?

$ rpm -q garcon
garcon-0.1.8-1.fc15.i686

--- Additional comment from kevin@scrye.com on 2011-09-20 11:12:04 EDT ---

0.1.9 is out with some new translations, we can look at updating that... I'm not sure if Preferences are one of the updated ones however, so you might want to file a bug. Upstream with Xfce might be best.

--- Additional comment from cwickert@fedoraproject.org on 2011-09-20 17:53:08 EDT ---

(In reply to comment #5)
> In my F15 the Xfce menu "Preferences" is not translated (italian). Should I
> open a new bug?

It should be translated. For the preferences /etc/xdg/menus/xfce-applications.menu defines xfce-settings.directory.

$ grep it /usr/share/desktop-directories/xfce-settings.directory
Name[it]=Impostazioni
$ rpm -q garcon
garcon-0.1.8-1.fc15.x86_64

What menu are you talking about? The one form the panel or the one you get when you right-click on the desktop? Are you sure you don't have an old/custoized version of xfce-applications.menu, say in ~/.config/menus?

--- Additional comment from massi.ergosum@gmail.com on 2011-09-21 13:55:33 EDT ---

> It should be translated.
The item is translated, but translation has no effect.

> What menu are you talking about? The one form the panel or the one you get when
> you right-click on the desktop?
Both. The one from panel is not translated. The one from right-click on deskop is not translated and has no icon.

>Are you sure you don't have an old/custoized
> version of xfce-applications.menu, say in ~/.config/menus?
$ ls .config/
autostart  geany  gthumb  gtk-2.0  Terminal  Thunar  user-dirs.dirs  user-dirs.locale  xfce4

I notice that [nl] translation has an extra new-line:
Comment[nl]=Toepassingen voor bureaubladgebruik
en voor systeeminstellingen

By removing the new-line I solved the problem: now label and icon are correct.
Please commit this bug-fix.
Thanks
Comment 1 Fedora Update System 2011-10-22 16:15:42 EDT
garcon-0.1.9-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/garcon-0.1.9-1.fc16
Comment 2 Massimiliano 2011-10-23 06:58:14 EDT
This bug is not only related to F16, but also affect F15.
Comment 3 Christoph Wickert 2011-10-23 09:01:23 EDT
*This* bug was created for F16. Because of the NTH bug process [1] we need it while I can push an update for F15 without a corresponding bug report. If you want one for F15, reopen bug 694897 or clone this one.

Please note that I will not be able to push garcon 0.1.9 to F15 until we have it in F16, otherwise we have no clean upgrade path any longer.

[1] http://fedoraproject.org/wiki/QA:SOP_nth_bug_process
Comment 4 Christoph Wickert 2011-10-23 10:04:17 EDT
Removing blocker on bug 694897. If this bug depended on it we'd have to push the F15 update first, which would then break the upgrade path.
Comment 5 Massimiliano 2011-10-23 11:42:16 EDT
It seems that bug 694897 has changed status: do you still need a new bug for F15?
Comment 6 Adam Williamson 2011-10-24 21:41:31 EDT
+1 nth, 'blocker' bug in non-blocking desktop.
Comment 7 Fedora Update System 2011-10-24 23:37:11 EDT
garcon-0.1.9-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.