Bug 74820 - traceback if networkSetup!=1 and stdin is null
traceback if networkSetup!=1 and stdin is null
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 17:59 EDT by Mike McLean
Modified: 2015-01-07 19:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 17:02:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McLean 2002-10-01 17:59:06 EDT
* up2date-3.0.7-1

0.  isatty             No
1.  retrieveSource     No
...
28. gpgKeyRing         /etc/sysconfig/rhn/up2date-keyring.gpg
29. httpProxy
30. headerCacheSize    40


Enter number of item to edit <return to exit, q to quit without saving>:
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 801, in ?
    main()
  File "/usr/sbin/up2date", line 473, in main
    text_config.main()
  File "/usr/share/rhn/up2date_client/text_config.py", line 191, in main
    value = raw_input(prompt)
EOFError: EOF when reading a line
Comment 1 Adrian Likins 2003-01-20 23:34:34 EST
ugh. 

Hmmm, guess I could detect when stdin is null and... er... do nothing?
(ie, skip the configuration)
Kind of unusual operating situation...

How are you invoking it to get this failure?
Comment 2 Mike McLean 2003-01-21 10:56:32 EST
Been a while since I filed this.... probably something like: up2date -u -f -i
--nox --nosrc

..or possibly: up2date -f -i --nox --nosrc up2date
Comment 3 Adrian Likins 2004-04-05 17:02:25 EDT
Don't really consider this a bug to worry about.
Reopen if you disagree. 

Note You need to log in before you can comment on or make changes to this bug.