Bug 748216 - util-linux requires pam >= 1.1.3-7
Summary: util-linux requires pam >= 1.1.3-7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-23 05:55 UTC by Bruce Jerrick
Modified: 2011-12-04 02:46 UTC (History)
2 users (show)

Fixed In Version: util-linux-2.20.1-2.1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-04 02:46:13 UTC
Type: ---


Attachments (Terms of Use)

Description Bruce Jerrick 2011-10-23 05:55:54 UTC
Description of problem:
The "Requires: pam" of util-linux is inadequate -- /etc/pam.d/{login,remote}
 both do an 'include' of postlogin, but /etc/pam.d/postlogin did not exist
 until pam-1.1.3-7 .
Without /etc/pam.d/postlogin, console login (e.g. on virtual tty2) will
 fail:

  Login incorrect

with an error message in /var/log/secure:

  ... login: PAM _pam_load_conf_file: unable to open /etc/pam.d/postlogin

So the requires line in th spec file should be:
  Requires: pam >= 1.1.3-7

Version-Release number of selected component (if applicable):
util-linux-2.20-1.fc16
(Note: Same problem exists in coreutils-8.12-2.fc16.i686; a separate
 report has been filed against coreutils .)

This is not likely to happen on a standard spin.  And during OS install,
/etc/pam.d/postlogin is replaced by a symlink to a generated postlogin-ac .
But by examining the following, it is apparent that util-linux really does
need postlogin, and that postlogin first appeared in pam-1.1.3-7:

  $ grep postlogin /etc/pam.d/{login,remote}
  $ rpm -q --changelog pam-1.1.4-4.fc16 | grep -B1 postlogin
  $ rpmls pam-1.1.4-4.fc16 | grep postlogin

Comment 1 Fedora Update System 2011-11-22 16:35:25 UTC
util-linux-2.20.1-2.1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/util-linux-2.20.1-2.1.fc16

Comment 2 Fedora Update System 2011-11-23 00:56:11 UTC
Package util-linux-2.20.1-2.1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing util-linux-2.20.1-2.1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16249/util-linux-2.20.1-2.1.fc16
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2011-12-04 02:46:13 UTC
util-linux-2.20.1-2.1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.