Bug 748226 - Directory menu -> Open in Terminal does not work
Summary: Directory menu -> Open in Terminal does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-panel
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F16Blocker-xfce
TreeView+ depends on / blocked
 
Reported: 2011-10-23 12:20 UTC by Christoph Wickert
Modified: 2011-10-25 03:41 UTC (History)
4 users (show)

Fixed In Version: xfce4-panel-4.8.6-2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-25 03:41:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Xfce 8018 None None None Never

Description Christoph Wickert 2011-10-23 12:20:54 UTC
Description of problem:
While I was running the desktop validation testing for Xfce (with F16 Final TC2) I noticed that the 'Open in Terminal' option of the directory menu does not work.

Version-Release number of selected component (if applicable):
xfce4-panel-4.8.6-1.fc16

How reproducible:
always

Steps to Reproduce:
1. add directory menu plugin to panel if you haven't already
2. click it, select any folder
3. click 'Open in Terminal'

Actual results:
nothing happens

Expected results:
desired folder should opened in terminal

Additional info:
When starting xfce4-panel from a console you will see the output

  'Unknown option "home liveuser"'

It seems like the panel just calls the terminal emulator and the path, while for Xfce's Terminal it should be 'terminal --working-directory <path>'. So this might actually be a configuration problem in exo.

Comment 1 Christoph Wickert 2011-10-23 13:55:57 UTC
Proposing this bug to block F16-accepted because it violates the following Release critieria [1] "All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use."

http://fedoraproject.org/wiki/Fedora_16_Final_Release_Criteria

Comment 2 Christoph Wickert 2011-10-23 14:06:31 UTC
Sorry, wrong release criteria. I meant: "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in common use"

Comment 3 Christoph Wickert 2011-10-23 16:03:01 UTC
Guess there is not much we can do, it has been reported upstream without success: https://bugzilla.xfce.org/show_bug.cgi?id=8018

Comment 4 Christoph Wickert 2011-10-23 17:54:12 UTC
Ok, fix from upstream coming your way...

Comment 5 Fedora Update System 2011-10-23 18:53:43 UTC
xfce4-panel-4.8.6-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xfce4-panel-4.8.6-2.fc16

Comment 6 Adam Williamson 2011-10-25 01:50:03 UTC
'blocker' bug in non-blocking desktop -> +1 nth (per comment #2).

Comment 7 Fedora Update System 2011-10-25 03:41:53 UTC
xfce4-panel-4.8.6-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.