This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 74826 - RFE: Tell user how many CDs will be required for installation
RFE: Tell user how many CDs will be required for installation
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
: FutureFeature
: 74813 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 18:49 EDT by Richard Lloyd
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-25 19:04:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Lloyd 2002-10-01 18:49:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
I'd only burned CD's 1 and 2 of the 3 CDs needed for RH 8.0
(it didn't help that the main UK mirror at ftp.mirror.ac.uk
decided to trash ISO images for discs 3-5 on the morning of
1st October 2002, which explains my lack of disc 3).

Imagine my horror when RH 8.0 asked for disc 3 to load ONE RPM
(kde-i18n-British-3.0.3-1 - 4,484K long) simply because I'd
selected British English as the language on a fairly standard
"Workstation" install (which included the KDE Desktop).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RH 8.0 from CD-ROM (normal install - e.g. Desktop or Workstation)
2. Select British English as the default language during the install
3. I additionally selected KDE Desktop as well as Gnome Desktop
4. Watch in horror as it asks for Disc 3 for a single RPM - arrgh !
5. Re-install RH 8.0 again but this time leave the default language
as US English
6. Sob as you see it only requires 2 CDs, not 3.
	

Actual Results:  Sure enough - an RPM less than 5MB is needed to complete the KDE
install for British English language environments - the one and only
RPM needed from Disc 3 for a typical desktop install.

Expected Results:  It really shouldn't ask for disc 3 for a single RPM for UK KDE
users - that smacks of US-centric organisation of the CD-ROMs.

Additional info:

Slightly off-topic - if you get stuck at the end of the install
with Anaconda asking for CD 3 and you don't have it, it seems
impossible to break out of the "Please insert disc 3" prompt
(escape or CTRL-ALT-Delete don't work and there's no Abort/Retry/
Cancel on the dialog - just "OK").

When you power cycle (yep, I had to do that !) after such a failed
install, GRUB has been reconfigured and dumps you into a hostile
GRUB prompt (i.e. stuff had been done to the bootloader, despite
the full RPM set not being installed). I had to boot back off
CD 1 and re-install the OS to get my multi-boot setup back - not good.
Comment 1 Michael Fulbright 2002-10-02 10:40:56 EDT
I'm changing this to a request for a message to the user telling them how many
CDs will be required before starting the installation. That way you can opt out
if you do not have them all.
Comment 2 Michael Fulbright 2002-10-02 10:42:49 EDT
*** Bug 74813 has been marked as a duplicate of this bug. ***
Comment 3 Richard Lloyd 2002-10-02 18:19:09 EDT
The calculation of which CDs will be required will be a nice enhancement,
but it still doesn't address the original report I made - namely, it
appears that only US English KDE users can get away with not needing
a third CD when installing Red Hat 8.0. I suspect every other language
needs a single RPM from Disc 3 - the appropriate i18n KDE RPM.

It's possible the UK is the #2 country in the world (after the US) in terms
of Red Hat users who have English as their first language, so I was hoping
that us poor cousins over the Atlantic might get their KDE RPM for British
English included on one of the first 2 discs (I can but dream...).

BTW, as I speak, the one and only official UK mirror of Red Hat is basically
down (and has had poor performance for months anyway, not just around RH
release dates). Maybe it's time for RH to list at least a second UK mirror
site (the US has about 40 official mirrors !) ?
Comment 4 Jeremy Katz 2003-09-25 19:04:18 EDT
Unfortunately, these packages aren't in the dependency chain (nothing requires
them) and so the dependency ordering puts them last. 

Current code at tells you which CDs you need early.

Note You need to log in before you can comment on or make changes to this bug.