This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 748277 - No default file manager set even if just one is installed
No default file manager set even if just one is installed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: exo (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F16Blocker-xfce
  Show dependency treegraph
 
Reported: 2011-10-23 17:03 EDT by Christoph Wickert
Modified: 2011-10-29 02:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: exo-0.6.2-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-29 02:31:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 8062 None None None Never

  None (edit)
Description Christoph Wickert 2011-10-23 17:03:54 EDT
Description of problem:
After installation of the Xfce spin, there is no default file manager configured in exo-preferred-applications - even though Thunar is the only one that is installed.

Version-Release number of selected component (if applicable):
exo-0.6.2-2.fc16

How reproducible:
always

Steps to Reproduce:
1. install Xfce
2. log in
3. click on a folder, e.g. from the directory menu or the desktop
  
Actual results:
A dialog to select the preferred file manager shows up and there is only one file manager to choose (Thunar)

Expected results:
Thunar should show up directly.

Additional info:
"FileManager=Thunar" is missing from /etc/xdg/xfce4/helpers.rc
Comment 1 Christoph Wickert 2011-10-23 17:05:24 EDT
I already added a workaround for this on the livecd in F15, but the proper fix is to do it in the package because it affects installed systems, too.
Comment 2 Christoph Wickert 2011-10-23 17:16:00 EDT
Reported upstream as https://bugzilla.xfce.org/show_bug.cgi?id=8062
Comment 3 Fedora Update System 2011-10-24 05:52:52 EDT
exo-0.6.2-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/exo-0.6.2-3.fc16
Comment 4 Fedora Update System 2011-10-24 23:08:14 EDT
Package exo-0.6.2-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing exo-0.6.2-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14896
then log in and leave karma (feedback).
Comment 5 Adam Williamson 2011-10-28 15:15:52 EDT
Discussed at 2011-10-28 NTH review meeting, accepted as NTH as a breakage of a 'blocker' criterion in a non-blocker desktop.
Comment 6 Fedora Update System 2011-10-29 02:31:37 EDT
exo-0.6.2-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.