Bug 74828 - rhl-applet-gui crashes when I start it
Summary: rhl-applet-gui crashes when I start it
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-01 23:01 UTC by Kenneth Rohde Christiansen
Modified: 2007-04-18 16:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-12 14:02:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kenneth Rohde Christiansen 2002-10-01 23:01:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
rhl-applet-gui crashes

(rhn-applet-gui &)
[kenneth@llephaane kenneth]$ Traceback (most recent call last):
  File "/usr/bin/rhn-applet-gui", line 41, in ?
    main()
  File "/usr/bin/rhn-applet-gui", line 37, in main
    applet = rhn_applet.rhnApplet()
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 136, in __init__
    gtk.Object.connect(self.session, "save-yourself", self.save_yourself)
TypeError: descriptor 'connect' requires a 'gobject.GObject' object but received
a 'NoneType'


Version-Release number of selected component (if applicable):


How reproducible:
Always

Additional info:

Comment 1 Ali-Reza Anghaie 2002-10-01 23:05:56 UTC
Did you "up2date --register" before trying to run the applet? In other words, 
have you setup your RHN profile yet? That might be it. Cheers, -Ali

Comment 2 Kenneth Rohde Christiansen 2002-10-02 06:59:42 UTC
I will see if I did that when I get home - it might be that. 
Still it shouldn't crash anyway

Comment 3 Daniel Veillard 2003-07-01 09:09:29 UTC
Bastien Nocera managed to duplicate the problem, current solution
is to not use the session if it's value is None, this doesn't help
explain why this occurs but avoid the applet from crashing at startup...
This will be in the next release of the RHN applet.

Daniel

Comment 4 Bastien Nocera 2003-07-04 10:16:51 UTC
gnome.program_init("rhn-applet", "2.0.0") seems to be called after some other
gtk+ functions like self.tooltip = gtk.Tooltips()

I wasn't able to reproduce the problem with the stock python install on RHL9.
Kenneth, which version of gnome-python are you using? Did you change it from the
package installed with RHL9?

Comment 5 Bastien Nocera 2003-07-04 10:55:12 UTC
The RH shipped version is:
gnome-python2-1.99.14-5

Comment 6 Daniel Veillard 2003-07-04 11:45:33 UTC
I moved the call to gnome.program_init() before the calls to gtk,
I can't tell if this may help on this but I see no negative effect in
doing so,

Daniel

Comment 7 Bastien Nocera 2003-08-11 14:46:48 UTC
Seems to be related to that:
http://bugzilla.gnome.org/show_bug.cgi?id=119592

Comment 8 Bastien Nocera 2003-08-12 14:02:44 UTC
The crash is fixed. The bug would actually only happen with a non-Red Hat
provided libgnome (http://bugzilla.gnome.org/show_bug.cgi?id=117421 wasn't fixed
until recently upstream, patch is included in the Red Hat package).

I guess this should be closed.


Note You need to log in before you can comment on or make changes to this bug.