Bug 74830 - RAM size reported incorectly in guname
RAM size reported incorectly in guname
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnome-utils (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 19:16 EDT by adam bowns
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-10 18:53:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam bowns 2002-10-01 19:16:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020924

Description of problem:
In the memory information tab of guname the total memory size is reported
incorrectly. It reports 904324k when it should report 1048576k (1GB). I dont
believe there to be any bios problem causing this because windows XP reports the
system memory to be 1gb as it should.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot computer into gnome
2.open guname (system information)
3.click detailed information
4.open memory information tab

Actual Results:  the reported value for total memory is 904324k 	

Expected Results:  the reported value for total memory is 1048576k (1GB)

Additional info:

the bug has occured when using both your default shipping kernel, your updated
kernel and my own 2.4.19 custom kernel, so I don't think its a kernel problem
either, but I'll let you be the judge of that.

More hardware info if u require it: -
motherboard: asus a7v333
chipset: VIA KT333
ram: 2 x 512 mb samsung pc2700 ddr (not overclocked)
Comment 1 Havoc Pennington 2002-11-05 13:22:37 EST
What RAM do you have if you look at the file /proc/meminfo?

I think this may just be that guname reports memory available to userspace 
(subtracts memory used by the kernel), or something like that. 
If guname shows the same as /proc/meminfo I think it's not a bug, just 
the way linux reports available ram.

Note You need to log in before you can comment on or make changes to this bug.