Bug 748303 - Entitlement key isn't removed after unsubscribing
Entitlement key isn't removed after unsubscribing
Status: CLOSED DUPLICATE of bug 708362
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-10-23 23:33 EDT by yu zheng
Modified: 2015-05-14 11:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 07:57:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yu zheng 2011-10-23 23:33:17 EDT
Description of problem:
The entitlement key isn't removed from /etc/pki/entitlement/ after unsubscribing.

Version-Release number of selected component (if applicable):
subscription-manager-0.96.16-1.el6.x86_64
python-rhsm-0.96.15-1.el6.noarch
candlepin (stage env)

How reproducible:
Always

Steps to Reproduce:
1.register to stage using stage_test_12/redhat
2.list available subscriptions
[root@unused-2-235 ~]# subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+

ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f98233137a9701331d92a4301203
Quantity:          	100                      
Multi-Entitlement: 	No                       
Expires:           	10/18/2012               
MachineType:       	physical                 

ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f98233137a9701331d92a446120f
Quantity:          	400                      
Multi-Entitlement: 	No                       
Expires:           	10/18/2012               
MachineType:       	virtual
3.subscribe 
[root@unused-2-235 ~]# subscription-manager subscribe --pool=8a99f98233137a9701331d92a4301203
Successfully subscribed the system to Pool 8a99f98233137a9701331d92a4301203
4.unsubscribe
[root@unused-2-235 ~]# subscription-manager unsubscribe --all
[root@unused-2-235 ~]# ls /etc/pki/entitlement/
5265169466923923161-key.pem
  
Actual results:
The entitlement key is still in /etc/pki/entitlement.

Expected results:
All entitlement certs and keys should be removed after unsubcribing all consumed subscriptions.

Additional info:
n/a
Comment 1 Bryan Kearney 2011-10-24 07:57:27 EDT

*** This bug has been marked as a duplicate of bug 708362 ***

Note You need to log in before you can comment on or make changes to this bug.