Bug 748314 - Group Memberships are not respected
Group Memberships are not respected
Status: CLOSED DUPLICATE of bug 745675
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-24 01:31 EDT by Justin Brown
Modified: 2011-10-24 13:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 13:09:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Justin Brown 2011-10-24 01:31:01 EDT
Description of problem:
No matter what I do, the system will not respect my group memberships.

During installation, I made the primary account part of the administrators group (wheel). After installation, I get error messages that I am not in the sudoers file. 

Check /etc/group, I find
wheel:x:10:justin

However, the system does not recognize this
[root@thebe ~]# groups justin
justin : justin

I have repeatedly tried `usermod -aG wheel justin` to no avail.

Version-Release number of selected component (if applicable):
Name        : coreutils
Arch        : x86_64
Version     : 8.12
Release     : 2.fc16
Size        : 13 M

How reproducible:
Rebooted several times and have run updates

Steps to Reproduce:
1. Install F16 w/ Btrfs for / (not sure if Btrfs is causing part of the problem)
2. Try to sudo
3. Observe that group memberships are not respected
  
Actual results:
membership in /etc/group exists, but `groups` doesn't reflect it.

Expected results:
entries in /etc/group should match the system groups.

Additional info:
Comment 1 Ondrej Vasik 2011-10-24 01:53:09 EDT
Thanks for report - however likely a duplicate of glibc bug #745675 ... could you please check your glibc version?
Comment 2 Justin Brown 2011-10-24 13:09:04 EDT
Ondrej,

Thanks for looking at this.

Yes, this is a duplicate of #745675. 

yum update fixed it.

Regards,

*** This bug has been marked as a duplicate of bug 745675 ***

Note You need to log in before you can comment on or make changes to this bug.