Bug 74833 - nautilus freezes when opening a particular folder
nautilus freezes when opening a particular folder
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-01 19:38 EDT by Don Hardaway
Modified: 2015-01-07 19:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-17 05:26:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gzip file (12.93 KB, application/octet-stream)
2002-10-02 13:49 EDT, Don Hardaway
no flags Details
i think this one is correct (116.44 KB, application/octet-stream)
2002-10-02 15:53 EDT, Don Hardaway
no flags Details
here is the trace file again following your instructions exactly (102.06 KB, application/octet-stream)
2002-10-02 16:26 EDT, Don Hardaway
no flags Details
here is a copy of my terminal window with commands used and outputs (715 bytes, text/plain)
2002-10-02 16:28 EDT, Don Hardaway
no flags Details
here is the output file after using -tt option (146.93 KB, application/octet-stream)
2002-10-02 16:47 EDT, Don Hardaway
no flags Details
backtrace output (1.82 KB, text/plain)
2002-10-02 17:26 EDT, Don Hardaway
no flags Details
here is the first of 3 (275.86 KB, image/jpeg)
2002-10-03 08:11 EDT, Don Hardaway
no flags Details
here is the second of 3 (771.11 KB, image/jpeg)
2002-10-03 08:12 EDT, Don Hardaway
no flags Details
here is the last of 3 (264.59 KB, image/jpeg)
2002-10-03 08:13 EDT, Don Hardaway
no flags Details

  None (edit)
Description Don Hardaway 2002-10-01 19:38:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When I open one of two folder that were copied over from a windows ntfs
partition nautilus freezes and the scroll bar does not work and clicking on any
files does not highlight them or open them. All of the files in this directory
can be accessed though from applications that open them. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.click the folder open
2.click any file or try to use the scroll bar.
3.
	

Actual Results:  everthing in the window is frozen.

Expected Results:  folder and files would be clickable.

Additional info:
Comment 1 Havoc Pennington 2002-10-01 22:22:52 EDT
We'll need an archive of this folder, or some other way to reproduce the bug.
Or you can maybe try stracing nautilus or otherwise debugging it and attach any
info you can collect.
Comment 2 Don Hardaway 2002-10-02 10:24:03 EDT
The directory is too big to send and has several thousand files. If you instruct
me I will go through the debug process to the extent I can.
Comment 3 Havoc Pennington 2002-10-02 11:05:55 EDT
Step 1 is be sure nautilus is locked up rather than just slow. i.e. wait a few
minutes. (Just checking, you probably already did this.)

Then we need to get nautilus out of your session so we can start a copy of it in
the terminal. Run gnome-session-properties, select nautilus, click remove and
apply. When you're done debugging you'll want to start nautilus again, and 
gnome-session-save, to get nautilus back in your session. Or delete
~/.gnome2/session to revert to the default session.

Once nautilus is gone, start it in a terminal under strace as follows:

 strace -o /tmp/output -f nautilus

Do what you need to do to lock up nautilus. Then Ctrl+c the nautilus in the
terminal, type "gzip /tmp/output", and make /tmp/output.gz available somewhere
we can get it (attaching it to this bug report would be fine).

I don't know if that will turn out to be useful, but it might give us some leads.

Thanks!
Comment 4 Don Hardaway 2002-10-02 11:18:02 EDT
Here is what i got when i typed the first command. At the time of typing this
there are no folders open, just the desktop.

[root@dhcppc2 root]# gnome-session-properties

(gnome-session-properties:1450): GnomeUI-WARNING **: While connecting to session
 manager:
Authentication Rejected, reason : None of the authentication protocols specified
 are supported and host-based authentication failed.

** (gnome-session-properties:1450): CRITICAL **: file gsm-protocol.c: line 636 (
gsm_protocol_new): assertion `GNOME_CLIENT_CONNECTED (gnome_client)' failed

** (gnome-session-properties:1450): WARNING **: Could not connect to gnome-sessi
on.
Comment 5 Havoc Pennington 2002-10-02 12:24:58 EDT
If you're logged in as a user, you need to type these commands as that user, not
as root.
Comment 6 Don Hardaway 2002-10-02 13:49:33 EDT
Created attachment 78124 [details]
gzip file
Comment 7 Havoc Pennington 2002-10-02 15:06:35 EDT
Did you browse to the problematic folder while the strace was in progress?
Or are you sure the old nautilus process was gone?
It looks like the nautilus process exited very quickly without doing much, 
as if perhaps it just opened a new window in an existing nautilus instead of
getting a new nautilus in the strace.
Comment 8 Don Hardaway 2002-10-02 15:27:15 EDT
I am not sure I am following the instructions the way you want. Please enumerate
step by step the procedures starting from a fresh login.
Comment 9 Don Hardaway 2002-10-02 15:53:07 EDT
Created attachment 78164 [details]
i think this one is correct
Comment 10 Havoc Pennington 2002-10-02 16:00:33 EDT
1. Open a terminal
2. type gnome-session-properties
3. in gnome-session-properties choose Current Session tab
4. select nautilus from the list
5. click the Remove button, click Apply button, close dialog; 
   nautilus should now have exited, so you have no desktop icons
   or file manager windows
6. run "strace -o /tmp/output -f nautilus" in the terminal
7. nautilus should have started up; follow the steps to reproduce this bug 
   report, so nautilus is locked up
8. return to the terminal and type Ctrl+C to exit nautilus
9. gzip /tmp/output and attach /tmp/output.gz to this bug report
10.delete ~/.gnome2/session to restore the default session, so you 
   have nautilus again in the future.
Comment 11 Havoc Pennington 2002-10-02 16:21:21 EDT
I'm not sure what all the SIGRTMIN stuff is about... 

It looks like nautilus is basically busy reading files when you ctrl+c it, 
as if it might finish someday. If you add the "-tt" option to the strace command
line it might help show where there's a long pause (where a hang may occur).

Could also try "tail -f /tmp/output" from another terminal while nautilus is
hanging, and see if anything is being printed out.
Comment 12 Don Hardaway 2002-10-02 16:26:47 EDT
Created attachment 78225 [details]
here is the trace file again following your instructions exactly
Comment 13 Don Hardaway 2002-10-02 16:28:09 EDT
Created attachment 78226 [details]
here is a copy of my terminal window with commands used and outputs
Comment 14 Don Hardaway 2002-10-02 16:48:00 EDT
Created attachment 78244 [details]
here is the output file after using -tt option
Comment 15 Havoc Pennington 2002-10-02 16:52:57 EDT
Wild guess, can you see if the problem is "/home/hardaway/Desktop/Java Skyline
Learn JDBC_files/tss_bigblue.gif" (for example if you move that file elsewhere
and browse to the elsewhere in nautilus, will nautilus crash?)
Comment 16 Don Hardaway 2002-10-02 17:05:33 EDT
The problem is once i open the folder with the files, all of the icons of other
folders and files appear BUT i can not click into any of the folders showing or
click any file showing. If i put the cursor over a file it will not highlight
nor  can i move it or anything.  The only way for me to access the files in this
problem folder is to open an application and then browse to the folder and
select a file to open.

Just an idea to talk over with management!
Would it help if I flew to rh and spend a couple of days letting the engineers
work with my laptop to get this problem and some X problems debugged. It might
be a way of really making some fast and needed improvements since the desktop is
becoming a target and many companies i know of use dell laptops.
Comment 17 Havoc Pennington 2002-10-02 17:15:04 EDT
I think flying here would be overkill. ;-) Our X developer works from home in
Canada anyway. I don't think this nautilus issue is at all specific to your
hardware though.

Can you try another thing; in your terminal, without nautilus running, do:

gdb nautilus
(gdb) run
[get nautilus to crash]
(gdb) backtrace

and copy in the backtrace output?

Comment 18 Don Hardaway 2002-10-02 17:26:58 EDT
Created attachment 78264 [details]
backtrace output
Comment 19 Havoc Pennington 2002-10-02 18:06:11 EDT
Looks like it may be crashing on a strange jpeg file. How many jpegs are in that
folder? any chance we could get a copy of those jpegs? Or see if moving all the
jpegs somewhere and viewing the new location also crashes?
Comment 20 Don Hardaway 2002-10-02 18:18:04 EDT
There are a bunch a jpegs. if you know of a particular one the is causing the
problem i can access it from the terminal and send it to you.  I guess if i had
to, i could (using a terminal window) mv all of the jpegs out of that directory.
Let me know what you want me to do.
Comment 21 Havoc Pennington 2002-10-02 19:42:53 EDT
You could try just copying them to another directory with cp, to avoid messing
up your directory, perhaps.
Comment 22 Don Hardaway 2002-10-02 22:07:14 EDT
I have found the problem. I moved 4 jpgs that were in the folder and now the
folder and the subfolders with their jpgs work fine.
Comment 23 Havoc Pennington 2002-10-02 22:37:35 EDT
Any chance we could get a copy of those jpegs in order to make nautilus (or
perhaps it's libjpeg) work with them?
Comment 24 Don Hardaway 2002-10-03 08:11:33 EDT
Created attachment 78324 [details]
here is the first of 3
Comment 25 Don Hardaway 2002-10-03 08:12:34 EDT
Created attachment 78325 [details]
here is the second of 3
Comment 26 Don Hardaway 2002-10-03 08:13:27 EDT
Created attachment 78326 [details]
here is the last of 3
Comment 27 Don Hardaway 2002-10-03 08:57:13 EDT
Now, for problem #2. I don't know if this is nautilus or something in smb. I
open a nautilus window and put in smb://userid@pcname/directory. I can see my
files on the windoz2000 pc just fine. I start coping files from my laptop
(rh8.0) to the windoz2000pc and everything is coping fine and at some point it
stops and generates a error.  Please advise on how to trap the error and who
should be handling it.
Comment 28 Havoc Pennington 2002-10-03 09:43:24 EDT
Thanks for the images. Can you file problem #2 as a new bug report, for tracking?
It's much easier to deal with that way. (also, please include the exact text of
the error you mention.)
Comment 29 Alexander Larsson 2002-10-08 08:58:52 EDT
The problem was that those jpegs were in the CMYK colorspace.
I've fixed this in libgnomeui HEAD, so nautilus HEAD can now thumbnail those images.
Comment 30 Don Hardaway 2002-10-08 10:00:45 EDT
Way to go!  You are the only one out of the 4 bug reports filed that is
responsive. mharris of X does not respond and the evolution guy is slow as a
turtle, and now the smb problem that you transfered, i have not heard from. How
in the world is rh going to displace windoz on the desktop unless these
technical issues get a better response from all of the engineering dept. 
Anyway, pass the word to the management. i am determined to help rh take over
the desktop spreading the word with my corporate contacts and university ones
but something has to change with the quality of response.  I applaud you on this
debug experience. I wish the others were as good.

When can I get an update so that those jpegs will display properly?
Comment 31 Havoc Pennington 2002-10-08 12:11:53 EDT
Just to clarify expectations for bugzilla:
Please note that bugzilla is an engineering task tracker, not a support forum.
Support with guaranteed response time is provided via separate channels. When
you need (or expect) updates, or a particular response time, you need to go
through support channels, not bugzilla. Bugzilla is a way to say "FYI" to the
developers
but not a way to request a supported fix in a particular timeframe.
Comment 32 Don Hardaway 2002-10-08 12:24:06 EDT
Thanks for clearing that up. I had thought bugzilla was sort of a partnering
between people that were willing to invest time and energy to help rh build a
better product to compete with windoz.  Within the concept of partnering, I
guess I expected it to be a two way street.  After all, if you want to make
suggestions for improvements and not receive any cooperation back, one can
always do that with proprietary software like (Sun, MS).
Comment 33 Havoc Pennington 2002-10-08 14:02:40 EDT
Don't get me wrong, it _is_ a way of communicating with developers 
and we do appreciate working with people via bugzilla. All I'm saying is 
that the equivalent of Windows technical support and issue resolution 
is to contact our support department. Bugzilla is an extra feature on top 
of that that gives you some insight into internal development and helps
developers work with users. But it isn't staffed or organized for guaranteed
response time or the like.

Think of it as an informal conversation with the developers.
Comment 34 Alexander Larsson 2003-01-17 05:26:36 EST
The fixed code is now in rawhide.

Note You need to log in before you can comment on or make changes to this bug.