Bug 748398 - Firefox 32bit core dumps on current Fedora 16 Alpha
Firefox 32bit core dumps on current Fedora 16 Alpha
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
16
ppc64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Betappc
  Show dependency treegraph
 
Reported: 2011-10-24 07:06 EDT by Phil Knirsch
Modified: 2015-03-04 20:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-10 12:52:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Phil Knirsch 2011-10-24 07:06:02 EDT
Description of problem:

Trying to start a 32bit firefox using the current Fedora 16 Alpha for PPC64 results in the following error:

[root@power02 ~]# firefox
###!!! ABORT: X_GrabButton: BadLength (poly request too large or internal Xlib length error); 416 requests ago: file /builddir/build/BUILD/xulrunner-6.0.2/mozilla-release/toolkit/xre/nsX11ErrorHandler.cpp, line 199
###!!! ABORT: X_GrabButton: BadLength (poly request too large or internal Xlib length error); 416 requests ago: file /builddir/build/BUILD/xulrunner-6.0.2/mozilla-release/toolkit/xre/nsX11ErrorHandler.cpp, line 199
Aborted (core dumped)


Version-Release number of selected component (if applicable):

[root@power02 ~]# rpm -q kernel glibc libX11 firefox
kernel-3.1.0-0.rc8.git0.0.fc16.kh.ppc64
glibc-2.14.90-10.ppc64
glibc-2.14.90-10.ppc
libX11-1.4.3-1.fc16.ppc64
libX11-1.4.3-1.fc16.ppc
firefox-6.0.2-1.fc16.ppc


How reproducible:

Always

Steps to Reproduce:
1. Install latest Fedora 16 Alpha for PPC64 from http://ppc.koji.fedoraproject.org/scratch/karsten/iso/
2. Install 32 bit firefox 
3. Watch the error
  
Actual results:

See above

Expected results:

firefox not core duming and working

Additional info:

The interesting part is that the actual firefox window with all buttons, menu, URL line and everything is visible for a very brief moment after which it disappears and you get the above mentioned error message.
Comment 1 Phil Knirsch 2011-11-07 11:43:36 EST
One more note here:

Josh Boyer verified that it works perfectly on a local machine, my tests were done from a RHEL-6.1 x86_64 machine via ssh -X to the PPC box and thats when i got the error.

Thanks & regards, Phil
Comment 2 Phil Knirsch 2011-11-10 12:52:09 EST
OK, seems that something with my local x server seems to be fubar, it works nicely for others over SSH.

Closing as notabug then and i'll investigate where my local x server issue comes from.

Thanks & regards, Phil

Note You need to log in before you can comment on or make changes to this bug.