Bug 74842 - Sound Not Functional
Summary: Sound Not Functional
Status: CLOSED DUPLICATE of bug 74843
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tuxracer (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-02 03:43 UTC by Jack Aboutboul
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 03:14:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jack Aboutboul 2002-10-02 03:43:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
In 8.0 tux racer seems to have sound not enabled. This was consensus by many,
many users in #redhat. eSound is running. Provided strace. I'm toot tired to
figure this one out now.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install 8.0
2.make sure you pick tuxracer
3.run it!
	

Actual Results:  game played with no sound

Expected Results:  game should have sound as null did on same machine

Additional info:

strace output available at http://thumbingmyway.com/tuxtrace

Comment 1 tpoindex 2002-10-10 03:14:23 UTC
same here - tried all combinations of SDL_AUDIODRIVER={dsp,esd,artsc,dma}.  
tuxracer had sound functioning in 7.3. 

other games using SDL (e.g. chromium)
have sound, so it's not a problem with sound driver or SDL.

'ldd /usr/bin/tuxracer' seems to indicate that no sound was compiled in
(vis-a-vis 7.3 /usr/bin/tuxracer)  ldd on 7.3 tuxracer shows dependencies on 
sound related libs, none of which show as dependencies for the 8.0 version:
        libartsc.so.0 => /usr/lib/libartsc.so.0 (0x402d6000)
        libesd.so.0 => /usr/lib/libesd.so.0 (0x402dd000)
        libaudiofile.so.0 => /usr/lib/libaudiofile.so.0 (0x402e4000)
        libSDL_mixer-1.2.so.0 => /usr/lib/libSDL_mixer-1.2.so.0 (0x40302000)
        libvorbisfile.so.0 => /usr/lib/libvorbisfile.so.0 (0x406a2000)
        libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x406a8000)






Comment 2 Ngo Than 2002-10-14 15:24:38 UTC

*** This bug has been marked as a duplicate of 74843 ***


Note You need to log in before you can comment on or make changes to this bug.