Bug 74844 - Installer gives runtime error right after starting up
Installer gives runtime error right after starting up
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 00:22 EDT by Scott Dowdle
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-02 00:22:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2002-10-02 00:22:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
Good CD1 (did a verify on it and it passed... and it installs great on other
machines) that crashes after the "running anaconda (the install program)"
message (or whatever the exact wording of it is) with a runtime error. See
"Additional Information" section for details.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot install CD
2.Hit enter (default install) or try "linux text", "linux noprobe" and "linux
lowres"
3.anaconda runs and crashes with runtime error (see Additional Information
section for details)
	

Actual Results:  anaconda runs and crases with runtime error (see Additional
Information section for details)

Expected Results:  Install program should progress normally and allow me to install.

Additional info:

I get the following Python runtime error messasage from Python:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 384 in ?
    from installclass import DefaultInstall
  File "/usr/lib/anaconda/installclass.py", line 27 in ?
    from constants import BETANAG
ImportError: cannot import name BETANAG
install exited abnormally
(etc) reboot (etc)

Please note, this is the real RHL 8.0 and not a beta or a leaked release
canidate... the MD5checksums match up to those for RHL 8.0.  Oddly enough, I
installed all three betas for 8 (including Null) and never ran into this problem.

FIC motherboard running an AMD Duron with VIA chipset (can get more sprecifics
if requested) and a Voodoo 3 PCI (not AGP) video card.  I'm willing to try
various command line options to the installer but I've already tried all common
methods (mentioned in the install screens) and it runtime errors regardless.
Comment 1 Scott Dowdle 2002-10-02 02:33:07 EDT
Ok, more to the story... to clarify... I DID DO a media check on CD 1 and it
passed.  Upon futher examination, an alternate console (either ALT-F3 or ALT-F4,
I don't remember which) showed <3> decompression error (or something like that)
over and over... so for some reason my brand new Philips CDRW2400 services
burner couldn't read the disk.  I tried two other disks (both PASSed the media
check) and they did the same thing.

To get the blasted machine installed... I decided to do a network install... by
taking the first CD1 (as well as CD2 and CD3) and created an install server on
another machine in the house.  Then I used the same CD1 to boot from and used
the "linux askmethod" boot prompt option and did an NFS install.  Since it
didn't read much of the CD, I was able to install.

I guess I really am not looking for resolution to this problem because it
appears beyond the control of the anaconda installer...

BUT it is good to note that just because a CD passes the media check (yes, even
on the target install machine), that doesn't mean that the install machine will
be able to successfully read the CD for an install.

Note You need to log in before you can comment on or make changes to this bug.