Bug 74845 - gcc crashed while compiling 2.4.19 kernel
gcc crashed while compiling 2.4.19 kernel
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 00:37 EDT by James Haydon
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 18:12:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Haydon 2002-10-02 00:37:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
Compiler reported a Segmentation fault while compiling 2.4.19 with an xfs patch.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.make xconfig
2.make dep
3.make bzImage
	

Actual Results:  gcc -D__KERNEL__ -I/usr/src/linux-2.4.19/include  -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=athlon   
-nostdinc -I /usr/lib/gcc-lib/i386-redhat-linux/3.2/include
-DKBUILD_BASENAME=ip_options  -c -o ip_options.o ip_options.c
ip_options.c: In function `ip_options_fragment':
ip_options.c:227: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [ip_options.o] Error 1
make[3]: Leaving directory `/usr/src/linux-2.4.19/net/ipv4'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.19/net/ipv4'
make[1]: *** [_subdir_ipv4] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.19/net'
make: *** [_dir_net] Error 2


Expected Results:  I have a new kernel. Sometimes, I don't know how to answer this.

Additional info:
Comment 1 James Haydon 2002-10-02 01:19:24 EDT
It seems to a memory leak, because I tryed it 4 more time and gcc failed. I
reboot ed the machine and gcc compiled the kernel with no problem.
Comment 2 David S. de Lis 2002-10-12 22:17:33 EDT
I got the same error when compiling xine-lib-0.9.13... Before the segmentation
fault I get these funny error messages (also happened compiling kinkatta, which
is an instant messaging client for KDE):

gcc: /usr/var/tmp/tom-1.1.1/C/.libs/libC.so: No such file or directory
gcc: /usr/var/tmp/tom-1.1.1/tom/.libs/libtom.so: No such file or directory
gcc: /usr/var/tmp/tom-1.1.1/trt/.libs/libtrt.so: No such file or directory

I launched another gnome-console to reproduce the error, while I kept the screen
in the first one, but this time it compiled OK, so it indeed looks like some
pointers may be dancing a fandango on core in some part og gcc... (This happened
with gcc 3.2 as shipped in RedHat 8.0)
Comment 3 Alan Cox 2002-12-15 18:12:46 EST
Thats a classic report that looks like bad memory. It may also be stack bugs in
the older xfs patches. Reopen if you can recreate it with a RH shipped kernel
and if your PC passes memtest86

Note You need to log in before you can comment on or make changes to this bug.