Bug 74852 - It's very hard to access existing files/directories with ISO-8859-1 characters in the name
Summary: It's very hard to access existing files/directories with ISO-8859-1 character...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: basesystem (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-02 08:32 UTC by Need Real Name
Modified: 2014-03-17 02:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 22:56:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-02 08:32:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311

Description of problem:
Due to the switch to the UTF-8 locales existing files/directories with names
that contain UTF-8 characters are almost impossible to access.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Have to directories named M|lleimer (trashbin), one with the "|" in UTF-8 and
one with the "|" in ISO-8859-1
2. Try to manipulate the directories (rm, mv, cd)
3. Have fun
	

Actual Results:  It's next to impossible to access the old file/directory.

Expected Results:  It should be possible to access old directories even under
the new Locale.

Additional info:

This bug might prevent people from being able to access their data.

Comment 1 Bill Nottingham 2005-01-21 22:56:08 UTC
UTF-8 is not something that's going to be disabled. Sorry about this
report getting lost in the shuffle.

If it's a msdos/vfat/iso9660 filesystem, you probably want to check
the codepage it's mounted with. If it's ext2/ext3, file a bug with
coreutils if the normal tools don't work.


Note You need to log in before you can comment on or make changes to this bug.