Bug 7486 - The hostname given with the -h option disappears at renewal time
The hostname given with the -h option disappears at renewal time
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
: 4873 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-01 12:24 EST by regis
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 10:52:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description regis 1999-12-01 12:24:52 EST
At boot time, I give the name of my Red Hat box to the DHCP server with the
-h option. At renewal time, it seems that pump does not give the name of
the box again. So, the linux box appears as "null" in the DHCP monitoring
program, after the first renewal time.

Moreover, after the first renewal time, "pump -s" does not show the domain
name and the gateway address anymore.

Thanks for your help.
Comment 1 Erik Troan 1999-12-01 12:40:59 EST
I have a new version of pump which fixes these. Could I email you the
source tarball?

------- Email Received From  =?iso-8859-1?Q?ETOURMY_R=E9gis?= <ETOURMY.Regis@eulersff.com> 12/02/99 03:46 -------
Comment 2 Michael Hipp 2000-01-18 16:13:59 EST
I have this problem also.  My DHCP is being served from a Cisco router.  Works
under Win98.  Under RH 6.1, it hangs every time starting eth0.  Eventually
tracked it down to pump.  Changed my setup to a static IP address (and gateway,
etc.) and it works fine now.  But I need to use DHCP.  Any help?
Comment 3 Erik Troan 2000-02-03 10:52:59 EST
*** Bug 4873 has been marked as a duplicate of this bug. ***Fixed in pump-0.7.6, which will be on ftp://people.redhat.com/ewt later this
afternoon.

Note You need to log in before you can comment on or make changes to this bug.