Bug 748644 - llvm-devel 2.8 lacks llvm/Support/Signals.h
llvm-devel 2.8 lacks llvm/Support/Signals.h
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
15
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-24 20:42 EDT by postmodern
Modified: 2011-10-27 19:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-27 19:25:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description postmodern 2011-10-24 20:42:59 EDT
Description of problem:

I was attempting to compile ccons (https://code.google.com/p/ccons/), and noticed that it requires llvm/Support/Signals.h. This file should be included in llvm-devel, but for some reason is missing.


Version-Release number of selected component (if applicable): 2.8


How reproducible:


Steps to Reproduce:
1. yum install llvm-devel
2. ls /usr/include/llvm/Support/Signals.h
3.
  
Actual results: missing


Expected results: exists


Additional info:
Comment 1 jhackworth 2011-10-27 17:54:24 EDT
I am running into the same problem on a different platform.

It looks like System/Signals.h was renamed to Support/Signals.h in change 2.8 -> 2.9, which ccons is using now. (so bug might be invalid).

http://llvm.org/svn/llvm-project/llvm/tags/RELEASE_28/include/llvm/Support/
http://llvm.org/svn/llvm-project/llvm/tags/RELEASE_29/final/include/llvm/Support/

You may have to try an older version of ccons, try porting it back to 2.8, or upgrade llvm.
Comment 2 postmodern 2011-10-27 19:24:27 EDT
Ah ha. I've submitted an issue to ccons about the different paths in 2.8 vs. 2.9.

https://code.google.com/p/ccons/issues/detail?id=17&thanks=17&ts=1319757785
Comment 3 postmodern 2011-10-27 19:25:12 EDT
Ah ha. I've submitted an issue to ccons about the different paths in 2.8 vs. 2.9.

https://code.google.com/p/ccons/issues/detail?id=17&thanks=17&ts=1319757785

Note You need to log in before you can comment on or make changes to this bug.