Bug 748785 - yumex has crashes when searching with non-Latin characters
Summary: yumex has crashes when searching with non-Latin characters
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-25 11:26 UTC by Alexei Panov
Modified: 2011-11-08 18:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-31 11:27:06 UTC


Attachments (Terms of Use)
It works for me in F16 (47.85 KB, image/png)
2011-10-30 17:46 UTC, Tim Lauridsen
no flags Details

Description Alexei Panov 2011-10-25 11:26:56 UTC
Description of problem:
I've open yumex and try to find with non-Latin characters in search field.
yumex crash with:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1361, in dispatcher
    self.parse_command(args[0], args[1:])
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1321, in parse_command
    self.search(args)
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1068, in search
    for found in self.searchGenerator(filters, keys, showdups=True, keys=True):
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2482, in searchGenerator
    tmpres = self.searchPackageTags(real_crit_lower)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2550, in searchPackageTags
    res = self.pkgtags.search_tags(c)
  File "/usr/lib/python2.7/site-packages/yum/pkgtag_db.py", line 135, in search_tags
    for (name, taglist) in ptd.search_tags(tagname).items():
  File "/usr/lib/python2.7/site-packages/yum/pkgtag_db.py", line 79, in search_tags
    rows = self._sql_exec(query, (tag,))
  File "/usr/lib/python2.7/site-packages/yum/pkgtag_db.py", line 39, in newFunc
    raise PkgTagsError, unicode(e)
PkgTagsError: You must not use 8-bit bytestrings unless you use a text_factory that can interpret 8-bit bytestrings (like text_factory = str). It is highly recommended that you instead just switch your application to Unicode strings.

Version-Release number of selected component (if applicable):
yumex-3.0.4-1.fc15

How reproducible:
Anytime

Steps to Reproduce:
1. run yumex as LANG=ru_RU.UTF-8 yumex
2. in search field typing non-Latin characters (as Russian example: Пакет)
3. Enter
  
Actual results:
crash of yumex

Expected results:
yumex nothing to find, but don't fail

Additional info:
This bug is reproduced in Fedora 16 too.

Comment 1 Tim Lauridsen 2011-10-25 13:34:19 UTC
does the following work:

LANG=ru_RU.UTF-8 yum search "Пакет"

Comment 2 Alexei Panov 2011-10-25 13:36:08 UTC
Yes, it works.

Comment 3 Tim Lauridsen 2011-10-30 17:46:00 UTC
Created attachment 530844 [details]
It works for me in F16

Comment 4 Alexei Panov 2011-10-30 18:02:12 UTC
Yes for me works too in Fedora 16.
But five days ago was not working. Very strange.
Thanks.

Comment 5 Tim Lauridsen 2011-10-31 10:10:06 UTC
(In reply to comment #4)
> Yes for me works too in Fedora 16.
> But five days ago was not working. Very strange.
> Thanks.

Have you check if yum has been updated recently

yum history list yum

Comment 6 Alexei Panov 2011-10-31 10:19:39 UTC
Yes Tim, yum was updated at 27 oct.

ID     | Login user               | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
   113 | System <unset>           | 2011-09-27 16:03 | Update         |   17   
   101 | root <root>              | 2011-09-26 14:24 | D, I, O, U     | 1221 EE
     3 | Alexei <alex>            | 2011-09-10 16:49 | I, U           |  141 EE
     1 | 1706                     | 2011-08-08 21:22 | Install        | 1140   
history list

Comment 7 Tim Lauridsen 2011-10-31 11:27:06 UTC
Look like that have solved the issue :)

Comment 8 John Wehin 2011-10-31 11:44:27 UTC
not work for me in F14 and F15

Comment 9 Tim Lauridsen 2011-11-01 06:25:52 UTC
(In reply to comment #8)
> not work for me in F14 and F15

The yum update fixing the issues has properly not been released in F14 & F15 yet

Comment 10 John Wehin 2011-11-08 18:07:52 UTC
yumex seems broken again in Fedora 16

Comment 11 Alexei Panov 2011-11-08 18:12:29 UTC
Yes, Tim. It's broke again in Fedora 16. I can confirm it.


Note You need to log in before you can comment on or make changes to this bug.