Bug 748811 - Shutting down the installation: Assertion 'bus' failed at src/systemctl.c:1654, function start_special().
Shutting down the installation: Assertion 'bus' failed at src/systemctl.c:165...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
s390x Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2011-10-25 08:51 EDT by Jan Stodola
Modified: 2012-10-22 11:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 11:17:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ps auxf (6.88 KB, text/plain)
2011-10-31 05:43 EDT, Jan Stodola
no flags Details

  None (edit)
Description Jan Stodola 2011-10-25 08:51:35 EDT
Description of problem:
At the end of installation on s390x, anaconda doesn't shutdown system.
After clicking on Shutdown button, following message is displayed on terminal:

Assertion 'bus' failed at src/systemctl.c:1654, function start_special(). Aborting.
Connection to 10.16.105.198 closed.

But the system is still running - it means I can login via ssh.


Version-Release number of selected component (if applicable):
anaconda-16.22-1.fc16.dh.1
systemd-36-3.fc16.s390x

How reproducible:
always

Steps to Reproduce:
1. proceed through the installation process
2. at the finish screen, click on "Shutdown"
  
Actual results:
System doesn't shut down, assertion message on terminal

Expected results:
system should shut down (or reboot)
Comment 1 Chris Lumens 2011-10-29 11:20:44 EDT
Is systemd running?
Comment 2 Jan Stodola 2011-10-31 05:43:13 EDT
Created attachment 530932 [details]
ps auxf

Attaching list of processes before clicking on "Shutdown" button - systemd is not running.
Comment 3 Chris Lumens 2011-11-02 09:36:47 EDT
This is because anaconda's using systemd on all platforms now except s390, where we're still using our own init.  However, we are universally trying to use systemctl to reboot the machine which of course won't work on a system where systemd isn't running.

A short term fix would be to modify the bottom of the anaconda script to do something different on s390.  I'd be happy to review patches that do that.  The real fix would be to ditch linuxrc.s390 and use loader and systemd like every other platform.
Comment 4 Chris Lumens 2012-10-22 10:59:32 EDT
Are you still seeing this with F18?  There's no more linuxrc.s390, and a lot of work has gone into our systemd support.
Comment 5 Jan Stodola 2012-10-22 11:17:51 EDT
I haven't seen this message for ages, so closing this bug as fixed.

Note You need to log in before you can comment on or make changes to this bug.