Bug 74886 - Gnome fails to start on Kernel 2.4.19 with ATI Radeon Mobility 7500
Gnome fails to start on Kernel 2.4.19 with ATI Radeon Mobility 7500
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gnome-session (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 12:08 EDT by Need Real Name
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 16:40:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-02 12:08:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I've tried to update the kernel to 2.4.19 (downloaded from kernel.org) using 
the config scripts from the RedHat 8.0 distrib. (installed from the SRPMS 
kernel package 2.4.18-14).   The compile proceeds without errors, using the 
procedure outlined in the RHN 300 course documentation.  All functionality 
seems to work fine except when I invoke "startx".  After I boot to the new 
kernel, gnome fails to start correctly on "startx".  I get the RedHat splash 
screen then everything stops...I don't get the sequence if icons at the bottom 
I should during the loading process.  I've killed the server, restarted and 
the same result.  Gnome still works fine if I boot using Kernel 2.4.18-14.  
The only mods I make to the 2.4.19 kernel before I compile are selecting 
Pentium 4 as the processor and adding multiple LUN support for SCSI devices.  
Everything else is stoch RedHat.  I am using a Compaq Presario 1500 with ATI 
Radeon Mobility 7500 graphics chip set, 256MB RAM and, Compaq W200 multiport 
wireless adapter

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Compile 2.4.19 kernel from clean source using RedHat 2.4.18-14 kernel 
configuration file. 
2.Install kernel 2.4.18 and boot to it.
3.Login and type "startx"
	

Actual Results:  X launches and Gnome starts to loag but hangs on the RedHat 
intro/splash screen.  No icons across the bottom, like what is supposed to 
happen when gnome loads correctly.

Expected Results:  X launches and Gnome starts and shows RedHat intro/splash 
screen as icons across the bottom indicating gnome's load status/progress.

Additional info:

I can't find any seemingly abnormal or error messages from X, so I'm guessing 
the problem is gnome and not X.
Comment 1 Havoc Pennington 2002-10-02 13:03:31 EDT
If you can't reproduce with our stock kernel, really it's up to you to debug this. 

I would suggest an "strace -o /tmp/output -f startx" perhaps, or 
look at ~/.xsession-errors

Note You need to log in before you can comment on or make changes to this bug.