Bug 748884 - system-config-boot works only with grub not with grub2: drop from default install
system-config-boot works only with grub not with grub2: drop from default ins...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-25 10:16 EDT by Petr Schindler
Modified: 2014-03-16 23:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-25 11:47:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2011-10-25 10:16:45 EDT
Description of problem:
I've installed system from TC2 DVD.iso. There is system-config-boot in default compose. But it doesn't work with grub2, which is installed.

Version-Release number of selected component (if applicable):
system-config-boot-1.0-1.fc16.x86_64

How reproducible:
Intall system from TC2 DVD.iso in default configuration (or application compose). There is application Bootloader in Applications menu. Click on it. Write root password. Then error message is shown. It says: "error reading /boot/grub/grub.conf". This file doesn't exist, because system uses grub2.

Steps to Reproduce:
1. Intall system from TC2 DVD.iso with default apps compose.
2. In system go to Activities -> Applications and click on Bootloader
3. Write root password
4. Error message is shown
  
Actual results:
Program can't find /boot/grub/grub.conf file.

Expected results:
It should work with grub2 or, and I thing it's better way, this program shouldn't be in default compose.

Additional info:
This bug is against final release criterion no. 13: Menu sanity - the following criteria refer to both a live image and default installed system, and to all release-blocking desktops: 
  * All Applications listed in the system menus (or equivalent) must have icons which have a consistent appearance and sufficiently high resolution to avoid appearing blurry
  * All applications listed under the Applications menu or category must start successfully
  * All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items
Comment 1 Adam Williamson 2011-10-25 11:37:56 EDT
yeah, we should probably drop this from comps. +1 blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Bill Nottingham 2011-10-25 11:47:31 EDT
Dropped. At some point we might consider whether we want to drop the whole group from the default.

Note You need to log in before you can comment on or make changes to this bug.