Bug 74890 - daemon does not start when pid file mentions existing PID of other daemon
daemon does not start when pid file mentions existing PID of other daemon
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 12:41 EDT by Need Real Name
Modified: 2014-03-16 22:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 16:18:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-02 12:41:05 EDT
We have some boxes deployed into environments where monkeys sometimes unplug
them.  When the machine comes back up, sometimes apache doesn't start up because
the PID mentioned in its PID file refers to a live process from some other daemon.

I'm hoping that the functions (such as daemon) can be modified to avoid
triggering this error by checking the /proc/$PID/cmdline to see if it matches
the cmdname expected for that daemon.

initscripts-6.67-1

If you were willing to require perl, you could extract the command name with the
following code fragment: 

cmdname=`perl -e '$/ = "\0"; $_ = <STDIN>; chomp; s-.*/--; print "$_\n"' <
/proc/$PID/cmdline `
Comment 1 Bill Nottingham 2005-09-29 16:18:55 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.