Bug 748952 - Fatal Errors from grubby when updating kernel
Fatal Errors from grubby when updating kernel
Status: CLOSED DUPLICATE of bug 730357
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-25 12:48 EDT by Baptiste Mille-Mathias
Modified: 2011-11-25 10:24 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-25 10:24:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Baptiste Mille-Mathias 2011-10-25 12:48:24 EDT
Description of problem:
Did a yum update and had these messages, I don't know how critical it is but the message "fatal error" does make me safe.
I assigned to kernel but could also grubby.

…
Download delta size: 5.0 M
(1/3): kernel-3.1.0-0.rc10.git0.1.fc16_3.1.0-1.fc16.x86_64.drpm                                                                                            | 4.5 MB     00:07     
(2/3): kernel-headers-3.1.0-0.rc10.git0.1.fc16_3.1.0-1.fc16.x86_64.drpm                                                                                    | 110 kB     00:00     
(3/3): kernel-tools-3.1.0-0.rc10.git0.1.fc16_3.1.0-1.fc16.x86_64.drpm                                                                                      | 385 kB     00:00     
Finishing rebuild of rpms, from deltarpms
<locally rebuilding deltarpms>                                                                                                                             |  25 MB     00:22     
Presto reduced the update size by 80% (from 25 M to 5.0 M).
Test de la transaction en cours
Lancement de la transaction de test
Transaction de test réussie
Lancement de la transaction
Avertissement : RPMDB a été modifiée par une autre application que yum.
  Mise à jour    : kernel-tools-3.1.0-1.fc16.x86_64                                1/6 
  Mise à jour    : kernel-headers-3.1.0-1.fc16.x86_64                              2/6 
  Installation de: kernel-3.1.0-1.fc16.x86_64                                      3/6 
grubby fatal error: unable to find a suitable template
  Nettoyage      : kernel-3.1.0-0.rc8.git0.1.fc16.x86_64                           4/6 
grubby fatal error: unable to find a suitable template
grubby: doing this would leave no kernel entries. Not writing out new config.
  Nettoyage      : kernel-headers-3.1.0-0.rc10.git0.1.fc16.x86_64                  5/6 
  Nettoyage      : kernel-tools-3.1.0-0.rc10.git0.1.fc16.x86_64                    6/6
Comment 1 Josh Boyer 2011-10-25 13:16:10 EDT
That seems more like grubby than the kernel.  What version of grubby do you have installed?
Comment 2 Baptiste Mille-Mathias 2011-10-25 13:22:58 EDT
rpm -qa |grep grub
grubby-8.3-1.fc16.x86_64
grub2-1.99-10.fc16.x86_64
grub-efi-0.97-83.fc16.x86_64

Actually I don't remember having installed grubby by myself, but perhaps I'm wrong.
Comment 3 Mads Kiilerich 2011-11-25 10:24:13 EST

*** This bug has been marked as a duplicate of bug 730357 ***

Note You need to log in before you can comment on or make changes to this bug.