Bug 749033 - Globally uncaught exception with the metric portlet
Globally uncaught exception with the metric portlet
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
Unspecified Unspecified
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-25 17:39 EDT by Deon Ballard
Modified: 2014-05-30 15:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-30 15:26:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
message center message for the exception (9.26 KB, text/plain)
2011-10-25 17:39 EDT, Deon Ballard
no flags Details

  None (edit)
Description Deon Ballard 2011-10-25 17:39:05 EDT
Created attachment 530189 [details]
message center message for the exception

I was looking at the second-by-second metric graph for the "Resource Metrics" portlet in the dashboard, and when I closed the windows, I got a globally uncaught exception.

I couldn't reproduce this, and it didn't seem to affect the dashboard at all, so I'm just recording this for posterity.

I have attached the message from message center, since it's long. Seems to all be GWT-related.

I checked the server logs and, unfortunately, there wasn't anything recorded at the time of the incident (9:28am CT; the logs are in ET).

[snip]
2011-10-25 10:21:19,737 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [1033] timing (17788)ms
2011-10-25 10:22:35,443 WARN  [org.hibernate.hql.ast.QueryTranslatorImpl] firstResult/maxResults specified with collection fetch; applying in memory!
2011-10-25 10:22:37,815 WARN  [org.hibernate.hql.ast.QueryTranslatorImpl] firstResult/maxResults specified with collection fetch; applying in memory!
2011-10-25 10:22:38,906 WARN  [org.hibernate.hql.ast.QueryTranslatorImpl] firstResult/maxResults specified with collection fetch; applying in memory!
2011-10-25 10:25:04,121 WARN  [org.hibernate.hql.ast.QueryTranslatorImpl] firstResult/maxResults specified with collection fetch; applying in memory!
2011-10-25 10:25:59,550 WARN  [org.hibernate.hql.ast.QueryTranslatorImpl] firstResult/maxResults specified with collection fetch; applying in memory!
2011-10-25 10:26:59,149 WARN  [org.hibernate.hql.ast.QueryTranslatorImpl] firstResult/maxResults specified with collection fetch; applying in memory!
2011-10-25 10:27:59,136 WARN  [org.hibernate.hql.ast.QueryTranslatorImpl] firstResult/maxResults specified with collection fetch; applying in memory!
2011-10-25 10:28:59,536 WARN  [org.hibernate.hql.ast.QueryTranslatorImpl] firstResult/maxResults specified with collection fetch; applying in memory!
2011-10-25 10:34:34,200 INFO  [org.rhq.enterprise.server.core.AgentManagerBean] Agent with name [hp-bl490cg6-01.rhts.eng.bos.redhat.com] just went down

Note You need to log in before you can comment on or make changes to this bug.