Bug 74907 - Stale entryes in /etc/mtab after system runlevel change
Summary: Stale entryes in /etc/mtab after system runlevel change
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-02 18:46 UTC by Need Real Name
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-14 17:52:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-02 18:46:04 UTC
Description of Problem:
I mount several iso images (iso9660 fs) via loop devices. If I change system
runlevel from 3 to 1, initscripts unmount loop-mounted iso images (according
/proc/mounts), but appropriate entryes don't removed from /etc/mtab.


Version-Release number of selected component (if applicable):
kernel-2.4.19 (self-made, with xfs patch from sgi), glibc-2.2.5-39,
mount-2.11n-12.7.3, initscripts-6.67-1

How Reproducible:
always

Steps to Reproduce:
1. mount some iso-image via loop device (write this info in /etc/fstab)
2. change runlevel from 3 to 1 (init 1)
3. cat /proc/mounts
4. cat /etc/mtab

Actual Results:
image not mounted, but entryes in mtab exists

Expected Results:
no appropriate entryes in mtab

Additional Information:
none

Comment 1 Elliot Lee 2003-01-14 17:52:47 UTC
Thanks for the concise instructions. I can't reproduce the problem here on a rawhide-ish 
system, so I'm assuming the problem was fixed before 2.11y-1


Note You need to log in before you can comment on or make changes to this bug.