Bug 749083 - Software Update error
Software Update error
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-26 02:15 EDT by jurek.bajor
Modified: 2012-08-16 09:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 09:24:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jurek.bajor 2011-10-26 02:15:56 EDT
Description of problem:
Transaction error:
could not add package update for
sane-backends-libs-1.0.22-5.fc14(i686)updates:
sane-backends-libs-1.0.22-5.fc14.i686

Version-Release number of selected component (if applicable):
Installed Packages
PackageKit.i686                         0.6.12-4.fc14        @updates           
PackageKit-device-rebind.i686           0.6.12-4.fc14        @updates           
PackageKit-glib.i686                    0.6.12-4.fc14        @updates           
PackageKit-gstreamer-plugin.i686        0.6.12-4.fc14        @updates           
PackageKit-gtk-module.i686              0.6.12-4.fc14        @updates           
PackageKit-yum.i686                     0.6.12-4.fc14        @updates           
PackageKit-yum-plugin.i686              0.6.12-4.fc14        @updates           
gnome-packagekit.i686                   2.32.0-2.fc14     @fedora/$releasever

How reproducible:
only error messages available; system already updated with 'yum update';
see Additional Info below.

Steps to Reproduce:
1. not reproducible any more
2.
3.
  
Actual results:
se above

Expected results:
no update errors

Additional info:

I tried an update:
menu: System-Administration-Software Update (which is PackageKit)
...
Transaction error:
could not add package update for
sane-backends-libs-1.0.22-5.fc14(i686)updates:
sane-backends-libs-1.0.22-5.fc14.i686

which means the update process was interrupted and canceled.

# yum list sane-backends-libs
...
Installed Packages
sane-backends-libs.i686                  1.0.22-3.fc14                  @updates
Available Packages
sane-backends-libs.i686                  1.0.22-5.fc14                  updates
#

Next I tried update with yum:
# yum update
...
---> Package sane-backends.i686 0:1.0.22-5.fc14 set to be installed
--> Processing Dependency: sane-backends-libs(x86-32) = 1.0.22-5.fc14
for package: sane-backends-1.0.22-5.fc14.i686
...
--> Running transaction check
---> Package sane-backends-libs.i686 0:1.0.22-5.fc14 set to be updated
--> Finished Dependency Resolution
...
Installing:
...
     replacing  sane-backends.i686 1.0.22-3.fc14
     replacing  sane-backends-libs.i686 1.0.22-3.fc14
...
Updating for dependencies:
 sane-backends-libs          i686   1.0.22-5.fc14                 updates  77 k
...
Total download size: 205 M
Is this ok [y/N]: y
Downloading Packages:
...
Presto reduced the update size by 90% (from 182 M to 19 M).
Package(s) data still to download: 23 M
...
(10/16): sane-backends-1.0.22-5.fc14.i686.rpm            | 1.0 MB     00:04
(11/16): sane-backends-drivers-cameras-1.0.22-5.fc14.i68 |  40 kB     00:00
(12/16): sane-backends-drivers-scanners-1.0.22-5.fc14.i6 | 2.1 MB     00:08
(13/16): sane-backends-libs-1.0.22-5.fc14.i686.rpm       |  77 kB     00:00
...
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
...
  Installing     : sane-backends-drivers-cameras-1.0.22-5.fc14.i686      10/182
  Updating       : sane-backends-libs-1.0.22-5.fc14.i686                 11/182
  Installing     : sane-backends-1.0.22-5.fc14.i686
  12/182 ...
Dependency Updated:
  sane-backends-libs.i686 0:1.0.22-5.fc14

Replaced:
  ...
  sane-backends.i686 0:1.0.22-3.fc14
  sane-backends-libs.i686 0:1.0.22-3.fc14
  sane-backends-libs-gphoto2.i686 0:1.0.22-3.fc14

Complete!
[root <at> localhost jb]#

Why the difference ? Perhaps there is an error in one of the update packages ?
JB
Comment 1 pfusik 2011-10-26 16:42:26 EDT
Same problem here. "There are 57 updates available" but "Install updates" fails due to "Transaction error: could not add package update for sane-backends-libs-1.0.22-5.fc14(i686)updates: sane-backends-libs-1.0.22-5.fc14.i686".

Note that "sane-backends-libs" is hidden in the collapsed "sane-backends" and unchecking the "sane-backends" checkbox doesn't help - you need to expand the hidden items first. I think this may block all updates for the less experienced users.

I have never used any scanner software on this machine.
Comment 2 Martin Simmons 2011-11-01 08:02:56 EDT
I got similar problems: the Software Update desktop tool failed to update sane-backends-libs.  Also yum update failed like this:

---> Package sane-backends.x86_64 0:1.0.22-5.fc14 set to be updated
--> Processing Dependency: sane-backends-libs(x86-64) = 1.0.22-3.fc14 for package: sane-backends-libs-gphoto2-1.0.22-3.fc14.x86_64
---> Package sane-backends-libs.x86_64 0:1.0.22-5.fc14 set to be updated
--> Finished Dependency Resolution
Error: Package: sane-backends-libs-gphoto2-1.0.22-3.fc14.x86_64 (@updates)
           Requires: sane-backends-libs(x86-64) = 1.0.22-3.fc14
           Removing: sane-backends-libs-1.0.22-3.fc14.x86_64 (@updates)
               sane-backends-libs(x86-64) = 1.0.22-3.fc14
           Updated By: sane-backends-libs-1.0.22-5.fc14.x86_64 (updates)
               sane-backends-libs(x86-64) = 1.0.22-5.fc14
           Available: sane-backends-libs-1.0.21-3.fc14.x86_64 (fedora)
               sane-backends-libs(x86-64) = 1.0.21-3.fc14

Running yum update --obsoletes fixed it.  The problem was that sane-backends-libs-gphoto2 has been obsoleted by the new package sane-backends-drivers-cameras, but it looks like Software Update didn't deal with this.
Comment 3 Sitsofe Wheeler 2011-12-17 10:12:46 EST
This bug afflicts Fedora 15 too. Packagekit could not upgrade the system but a yum update could:




# yum update
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package sane-backends.x86_64 0:1.0.22-3.fc15 will be obsoleted
---> Package sane-backends.x86_64 0:1.0.22-5.fc15 will be obsoleting
--> Processing Dependency: sane-backends-libs(x86-64) = 1.0.22-5.fc15 for package: sane-backends-1.0.22-5.fc15.x86_64
---> Package sane-backends-drivers-cameras.x86_64 0:1.0.22-5.fc15 will be obsoleting
---> Package sane-backends-drivers-scanners.x86_64 0:1.0.22-5.fc15 will be obsoleting
---> Package sane-backends-libs.x86_64 0:1.0.22-3.fc15 will be obsoleted
---> Package sane-backends-libs-gphoto2.x86_64 0:1.0.22-3.fc15 will be obsoleted
--> Running transaction check
---> Package sane-backends-libs.x86_64 0:1.0.22-3.fc15 will be updated
---> Package sane-backends-libs.x86_64 0:1.0.22-5.fc15 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================================================
 Package                                             Arch                        Version                             Repository                    Size
========================================================================================================================================================
Installing:
 sane-backends                                       x86_64                      1.0.22-5.fc15                       updates                      980 k
     replacing  sane-backends.x86_64 1.0.22-3.fc15
 sane-backends-drivers-cameras                       x86_64                      1.0.22-5.fc15                       updates                       40 k
     replacing  sane-backends-libs-gphoto2.x86_64 1.0.22-3.fc15
 sane-backends-drivers-scanners                      x86_64                      1.0.22-5.fc15                       updates                      2.0 M
     replacing  sane-backends.x86_64 1.0.22-3.fc15
     replacing  sane-backends-libs.x86_64 1.0.22-3.fc15
Updating for dependencies:
 sane-backends-libs                                  x86_64                      1.0.22-5.fc15                       updates                       78 k

Transaction Summary
========================================================================================================================================================
Install       3 Package(s)
Upgrade       1 Package(s)

Total download size: 3.0 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 3.0 M
(1/4): sane-backends-1.0.22-5.fc15.x86_64.rpm                                                                                    | 980 kB     00:01     
(2/4): sane-backends-drivers-cameras-1.0.22-5.fc15.x86_64.rpm                                                                    |  40 kB     00:00     
(3/4): sane-backends-drivers-scanners-1.0.22-5.fc15.x86_64.rpm                                                                   | 2.0 MB     00:02     
(4/4): sane-backends-libs-1.0.22-5.fc15.x86_64.rpm                                                                               |  78 kB     00:00     
--------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                   678 kB/s | 3.0 MB     00:04     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : sane-backends-drivers-scanners-1.0.22-5.fc15.x86_64                                                                                  1/7 
  Updating   : sane-backends-libs-1.0.22-5.fc15.x86_64                                                                                              2/7 
  Installing : sane-backends-1.0.22-5.fc15.x86_64                                                                                                   3/7 
  Installing : sane-backends-drivers-cameras-1.0.22-5.fc15.x86_64                                                                                   4/7 
  Erasing    : sane-backends-libs-gphoto2-1.0.22-3.fc15.x86_64                                                                                      5/7 
  Cleanup    : sane-backends-libs-1.0.22-3.fc15.x86_64                                                                                              6/7 
  Cleanup    : sane-backends-1.0.22-3.fc15.x86_64                                                                                                   7/7 

Installed:
  sane-backends.x86_64 0:1.0.22-5.fc15   sane-backends-drivers-cameras.x86_64 0:1.0.22-5.fc15   sane-backends-drivers-scanners.x86_64 0:1.0.22-5.fc15  

Dependency Updated:
  sane-backends-libs.x86_64 0:1.0.22-5.fc15                                                                                                             

Replaced:
  sane-backends.x86_64 0:1.0.22-3.fc15        sane-backends-libs.x86_64 0:1.0.22-3.fc15        sane-backends-libs-gphoto2.x86_64 0:1.0.22-3.fc15       

Complete!
Comment 4 Sitsofe Wheeler 2011-12-17 10:13:44 EST
Richard: What do you think this is a packagekit error?
Comment 5 Fedora End Of Life 2012-08-16 09:24:04 EDT
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.