Bug 749188 - It's impossible to use as_IN locale
Summary: It's impossible to use as_IN locale
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc
Version: 6.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Jeff Law
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-26 12:43 UTC by Miroslav Franc
Modified: 2016-11-24 12:07 UTC (History)
4 users (show)

(edit)
No Documentation Needed
Clone Of:
(edit)
Last Closed: 2012-06-20 12:08:36 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0763 normal SHIPPED_LIVE glibc bug fix and enhancement update 2012-06-19 20:35:39 UTC

Description Miroslav Franc 2011-10-26 12:43:27 UTC
Description of problem:
It's impossible to use as_IN locale. One have to use as_IN.utf8. But for other indian locales (ar_IN bn_IN en_IN gu_IN hi_IN kn_IN kok_IN ks_IN ml_IN mr_IN or_IN pa_IN sa_IN sd_IN ta_IN te_IN) it works.


Version-Release number of selected component (if applicable):
glibc-2.12-1.45.el6


How reproducible:
every time


Steps to Reproduce:
1. LC_ALL=as_IN cal

  
Actual results:
    October 2011
Su Mo Tu We Th Fr Sa
                   1
 2  3  4  5  6  7  8
 9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31


Expected results:
     অক্টোবৰ 2011
দে সো মঙ্ বুধ বৃহ শুক্ শন
                   1
 2  3  4  5  6  7  8
 9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31
# the same as for `LC_ALL=as_IN.utf8 cal'


Additional info:
This works in fedora 15, should be very easy to fix.
I discover this during verification of bug 692838.

Comment 3 Jeff Law 2011-12-16 16:47:17 UTC
Automated test needed.

Comment 5 Jeff Law 2012-04-12 16:14:48 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation Needed

Comment 7 errata-xmlrpc 2012-06-20 12:08:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0763.html


Note You need to log in before you can comment on or make changes to this bug.