Bug 74920 - XFS 100% CPU utilization when viewing email in Evolution
Summary: XFS 100% CPU utilization when viewing email in Evolution
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-02 19:56 UTC by alan
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-04 23:46:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description alan 2002-10-02 19:56:17 UTC
Description of Problem:

When viewing email in Evolution XFS uses 100% CPU utilization and there is as
much as a twenty second delay before the email is displayed.

Version-Release number of selected component (if applicable):

Evolution 1.0.8  
Stock RH 8.0 XFS, couldn't find a version, maybe it's Xft 2.0-1 calling itself xfs?


How Reproducible:

At will and on demand.  Seems to depend on the email. A simple text email
doesn't seem to have a problem, but a complex email with fonts and colors takes
a long time


Steps to Reproduce:
1. open any font/color rich email in Evolution
2. 
3. 

Actual Results:



Expected Results:


Additional Information:
	
I can send an example email if needed, but almost any will do.

Comment 1 Owen Taylor 2002-10-02 20:32:46 UTC
xfs is the X font server. Xft is a library for doing fonts without
having to talk to the X server or X font server.

Most likely this is an evolution issue of it asking xfs to do
a lot of work.


Comment 2 alan 2002-10-04 23:45:58 UTC
I installed the MS Web fonts package trutype fonts in ~/.fonts/ and the "lag"
went to less than a second and CPU utilzation stayed low.  A huge difference
from 20 seconds and 100% utilization.  Looks like Evolution was making XFS look
for fonts that didn't exist then timing out or something.  Anyway, the web
truetype fonts in ~/.fonts/ seems to make the problem go away.

Comment 3 Jeremy Katz 2002-10-05 14:29:52 UTC
It's actually probably just picking fonts which X renders slowly.  This is not
an evolution bug at least.  If you'd like to follow up further on it, please
file a bug against XFree86.


Note You need to log in before you can comment on or make changes to this bug.