Bug 74927 - Unhandled exception before upgrading packages from 7.3 to 8.0
Unhandled exception before upgrading packages from 7.3 to 8.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
http://www.baschny.de/linux/RedHat-8....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 16:51 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-02 16:51:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-02 16:51:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
Upgrade from RedHat 7.3 to 8.0 fails before starting to upgrade the packages 
("Unhandled Exception").

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
On the system RedHat 7.3 is (freshly) installed.

1. Boot the PC using Intels ee100 and PXE (get the IP via DHCP and boot kernel 
via PXE from RedHats CD1: /images/pxeboot).
2. Text mode, since only 32mb of RAM are avaliable
3. Source of installation is a NFS-directory on another server, where the 3 
ISO images from RedHat are avaliable.
4. Choose the "upgrade" option.
5. Wait a while in "Finding packages to upgrade"
6. Wait another while in "Checking dependencies in packages selected for 
installation..."
7. "A complete log of your upgrade will be in /root/upgrade.log..." and I 
hit "OK"
8. after some seconds:

Exception Occurred

An unhandled exception has occurred. This is most likely a bug. Please
copy the full text of this exception or save the crash dump to a floppy then
file a detailed bug report against anaconda.
	

Actual Results:  Exception Occurred

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 694, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 446, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 613, in doPreInstall
    f.close()
IOError: [Errno 22] Invalid argument

Local variables in innermost frame:
upgrade: 1
ohcifnd: 0
instPath: /mnt/sysimage
f: <closed file '/mnt/sysimage/etc/mtab', mode 'w+' at 0x8200730>
i: /var/tmp
errno: 17
method: <image.NfsIsoInstallMethod instance at 0x83f97bc>
ehcifnd: 0
intf: <text.InstallInterface instance at 0x82cbe84>
select: <function select at 0xa847954>
usbcontrollers: []
msg: File exists
arch: i386
id: <instdata.InstallData instance at 0x853232c>
dir: 1

(full dump at http://www.baschny.de/linux/RedHat-8.0-anaconda-dump.txt).


Nothing from RedHat 8.0 installed.

Expected Results:  Packages upgraded from RedHat 7.3 to 8.0.


Additional info:

PC is a Pentium 120 MHz with 32 Mb of RAM and 1.6 Gb HD.
Maybe its a memory issue, but RedHat 7.3 installed without a problem.

I cannot boot from floppy or CD-ROM, since both are defect, my only choice is 
booting from PXE via the network (DHCP and TFTP loading Redhat's pxe kernel 
and initrd.img).

After that I install from NFS, where the 3 ISO images are located on a 
directory.
Comment 1 Michael Fulbright 2002-10-03 13:38:17 EDT
64MB is the minimum supported configuration.

Note You need to log in before you can comment on or make changes to this bug.