Bug 74928 - LPRng doesn't print duplex when configured that way.
LPRng doesn't print duplex when configured that way.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 16:52 EDT by Hunter Matthews
Modified: 2014-01-21 17:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-04 23:33:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
local.adl file from our print server (1.12 KB, application/octet-stream)
2002-10-02 18:15 EDT, Hunter Matthews
no flags Details

  None (edit)
Description Hunter Matthews 2002-10-02 16:52:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
LPRng stock on Red Hat 7.3. The configuration was copied up from 7.2.

HP Laserjet 4000N, configured with the gimp driver. The drivers duplex option is
on, and the duplex side (or whatever) is set to long (IE, print normal duplex as
you would expect.)

The printer is also set to duplex on, has been rebooted, and prints its
configuration page duplexed.

However, lpr name_of_file comes out simplex.

Suggestions welcome. My alchemist files are available on requrest.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. print a file
2. grab pages from printer
3.
	

Actual Results:  Prints in simplex

Expected Results:  Print in duplex mode 

Additional info:
Comment 1 Tim Waugh 2002-10-02 17:33:08 EDT
Yes, please attach /etc/alchemist/namespace/printconf/local.adl and I'll try 
to reproduce it.  Thanks.
Comment 2 Hunter Matthews 2002-10-02 18:15:17 EDT
Created attachment 78266 [details]
local.adl file from our print server
Comment 3 Hunter Matthews 2002-10-02 18:16:27 EDT
Would the particular DRIVER (i think I have that printer set to gimp print) have
an effect?
Comment 4 Hunter Matthews 2002-10-07 18:58:51 EDT
I've tried deleting and re-creating the queue, in the theory that it might be a
version skew kind of problem. No joy.

My users/boss are riding me pretty hard on this one: any suggestions?
Comment 5 Seth Vidal 2002-10-07 23:37:56 EDT
Got the same problem - prints in duplex on the postscript driver w/o a problem -
but the hp4000's blow up on certain postscript with the other drivers.

I might try it with the lj5gray drivers shortly - but I've gotten the best
output from the gimp-print driver.
Comment 6 Hunter Matthews 2002-10-08 13:02:26 EDT
I've reconfigured our printers here to use the postscript driver as well, and
they SEEM to be ok. I have users testing now. 

The gimp-print output IS better, so we would prefer to see a fix to allow that
driver to be used again.
Comment 7 Seth Vidal 2002-10-08 14:43:30 EDT
Using pxlmono does reasonable output - but I'd still love to know why gimp-print
doesn't work.
Comment 8 Seth Vidal 2002-10-08 16:28:01 EDT
whoops - spoke too soon, pxlmono and lj5gray will make both cause the hp4000 to
drop the last page <sigh>

Additionally, the postscript driver appears to send the printer cruft on certain
occasions and we know hp's ps support is, umm, a thing of legend.

Any leads on gimp-print as postscript?

thanks
Comment 9 Seth Vidal 2002-10-08 16:31:33 EDT
worthy of note - gimp-print won't duplex on the hp2200DN either.
Comment 10 Seth Vidal 2002-10-08 16:38:14 EDT
not to be a bother but:
Changelog

* Thu Jul 18 2002 Tim Waugh <twaugh@redhat.com> 4.2.1-5
  - Make the cups package own some directories.
* Tue Jul 16 2002 Tim Waugh <twaugh@redhat.com> 4.2.1-4
  - Fix PS:Duplex problems.

That is from the gimp-print package in Rawhide.

What is this fix?
Comment 11 Seth Vidal 2002-10-08 16:44:03 EDT
I should just consolidate this - but gimp-print appears to ignore duplex in 8.0 too.

I can attach a local.adl from there as well, if you'd like.

thanks
Comment 12 Tim Waugh 2002-10-09 03:49:52 EDT
> - Fix PS:Duplex problems. 
 
This was that the ghostscript IJS client was sending the gimp print IJS server 
PS:Duplex options, which the gimp-print-ijs server doesn't handle.  The 
subsequent errors prevented any printing at all. 
 
For the HP LaserJet 4000N, the recommended driver is Omni.  Have you tried 
that?
Comment 13 Seth Vidal 2002-10-09 10:43:00 EDT
Under 7.3 omni is not an option for hp4000's - would you like me to choose the
omni driver out from under another printer and try it on the hp4000n on 7.3?

Comment 14 Tim Waugh 2002-10-09 11:29:52 EDT
Oh, perhaps Omni only supports that model in 0.7.x then (I'm using Red Hat 
Linux 8.0 here).  Sorry.
Comment 15 Seth Vidal 2004-05-04 23:33:56 EDT
appears to be resolved on rhl9 and above for the hp4000's  - closing.

Note You need to log in before you can comment on or make changes to this bug.