Bug 749291 - Review Request: dpm-xrootd - xroot interface to the Disk Pool Manager (DPM)
Review Request: dpm-xrootd - xroot interface to the Disk Pool Manager (DPM)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adrien Devresse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-26 12:08 EDT by Ricardo Rocha
Modified: 2013-06-17 10:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-17 10:11:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
adev88: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Ricardo Rocha 2011-10-26 12:08:33 EDT
Spec URL: http://rocha.web.cern.ch/rocha/fedora/dpm-xrootd.spec
SRPM URL: http://rocha.web.cern.ch/rocha/fedora/dpm-xrootd-2.2.1-1.src.rpm
Description: This package contains the XROOT plugin implementation for the
Disk Pool Manager (DPM).

The Disk Pool Manager (DPM) is a lightweight storage solution for grid sites.
It offers a simple way to create a disk-based grid storage element and
supports relevant protocols (SRM, gridFTP, RFIO) for file management
and access.

XROOT aims at giving high performance, scalable fault tolerant access to data
repositories of many kinds.

This is part of my first set of packages, and I am looking for a sponsor. 

Other packages i'm submitting in this first bunch cover the bits of the DPM and
LFC components not yet available in Fedora/EPEL - the core components are
already built in Fedora (see lcgdm). 

This is part of a more general effort to get software already available and
packaged in the EMI project (http://www.eu-emi.eu/) directly available in the
main distributions.
Comment 1 Steve Traylen 2011-11-02 16:45:18 EDT
For the purpose of process bug #749132 records the whole sponsorship.

A quick parse:

1) Fully describe how the tar ball is created.
2) BuildRequires:  autoconf%{?_isa}
BuildRequires:  automake%{?_isa}

is a nonsense since both are noarch. You are probably using the isa tag
quite excessively here. I typically only add them for -devel packages 
and they should be present on interdependencies between your subpackages.

Editing .spec myself to allow me to continue.

Fails to build on a F15 machine

configure.ac:68: error: m4_require: circular dependency of AC_LANG_COMPILER(C++)
../../lib/autoconf/lang.m4:330: AC_LANG_COMPILER_REQUIRE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:606: AS_IF is expanded from...
../../lib/autoconf/general.m4:2032: AC_CACHE_VAL is expanded from...
/usr/share/aclocal/libtool.m4:1086: _LT_SYS_MODULE_PATH_AIX is expanded from...
/usr/share/aclocal/libtool.m4:5752: _LT_LANG_CXX_CONFIG is expanded from...
/usr/share/aclocal/libtool.m4:816: _LT_LANG is expanded from...
/usr/share/aclocal/libtool.m4:799: LT_LANG is expanded from...
../../lib/autoconf/c.m4:667: AC_LANG_COMPILER(C++) is expanded from...
../../lib/autoconf/lang.m4:330: AC_LANG_COMPILER_REQUIRE is expanded from...
../../lib/autoconf/general.m4:2607: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:606: AS_IF is expanded from...
../../lib/m4sugar/m4sh.m4:353: AS_REQUIRE is expanded from...
../../lib/autoconf/general.m4:183: AC_REQUIRE_SHELL_FN is expanded from...
../../lib/autoconf/headers.m4:129: _AC_CHECK_HEADER_MONGREL is expanded from...
../../lib/autoconf/headers.m4:67: AC_CHECK_HEADER is expanded from...
configure.ac:68: the top level

I've added "BuildFails" to the whiteboard above, be sure to remove it again
once the package builds.

http://fedoraproject.org/wiki/Package_Review_Process#The_Whiteboard
Comment 2 Ricardo Rocha 2011-11-08 08:51:23 EST
Sorry, i had only tested with RHEL5.

Fix for newer dists is in version 2.2.2 upstream, spec and srpm updated accordingly.

Here are the new ones for the review:
Spec URL: http://rocha.web.cern.ch/rocha/fedora/dpm-xrootd.spec
SRPM URL: http://rocha.web.cern.ch/rocha/fedora/dpm-xrootd-2.2.2-1.src.rpm

There's a warning regarding dangling-symlinks that i couldn't figure out. For the shared library calling exit, somehow the existing code relies on this, i can ask for it to be changed (in a next release if possible?).

Thanks.
Comment 4 Steve Traylen 2011-11-12 16:06:05 EST
Here is the review:
https://bugzilla.redhat.com/show_bug.cgi?id=749291

 +:ok, =:needs attention, -:needs fixing

MUST Items:
[-] MUST: rpmlint must be run on every package.
rpmlint ./dpm-xrootd.spec 
./dpm-xrootd.spec: W: invalid-url Source0: dpm-xrootd-2.2.2.tar.gz

dpm-xrootd.src: W: invalid-url Source0: dpm-xrootd-2.2.2.tar.gz
dpm-xrootd.x86_64: W: spelling-error %description -l en_US plugin -> plug in, plug-in, plugging
dpm-xrootd.x86_64: W: spelling-error %description -l en_US gridFTP -> grid Ftp, grid-ftp, griddle
dpm-xrootd.x86_64: W: spelling-error %description -l en_US scalable -> salable, scalawag, scalar

plugin should be plug-in.
scalable seems not to be word... You can swap "high performance, scalable fault tolerant"
for "high performance, easy to scale and fault tolerant" or something.

dpm-xrootd.x86_64: W: shared-lib-calls-exit /usr/lib64/libXrdDPMXmi.so.0.0.0 _exit@GLIBC_2.2.5
dpm-xrootd.x86_64: W: shared-lib-calls-exit /usr/lib64/libXrdDPMOfsAndN2N.so.0.0.0 _exit@GLIBC_2.2.5
You commented on this, hopefully fix one day.
dpm-xrootd.x86_64: W: dangling-symlink /usr/bin/dpm-cmsd /usr/bin/cmsd

dpm-xrootd.x86_64: W: dangling-symlink /usr/bin/dpm-manager-xrootd /usr/bin/xrootd
dpm-xrootd.x86_64: W: dangling-symlink /usr/bin/dpm-manager-cmsd /usr/bin/cmsd
dpm-xrootd.x86_64: W: dangling-symlink /usr/bin/dpm-xrootd /usr/bin/xrootd

It's okay the 3 targets are provided by xrootd, ... but what is the point of these symbolic
links?

dpm-xrootd-devel.x86_64: W: no-dependency-on dpm-xrootd/dpm-xrootd-libs/libdpm-xrootd

Indeed dpm-xrootd-devel should contain
Requires: dpm-xrootd%{?_isa} = %{version}-%{release}


[+] MUST: The package must be named according to the Package Naming Guidelines.
Based on SVN moulde name.
[+] MUST: The spec file name must match the base package %{name}
[+] MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines.
ASL 2.0
[-] MUST: The License field in the package spec file must match the actual license.
The only thing anywhere to suggest a license is a GPLv3 COPYING file. The c++ 
files and headers contain a copyright from SLAC but no hint as to what the license
is. Presumably you must clarify with SLAC what the license is or was.

[-] MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc.
The COPYING file is included but it's unclear if that is correct.

[+] MUST: The spec file must be written in American English.
[+] MUST: The spec file for the package MUST be legible.
[-] MUST: The sources used to build the package must match the upstream source, as provided in the spec URL.
I think the svn checkout resolves to
svn export http://svn.cern.ch/guest/lcgdm/dpm-xrootd/glite-data-dpm-xrootd_R_2_2_2_1 dpm-xrootd-2.2.2
which fails.

[+] MUST: The package must successfully compile and build into binary rpms on at least one supported architecture.
Mock builds.
[+] MUST: If the package does not successfully compile, build or work on an architecture, then those architectures should be listed in the spec in ExcludeArch.
Builds on all.
[+] MUST: All build dependencies must be listed in BuildRequires
[+] MUST: The spec file MUST handle locales properly. This is done by using the %find_lang macro.
No locales present.
[=] MUST: Every binary RPM package which stores shared library files (not just symlinks) in any of the dynamic linker's default paths, must call ldconfig in %post and %postun.

Your dpm-xrootd package has these but they are not needed on the devel package. rpmlint used to show these up.

[+] MUST: If the package is designed to be relocatable, the packager must state this fact in the request for review
Not relocatablle
[+] MUST: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory.
[+] MUST: A package must not contain any duplicate files in the %files listing.
[+] MUST: Permissions on files must be set properly. Executables should be set with executable permissions, for example. Every %files section must include a %defattr(...) line.
[+] MUST: Each package must have a %clean section, which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT).
[+] MUST: Each package must consistently use macros, as described in the macros section of Packaging Guidelines.
[+] MUST: The package must contain code, or permissible content. This is described in detail in the code vs. content section of Packaging Guidelines.
[+] MUST: Large documentation files should go in a doc subpackage.
[+] MUST: If a package includes something as %doc, it must not affect the runtime of the application.
[+] MUST: Header files must be in a -devel package.
[+] MUST: Static libraries must be in a -static package.
[+] MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig' (for directory ownership and usability).
[] MUST: If a package contains library files with a suffix (e.g. libfoo.so.1.1), then library files that end in .so (without suffix) must go in a -devel package.
[=] MUST: In the vast majority of cases, devel packages must require the base package using a fully versioned dependency: Requires: %{name} = %{version}-%{release} 
Fails as noticed by rpmlint
[=] MUST: Packages must NOT contain any .la libtool archives, these should be removed in the spec.
There is a .la and a .a file, drop them.

[+] MUST: Packages containing GUI applications must include a %{name}.desktop file, and that file must be properly installed with desktop-file-install in the %install section.
[?] MUST: Packages must not own files or directories already owned by other packages.
I notice this create /var/log/xroot and xrootd creates /var/log/xrootd ... Is that intentional?

[+] MUST: At the beginning of %install, each package MUST run rm -rf %{buildroot} (or $RPM_BUILD_ROOT).
Only needed for RHEL5.
[+] MUST: All filenames in rpm packages must be valid UTF-8.

SHOULD Items:
[+] SHOULD: The reviewer should test that the package builds in mock.
[+] SHOULD: The package should compile and build into binary rpms on all supported architectures.
[To be done] SHOULD: The reviewer should test that the package functions as described.
[=] SHOULD: If scriptlets are used, those scriptlets must be sane.
ldconfig on devel should not be there.
[=] SHOULD: Usually, subpackages other than devel should require the base package using a fully versioned dependency.
See above.
[] SHOULD: The placement of pkgconfig(.pc) files depends on their usecase, and this is usually for development purposes, so should be placed in a -devel pkg. A reasonable exception is that the main pkg itself is a devel tool not installed in a user runtime, e.g. gcc or gdb.
[+] SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself.
[+] SHOULD: Packages should try to preserve timestamps of original installed files.

Comments beyond what is above:
(1) CFLAGS do not look correct:
g++ "-DPACKAGE_NAME=\"DPM xrootd\"" -DPACKAGE_TARNAME=\"dpm-xrootd\" -DPACKAGE_VERSION=\"0.0.0\" "-DPACKAGE_STRING=\"DPM xrootd 0.0.0\"" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DPACKAGE=\"dpm-xrootd\" -DVERSION=\"0.0.0\" -D_THREAD_SAFE=1 -D_REENTRANT=1 -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64 -I. -I../ -I/usr/include/xrootd/ -I /usr/include/dpm -DXRDDPM_BUILDDATE=\"121111200750\" -g -O2 -MT libXrdDPMXmi_la-XrdDPMXmi.lo -MD -MP -MF .deps/libXrdDPMXmi_la-XrdDPMXmi.Tpo -c XrdDPMXmi.cc  -fPIC -DPIC -o .libs/libXrdDPMXmi_la-XrdDPMXmi.o

(2) Templates present but no configuration.
I presume that 
%config(noreplace) %{_sysconfdir}/sysconfig/dpm-xrd.templ
%config(noreplace) %{_sysconfdir}/xrd.authz.cnf.templ
%config(noreplace) %{_sysconfdir}/xrd.dpm.cf.templ

are template files and not the live files?
Better to move or at least copy them into the used location.

(3) The devel package can drop these %doc since they are in the main
   package. On a similar node the NEWS and AUTHORS file seem
   pointless.
Comment 5 Ricardo Rocha 2011-11-17 13:14:35 EST
Thanks Steve.

New spec and src rpms:
Spec URL: http://rocha.web.cern.ch/rocha/fedora/dpm-xrootd.spec
SRPM URL: http://rocha.web.cern.ch/rocha/fedora/dpm-xrootd-2.2.3-1.src.rpm

I've fixed the issues you mentioned, but also did a main change upstream. I got tired of loosing time with autotools and changed the build to use cmake instead.

There's one issue left, regarding the license. I checked the xrootd packages already in Fedora, and it's defined as BSD + LGPLv2+. I would say we should keep the same licensing (David agrees)?

For details on the individual fixes, you can have a look inline.

Koji builds (successful):
https://koji.fedoraproject.org/koji/taskinfo?taskID=3522044 (dist-5E-epel)
https://koji.fedoraproject.org/koji/taskinfo?taskID=3522052 (dist-6E-epel)
https://koji.fedoraproject.org/koji/taskinfo?taskID=3522058 (f16)

(In reply to comment #4)
> Here is the review:
> https://bugzilla.redhat.com/show_bug.cgi?id=749291
> 
>  +:ok, =:needs attention, -:needs fixing
> 
> MUST Items:
> [-] MUST: rpmlint must be run on every package.
> rpmlint ./dpm-xrootd.spec 
> ./dpm-xrootd.spec: W: invalid-url Source0: dpm-xrootd-2.2.2.tar.gz
> 
> dpm-xrootd.src: W: invalid-url Source0: dpm-xrootd-2.2.2.tar.gz
> dpm-xrootd.x86_64: W: spelling-error %description -l en_US plugin -> plug in,
> plug-in, plugging
> dpm-xrootd.x86_64: W: spelling-error %description -l en_US gridFTP -> grid Ftp,
> grid-ftp, griddle
> dpm-xrootd.x86_64: W: spelling-error %description -l en_US scalable -> salable,
> scalawag, scalar
> 
> plugin should be plug-in.
> scalable seems not to be word... You can swap "high performance, scalable fault
> tolerant"
> for "high performance, easy to scale and fault tolerant" or something.

Fixed as suggested.

> dpm-xrootd.x86_64: W: shared-lib-calls-exit /usr/lib64/libXrdDPMXmi.so.0.0.0
> _exit@GLIBC_2.2.5
> dpm-xrootd.x86_64: W: shared-lib-calls-exit
> /usr/lib64/libXrdDPMOfsAndN2N.so.0.0.0 _exit@GLIBC_2.2.5
> You commented on this, hopefully fix one day.

Bug added upstream:
https://svnweb.cern.ch/trac/lcgdm/ticket/345

> dpm-xrootd.x86_64: W: dangling-symlink /usr/bin/dpm-cmsd /usr/bin/cmsd
> 
> dpm-xrootd.x86_64: W: dangling-symlink /usr/bin/dpm-manager-xrootd
> /usr/bin/xrootd
> dpm-xrootd.x86_64: W: dangling-symlink /usr/bin/dpm-manager-cmsd /usr/bin/cmsd
> dpm-xrootd.x86_64: W: dangling-symlink /usr/bin/dpm-xrootd /usr/bin/xrootd
> 
> It's okay the 3 targets are provided by xrootd, ... but what is the point of
> these symbolic
> links?

I discussed this, and a solution should be possible. I added a bug here:
https://svnweb.cern.ch/trac/lcgdm/ticket/344

and it should be fixed for the next release of the component.

> dpm-xrootd-devel.x86_64: W: no-dependency-on
> dpm-xrootd/dpm-xrootd-libs/libdpm-xrootd

Added.

> Indeed dpm-xrootd-devel should contain
> Requires: dpm-xrootd%{?_isa} = %{version}-%{release}

Added.

> [+] MUST: The package must be named according to the Package Naming Guidelines.
> Based on SVN moulde name.
> [+] MUST: The spec file name must match the base package %{name}
> [+] MUST: The package must be licensed with a Fedora approved license and meet
> the Licensing Guidelines.
> ASL 2.0
> [-] MUST: The License field in the package spec file must match the actual
> license.
> The only thing anywhere to suggest a license is a GPLv3 COPYING file. The c++ 
> files and headers contain a copyright from SLAC but no hint as to what the
> license
> is. Presumably you must clarify with SLAC what the license is or was.

Not yet totally clear, but see above.

> [-] MUST: If (and only if) the source package includes the text of the
> license(s) in its own file, then that file, containing the text of the
> license(s) for the package must be included in %doc.
> The COPYING file is included but it's unclear if that is correct.

See above.

> [+] MUST: The spec file must be written in American English.
> [+] MUST: The spec file for the package MUST be legible.
> [-] MUST: The sources used to build the package must match the upstream source,
> as provided in the spec URL.
> I think the svn checkout resolves to
> svn export
> http://svn.cern.ch/guest/lcgdm/dpm-xrootd/glite-data-dpm-xrootd_R_2_2_2_1
> dpm-xrootd-2.2.2
> which fails.

Fixed.

> [+] MUST: The package must successfully compile and build into binary rpms on
> at least one supported architecture.
> Mock builds.
> [+] MUST: If the package does not successfully compile, build or work on an
> architecture, then those architectures should be listed in the spec in
> ExcludeArch.
> Builds on all.
> [+] MUST: All build dependencies must be listed in BuildRequires
> [+] MUST: The spec file MUST handle locales properly. This is done by using the
> %find_lang macro.
> No locales present.
> [=] MUST: Every binary RPM package which stores shared library files (not just
> symlinks) in any of the dynamic linker's default paths, must call ldconfig in
> %post and %postun.
> 
> Your dpm-xrootd package has these but they are not needed on the devel package.
> rpmlint used to show these up.

Removed.

> [+] MUST: If the package is designed to be relocatable, the packager must state
> this fact in the request for review
> Not relocatablle
> [+] MUST: A package must own all directories that it creates. If it does not
> create a directory that it uses, then it should require a package which does
> create that directory.
> [+] MUST: A package must not contain any duplicate files in the %files listing.
> [+] MUST: Permissions on files must be set properly. Executables should be set
> with executable permissions, for example. Every %files section must include a
> %defattr(...) line.
> [+] MUST: Each package must have a %clean section, which contains rm -rf
> %{buildroot} (or $RPM_BUILD_ROOT).
> [+] MUST: Each package must consistently use macros, as described in the macros
> section of Packaging Guidelines.
> [+] MUST: The package must contain code, or permissible content. This is
> described in detail in the code vs. content section of Packaging Guidelines.
> [+] MUST: Large documentation files should go in a doc subpackage.
> [+] MUST: If a package includes something as %doc, it must not affect the
> runtime of the application.
> [+] MUST: Header files must be in a -devel package.
> [+] MUST: Static libraries must be in a -static package.
> [+] MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig'
> (for directory ownership and usability).
> [] MUST: If a package contains library files with a suffix (e.g.
> libfoo.so.1.1), then library files that end in .so (without suffix) must go in
> a -devel package.
> [=] MUST: In the vast majority of cases, devel packages must require the base
> package using a fully versioned dependency: Requires: %{name} =
> %{version}-%{release} 
> Fails as noticed by rpmlint

Fixed.

> [=] MUST: Packages must NOT contain any .la libtool archives, these should be
> removed in the spec.
> There is a .la and a .a file, drop them.

Fixed.
 
> [+] MUST: Packages containing GUI applications must include a %{name}.desktop
> file, and that file must be properly installed with desktop-file-install in the
> %install section.
> [?] MUST: Packages must not own files or directories already owned by other
> packages.
> I notice this create /var/log/xroot and xrootd creates /var/log/xrootd ... Is
> that intentional?

Dropped. The directory comes with the xrootd package, and dpm-xrootd was putting the files in a different one (that's why it was needed).

> [+] MUST: At the beginning of %install, each package MUST run rm -rf
> %{buildroot} (or $RPM_BUILD_ROOT).
> Only needed for RHEL5.
> [+] MUST: All filenames in rpm packages must be valid UTF-8.
> 
> SHOULD Items:
> [+] SHOULD: The reviewer should test that the package builds in mock.
> [+] SHOULD: The package should compile and build into binary rpms on all
> supported architectures.
> [To be done] SHOULD: The reviewer should test that the package functions as
> described.
> [=] SHOULD: If scriptlets are used, those scriptlets must be sane.
> ldconfig on devel should not be there.

Fixed.

> [=] SHOULD: Usually, subpackages other than devel should require the base
> package using a fully versioned dependency.
> See above.

Fixed.

> [] SHOULD: The placement of pkgconfig(.pc) files depends on their usecase, and
> this is usually for development purposes, so should be placed in a -devel pkg.
> A reasonable exception is that the main pkg itself is a devel tool not
> installed in a user runtime, e.g. gcc or gdb.
> [+] SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin,
> /usr/bin, or /usr/sbin consider requiring the package which provides the file
> instead of the file itself.
> [+] SHOULD: Packages should try to preserve timestamps of original installed
> files.
> 
> Comments beyond what is above:
> (1) CFLAGS do not look correct:
> g++ "-DPACKAGE_NAME=\"DPM xrootd\"" -DPACKAGE_TARNAME=\"dpm-xrootd\"
> -DPACKAGE_VERSION=\"0.0.0\" "-DPACKAGE_STRING=\"DPM xrootd 0.0.0\""
> -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DSTDC_HEADERS=1
> -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1
> -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1
> -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\"
> -DPACKAGE=\"dpm-xrootd\" -DVERSION=\"0.0.0\" -D_THREAD_SAFE=1 -D_REENTRANT=1
> -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64 -I. -I../ -I/usr/include/xrootd/
> -I /usr/include/dpm -DXRDDPM_BUILDDATE=\"121111200750\" -g -O2 -MT
> libXrdDPMXmi_la-XrdDPMXmi.lo -MD -MP -MF .deps/libXrdDPMXmi_la-XrdDPMXmi.Tpo -c
> XrdDPMXmi.cc  -fPIC -DPIC -o .libs/libXrdDPMXmi_la-XrdDPMXmi.o

Fixed (major cleanup thanks to the move to cmake).
 
> (2) Templates present but no configuration.
> I presume that 
> %config(noreplace) %{_sysconfdir}/sysconfig/dpm-xrd.templ
> %config(noreplace) %{_sysconfdir}/xrd.authz.cnf.templ
> %config(noreplace) %{_sysconfdir}/xrd.dpm.cf.templ
> 
> are template files and not the live files?
> Better to move or at least copy them into the used location.

Fixed as suggested.

> (3) The devel package can drop these %doc since they are in the main
>    package. On a similar node the NEWS and AUTHORS file seem
>    pointless.

Fixed as suggested.
Comment 6 Steve Traylen 2011-11-18 18:37:01 EST
Not checked the details of everything but from your comments
licensing still to sort out with upstream.

Ignore till then.
Comment 7 Ricardo Rocha 2011-11-21 10:58:56 EST
Licensing figured out.

Checked and it used to be that some xrootd code was in the package, but not anymore. Traces of the previous copyright replaced with CERN/IT/GT/DMS. Code simply links against xrootd libraries.

License stays GPLv3. 

New srcrpm / spec:
http://rocha.web.cern.ch/rocha/fedora/dpm-xrootd.spec
http://rocha.web.cern.ch/rocha/fedora/dpm-xrootd-2.2.4-1.src.rpm

Koji builds (success):
https://koji.fedoraproject.org/koji/taskinfo?taskID=3529805 (5E)
https://koji.fedoraproject.org/koji/taskinfo?taskID=3529811 (6E)
https://koji.fedoraproject.org/koji/taskinfo?taskID=3529816 (f16)
Comment 8 Steve Traylen 2011-12-04 12:56:17 EST
CFLAGS look good now.

/usr/lib64/ccache/c++  -fPIC -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic   -shared -Wl,-soname,libXrdDPMXmi.so.2 -o libXrdDPMXmi.so.2.2.3 CMakeFiles/XrdDPMXmi.dir/XrdDPMXmi.cc.o CMakeFiles/XrdDPMXmi.dir/XrdDPMXmiQueueAndReq.cc.o -ldpm -lXrd

there are some warnings you might like to submit upstream as improvements:

/builddir/build/BUILD/dpm-xrootd-2.2.4/src/XrdDPMXmi.cc: In member function 'void XrdDPMXmi::InitXeq()':
/builddir/build/BUILD/dpm-xrootd-2.2.4/src/XrdDPMXmi.cc:325: warning: suggest explicit braces to avoid ambiguous 'else'
/builddir/build/BUILD/dpm-xrootd-2.2.4/src/XrdDPMXmi.cc: In member function 'void XrdDPMXmi::MSSPoll()':
/builddir/build/BUILD/dpm-xrootd-2.2.4/src/XrdDPMXmi.cc:359: warning: deprecated conversion from string constant to 'char*'
/builddir/build/BUILD/dpm-xrootd-2.2.4/src/XrdDPMXmi.cc: In member function 'int XrdDPMXmi::SetDefaultsAndReadConfig(XrdCmsXmiEnv*)':
/builddir/build/BUILD/dpm-xrootd-2.2.4/src/XrdDPMXmi.cc:1640: warning: comparison between signed and unsigned integer expressions
/builddir/build/BUILD/dpm-xrootd-2.2.4/src/XrdDPMXmi.cc: In function 'char* prefix_mad(const char*, char*, size_t)':
/builddir/build/BUILD/dpm-xrootd-2.2.4/src/XrdDPMXmi.cc:1868: warning: comparison between signed and unsigned integer expressions

Now installing the package and checking basics:

Sorry I missed this earlier:
/etc/init.d/dpm-cms
/etc/init.d/dpm-manager-cms
/etc/init.d/dpm-manager-xrd
/etc/init.d/dpm-xrd

should all be in %{_initrddir}.

The various start up scripts look dodgy not to say the least:


# service dpm-cms start
Error: /opt/lcg/bin/dpm-cmsd does not exist

# service dpm-manager-cms start
Error: /opt/lcg/bin/dpm-manager-cmsd does not exist

# service dpm-manager-xrd start
Error: /opt/lcg/bin/dpm-manager-xrootd does not exist

# service dpm-xrd start
Error: /opt/lcg/bin/dpm-xrootd does not exist

More over these all return 0.

Please have default configurations work or at the very least return
a sensible error code:

http://fedoraproject.org/wiki/Packaging:SysVInitScript#Exit_Codes_for_non-Status_Actions
Comment 9 Ricardo Rocha 2012-05-24 17:15:03 EDT
Hi.

I would like to revive this review. Upstream has done significant changes to provide something that can be properly deployed.

Here's the new try:
http://rocha.web.cern.ch/rocha/fedora/dpm-xrootd.spec
http://rocha.web.cern.ch/rocha/fedora/dpm-xrootd-3.0.0-2.fc16.src.rpm

Koji build (rawhide):
http://koji.fedoraproject.org/koji/taskinfo?taskID=4099586

Regards,
Ricardo
Comment 10 Adrien Devresse 2012-06-22 05:20:51 EDT
Conform to the requester wish, I take care of this.


First comments :

- build failure on f16/el/e6 ( I have not tested the other ) : 
  ->http://koji.fedoraproject.org/koji/taskinfo?taskID=4187213
  ->  http://koji.fedoraproject.org/koji/taskinfo?taskID=4187245

-> BuildRequires 

- %{isa}  macro is not required on BuildRequires

- BuildRequires:	xrootd-libs is implicite in xrootd-devel

- GPL 3 -> No license file or no license in headers.

- shadowutil dependency -> not needed if no user/group modifications

- It is a good pratice to use %macro or $macro but not both for lisibility
Comment 11 Adrien Devresse 2012-06-22 05:27:28 EDT
 correction on my side : License File is present under file COPYING
Comment 12 Ricardo Rocha 2012-06-26 10:46:16 EDT
Hi.

Thanks for looking at this.

See inline.

(In reply to comment #10)
> Conform to the requester wish, I take care of this.
> 
> 
> First comments :
> 
> - build failure on f16/el/e6 ( I have not tested the other ) : 
>   ->http://koji.fedoraproject.org/koji/taskinfo?taskID=4187213
>   ->  http://koji.fedoraproject.org/koji/taskinfo?taskID=4187245

Forgot to say it, but for the moment it's aimed only at rawhide - that's where xrootd >= 3.2 is available for now, which we depend on.

> -> BuildRequires 
> 
> - %{isa}  macro is not required on BuildRequires
> 
> - BuildRequires:	xrootd-libs is implicite in xrootd-devel
> 
> - GPL 3 -> No license file or no license in headers.
> 
> - shadowutil dependency -> not needed if no user/group modifications
> 
> - It is a good pratice to use %macro or $macro but not both for lisibility

All fixed. I've updated the spec to build the new upstream release 3.1.0.

http://rocha.web.cern.ch/rocha/fedora/dpm-xrootd.spec
http://rocha.web.cern.ch/rocha/fedora/dpm-xrootd-3.1.0-1.src.rpm

Koji build (rawhide):
http://koji.fedoraproject.org/koji/taskinfo?taskID=4196700

Thanks again,
  Ricardo
Comment 13 Adrien Devresse 2012-07-02 05:22:26 EDT
First official review :

OK: rpmlint must be run on the source rpm and all binary rpms the build produces. The output should be posted in the review.

dpm-xrootd.src: W: invalid-url Source0: dpm-xrootd-3.1.0.tar.gz
dpm-xrootd-devel.x86_64: W: no-documentation
4 packages and 0 specfiles checked; 0 errors, 2 warnings.

	-> minor warnings, documentation files should be added if possible in future.

OK: The package must be named according to the Package Naming Guidelines .
OK: The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exemption. 
MUST: The package must meet the Packaging Guidelines .
OK: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines .
OK: The License field in the package spec file must match the actual license. 
OK: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc.
OK: The spec file must be written in American English.
OK: The spec file for the package MUST be legible. 
OK: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use md5sum for this task. If no upstream URL can be specified for this package, please see the Source URL Guidelines for how to deal with this.
OK: The package MUST successfully compile and build into binary rpms on at least one primary architecture. 

		-> validated for rawhide.

OK: If the package does not successfully compile, build or work on an architecture, then those architectures should be listed in the spec in ExcludeArch. Each architecture listed in ExcludeArch MUST have a bug filed in bugzilla, describing the reason that the package does not compile/build/work on that architecture. The bug number MUST be placed in a comment, next to the corresponding ExcludeArch line. 
OK: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines ; inclusion of those as BuildRequires is optional. Apply common sense.
OK: The spec file MUST handle locales properly. This is done by using the %find_lang macro. Using %{_datadir}/locale/* is strictly forbidden.
OK: Every binary RPM package (or subpackage) which stores shared library files (not just symlinks) in any of the dynamic linker's default paths, must call ldconfig in %post and %postun. 
OK: Packages must NOT bundle copies of system libraries.
OK: If the package is designed to be relocatable, the packager must state this fact in the request for review, along with the rationalization for relocation of that specific package. Without this, use of Prefix: /usr is considered a blocker. 
OK: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory. 
OK: A Fedora package must not list a file more than once in the spec file's %files listings. (Notable exception: license texts in specific situations)
OK: Permissions on files must be set properly. Executables should be set with executable permissions, for example. 
OK: Each package must consistently use macros. 
OK: The package must contain code, or permissable content. 
N/A: Large documentation files must go in a -doc subpackage. (The definition of large is left up to the packager's best judgement, but is not restricted to size. Large can refer to either size or quantity). 
N/A: If a package includes something as %doc, it must not affect the runtime of the application. To summarize: If it is in %doc, the program must run properly if it is not present. 
N/A: Static libraries must be in a -static package. 
OK: Development files must be in a -devel package. 
OK: In the vast majority of cases, devel packages must require the base package using a fully versioned dependency: Requires: %{name}%{?_isa} = %{version}-%{release}
OK: Packages must NOT contain any .la libtool archives, these must be removed in the spec if they are built.
N/A: Packages containing GUI applications must include a %{name}.desktop file, and that file must be properly installed with desktop-file-install in the %install section. If you feel that your packaged GUI application does not need a .desktop file, you must put a comment in the spec file with your explanation. 
OK: Packages must not own files or directories already owned by other packages. The rule of thumb here is that the first package to be installed should own the files or directories that other packages may rely upon. This means, for example, that no package in Fedora should ever share ownership with any of the files or directories owned by the filesystem or man package. If you feel that you have a good reason to own a file or directory that another package owns, then please present that at package review time. 
OK: All filenames in rpm packages must be valid UTF-8.

OK: If the source package does not include license text(s) as a separate file from upstream, the packager SHOULD query upstream to include it. 
OK: The description and summary sections in the package spec file should contain translations for supported Non-English languages, if available.
OK: The reviewer should test that the package builds in mock.

	 mock -r fedora-rawhide-x86_64 dpm-xrootd-3.1.0-1.src.rpm

	INFO: Done(dpm-xrootd-3.1.0-1.src.rpm) Config(fedora-rawhide-x86_64) 3 minutes 45 seconds
	INFO: Results and/or logs in: /var/lib/mock/fedora-rawhide-x86_64/result
	State Changed: end

	 mock -r fedora-rawhide-i386 dpm-xrootd-3.1.0-1.src.rpm

	INFO: Done(dpm-xrootd-3.1.0-1.src.rpm) Config(fedora-rawhide-i386) 3 minutes 2 seconds
	INFO: Results and/or logs in: /var/lib/mock/fedora-rawhide-i386/result
	State Changed: end


OK: The package should compile and build into binary rpms on all supported architectures.
OK: The reviewer should test that the package functions as described. A package should not segfault instead of running, for example.
N/A: If scriptlets are used, those scriptlets must be sane. This is vague, and left up to the reviewers judgement to determine sanity. 
OK: Usually, subpackages other than devel should require the base package using a fully versioned dependency. 
N/A: The placement of pkgconfig(.pc) files depends on their usecase, and this is usually for development purposes, so should be placed in a -devel pkg. A reasonable exception is that the main pkg itself is a devel tool not installed in a user runtime, e.g. gcc or gdb.
N/A: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself. 
N/A: your package should contain man pages for binaries/scripts. If it doesn't, work with upstream to add them where they make sense.

Minor errors only :

-> missing documentation files for devel package.

Package approved for fedora rawhide.
Comment 14 Ricardo Rocha 2012-07-10 05:47:54 EDT
New Package SCM Request
=======================
Package Name: dpm-xrootd
Short Description: xroot interface to the Disk Pool Manager (DPM)
Owners: rocha
Branches: 
InitialCC:
Comment 15 Kevin Fenzi 2012-07-10 18:19:15 EDT
Git done (by process-git-requests).
Comment 16 Ricardo Rocha 2013-03-07 12:28:52 EST
Package Change Request
======================
Package Name: dpm-xrootd
New Branches: el5 el6
Owners: 
InitialCC:
Comment 17 Jon Ciesla 2013-03-07 12:36:34 EST
Must list branch owners.
Comment 18 Ricardo Rocha 2013-03-07 12:38:39 EST
Package Change Request
======================
Package Name: dpm-xrootd
New Branches: el5 el6
Owners: rocha
InitialCC:
Comment 19 Jon Ciesla 2013-03-07 12:44:36 EST
Git done (by process-git-requests).

Note You need to log in before you can comment on or make changes to this bug.