Bug 7493 - libtool package provides source but no compiled library
libtool package provides source but no compiled library
Product: Red Hat Linux
Classification: Retired
Component: libtool (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Depends On:
  Show dependency treegraph
Reported: 1999-12-01 15:37 EST by jfm3
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-12-22 11:33:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description jfm3 1999-12-01 15:37:38 EST
OK, maybe there's a reason but I don't know it.

The libtool package that comes with redhat simply dumps a bunch of sources
in your share directory, but no compiled libraries.

As a result, the build process for an Open Source project I'm helping with
(http://www.quasimodo.org) is butt-ugly.

Why is there no libltdl.* in the libtool rpm?

Comment 1 Jeff Johnson 1999-12-02 09:38:59 EST
Adding the library to libtool would necessitate changing libtool from a noarch
to a per-arch package. So far, there is no Red Hat package that needs the
functionality supplied by the libtool libraries. Can you supply some more
details regarding why the libtool libraries have to be included? Meanwhile,
it's pretty trivial to make an arch-specific libtool package including the
libraries if that simplifies your project.
Comment 2 Jeff Johnson 1999-12-22 11:33:59 EST
Fixed in libtool-1.3.3-2 in Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.