Bug 74934 - noatun rpm packaging problem
noatun rpm packaging problem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdemultimedia (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 17:40 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-05 09:03:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-02 17:40:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
rpm -qp noatun-3.0.3-4.i386.rpm --provides

Lots of output, then...
noatun = 6:3.0.3-4

If I try to freshen the existing 'noatun':
    rpm -Fvh noatun-3.0.3-4.i386.rpm

I see this:

error: Failed dependencies:
        noatun = 3.0.3 is needed by (installed) kdemultimedia-devel-3.0.3-4


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -Fvh noatun-3.0.3-4.i386.rpm
	

Actual Results:  error: Failed dependencies:
        noatun = 3.0.3 is needed by (installed) kdemultimedia-devel-3.0.3-4


Expected Results:  Program should have been installed, replacing the existing
noatun:

rpm -qa|grep noatun
noatun-3.0.3-1


Additional info:
Comment 1 Ngo Than 2002-10-05 07:48:07 EDT
does it work if you update all rpms from kdemultimedia-3.0.3-4 ?
perhaps are some bugs from the 8.0 beta.
Comment 2 Need Real Name 2002-10-05 09:03:37 EDT
$ grep kdemultim /var/log/rpmpkgs
kdemultimedia-arts-3.0.3-4.i386.rpm
kdemultimedia-devel-3.0.3-4.i386.rpm
kdemultimedia-kfile-3.0.3-4.i386.rpm
kdemultimedia-libs-3.0.3-4.i386.rpm

All kde rpms are updated.

$ rpm -qp kdemultimedia-devel-3.0.3-4.i386.rpm --requires
kdemultimedia-arts = 3.0.3
noatun = 3.0.3
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

Looks like kdemultimedia-devel wants noatun-3.0.3.
Comment 3 Ngo Than 2002-10-16 11:49:31 EDT
it's very strange here. The dependency looks correct to me.
The kdemultimedia-devel requires noatun-3.0.3, and the noatun rpm package, which
you want to update, has version number as 3.0.3-4.

I have added some more sane requires in kdemultimedia-3.0.4-1, which should fix
this issue, although i really cannot reproduce it on my local machine.
Comment 4 Need Real Name 2002-10-16 21:39:44 EDT
On 10/16/2002 I ran up2date. It told me to install these files:

ggv-1.99.9-5.i386.rpm, noatun-3.0.3-4.i386.rpm, tetex-1.0.7-57.1.i386.rpm, and
tetex-dvips-1.0.7-57.1.i386.rpm.

I downloaded all the files, and they all installed perfectly. I then compared
the noatun downloaded with the one in the psyche distro, and they WERE THE SAME!

I honestly do not get it at all, but my system is up to date and noatun
installed fine.


Note You need to log in before you can comment on or make changes to this bug.