Bug 74941 - RPM package download "succeeds" with 0 length download
RPM package download "succeeds" with 0 length download
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 18:41 EDT by Nick Mumbach
Modified: 2007-04-18 12:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 03:52:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Mumbach 2002-10-02 18:41:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
When I started to download an RPM file, I decided to tell Linux to "use" rpm to
run the update from the 'net.  After download began, I realized I wanted to
update my laptop as well, so I cancelled and changed to 'Save to a file' (the
"always ask" checkbox is checked!) then started again. The resulting download
finishes immediately, and results in a 0-length destination file. In order to
download the file, I had to click on the 'Advanced' button and change from "Use
'rpm'..." to "Save to file ...", then the download worked.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. tell Linux to "use rpm" to run the download file
2. start download, with "always ask" box checked
3. change mind, cancel above action
4. try again, switching to "save to file"
5. start download
6. download begins and ends instantly, says it's done
7. target file is zero-length
8. try again, click on advanced, switch default to "save to file"
9. file successfully downloads (4 minutes)

Actual Results:  the 'Ask Every Time' button does not successfully switch modes
from 'Run with ...' to "Save to File..."

Expected Results:  Should be able to switch from default handling on an
instance-by- instance basis.

Additional info:
Comment 1 Warren Togami 2005-04-25 03:52:17 EDT
closing due to lack of activity

Note You need to log in before you can comment on or make changes to this bug.