Bug 74944 - Kudzu ddc detection segfaults on bogus horizontal/veritical sync/refresh data
Summary: Kudzu ddc detection segfaults on bogus horizontal/veritical sync/refresh data
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-02 23:04 UTC by Dan Burcaw
Modified: 2014-03-17 02:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-17 05:44:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix for this bug. (452 bytes, patch)
2002-10-02 23:05 UTC, Dan Burcaw
no flags Details | Diff

Description Dan Burcaw 2002-10-02 23:04:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.0.1) Gecko/20020827

Description of problem:
Kudzu's ddc checking uses values from the monitor's entry in MonitorsDB
if the horizontal and vertical ranges for the monitor are bogus.
Unfortunately, if the MonitorsDB doesn't have an entry for the monitor,
kudzu segfaults.  This is because it tries to access a null pointer.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run kudzu -b DDC on a monitor with bogus horz/vert ranges such as many LCDs.
Due this without that monitor having an entry in MonitorsDB.
2.
3.
	

Actual Results:  Seg fault.

Expected Results:  No seg fault. :-)

Additional info:

Attached is a patch to fix this problem.  It basically
checks not only that the ranges are bogus, but also that
we have in fact found a monitor entry in the MonitorsDB
to use.

Comment 1 Dan Burcaw 2002-10-02 23:05:04 UTC
Created attachment 78284 [details]
Proposed fix for this bug.

Comment 2 Miloslav Trmac 2002-10-03 01:21:07 UTC
duplicate of 70190 and 74424

Comment 3 Bill Nottingham 2003-01-17 05:44:46 UTC
Added, will be in 0.99.89-1.


Note You need to log in before you can comment on or make changes to this bug.