Bug 749541 - gnucash crashes trying to edit scheduled transaction
Summary: gnucash crashes trying to edit scheduled transaction
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 749552 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-27 12:12 UTC by Jonathan Kamens
Modified: 2011-11-17 23:32 UTC (History)
5 users (show)

Fixed In Version: gtk2-2.24.7-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-10 17:46:01 UTC
Type: ---


Attachments (Terms of Use)
stack trace (9.35 KB, text/plain)
2011-10-27 12:12 UTC, Jonathan Kamens
no flags Details
2.4.8 stack trace (9.34 KB, text/plain)
2011-10-27 12:34 UTC, Jonathan Kamens
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 662633 None None None Never

Description Jonathan Kamens 2011-10-27 12:12:04 UTC
Created attachment 530468 [details]
stack trace

gnucash-2.4.7-4.fc16.x86_64. All other packages current from F16.

Do the following:

1. Launch GnuCash.
2. Open scheduled transaction editor.
3. Open a transaction.
4. Edit its template transaction.
5. Click OK.
6. GnuCash crashes.

Stack trace attached.

Comment 1 Jonathan Kamens 2011-10-27 12:34:53 UTC
Created attachment 530474 [details]
2.4.8 stack trace

I built a new RPM from 2.4.8, and the problem persists.

Comment 2 Richard Marko 2011-10-27 13:44:01 UTC
*** Bug 749552 has been marked as a duplicate of this bug. ***

Comment 3 Richard Marko 2011-10-27 13:45:22 UTC
ABRT report in 749552

Comment 4 Bill Nottingham 2011-10-31 18:18:45 UTC
This appears to be a regression between gtk-2.24.6 and gtk-2.24.7.

Comment 5 Bill Nottingham 2011-10-31 18:38:48 UTC
Commit a516d2359c9eac84bfa4682a70a62315adedb1d6, to be precise.

http://git.gnome.org/browse/gtk+/commit/?h=gtk-2-24&id=a516d2359c9eac84bfa4682a70a62315adedb1d6

Comment 6 Jonathan Kamens 2011-11-02 19:32:11 UTC
A patch has been committed for the upstream bug. Would be great to get it into F16.

Comment 7 Fedora Update System 2011-11-02 22:18:58 UTC
gtk2-2.24.7-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gtk2-2.24.7-3.fc16

Comment 8 Fedora Update System 2011-11-02 22:27:19 UTC
gtk2-2.24.7-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gtk2-2.24.7-3.fc15

Comment 9 Fedora Update System 2011-11-03 21:51:55 UTC
Package gtk2-2.24.7-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gtk2-2.24.7-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15343
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-11-10 17:46:01 UTC
gtk2-2.24.7-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-11-17 23:32:20 UTC
gtk2-2.24.7-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.