This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 74957 - Printer H/W detect fails when CUPS is default
Printer H/W detect fails when CUPS is default
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
8.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 00:35 EDT by Graham Hudspith
Modified: 2014-03-16 22:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-03 00:35:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Graham Hudspith 2002-10-03 00:35:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Had (parallel-port) printer switched off. Installed RH8.0 from scratch
using custom install.

[NOTE - had to select CUPS package for installation - thought this was
the default now and that LPRng was deprecated?]

System installed fine and rebooted. Did a "Printer System Switcher"
to switch over to using CUPS.

No printer configured at this point.

Switched printer on and rebooted system.

Kudzu kicks in, finds correct model of printer and carries on.

Brought up "Red Hat Printer Config" (printconf-gui). This "knows"
about the printer, but can't print a test page (trying to use
LPRng?).

Brought up CUPS config. Does not know about printer. Had to manually
add printer (which then worked fine).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Aargh! See Description.

Actual Results:  Aargh! See Description.

Expected Results:  Either printconf-gui worked in presence of CUPS and/or
CUPS also already had newly discovered printer in config.

Additional info:
Comment 1 Bill Nottingham 2002-10-03 00:41:03 EDT
kudzu simply calls printconf, and relies on it. printconf in 8.0 only supports
LPRng.

Note You need to log in before you can comment on or make changes to this bug.