Bug 749595 - Drift detail view back button navigates to the wrong page
Drift detail view back button navigates to the wrong page
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.2
All All
high Severity high (vote)
: ---
: JON 3.0.0,RHQ 4.3.0
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: jon3 707225
  Show dependency treegraph
 
Reported: 2011-10-27 12:07 EDT by Jay Shaughnessy
Modified: 2012-02-07 14:19 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:19:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2011-10-27 12:07:56 EDT
When accessing drift detail from a drift snapshot view, the back button
sends you to an unexpected page, usually the snapshot view's parent page.
This is confusing although it's fairly easy to nav back if you need to.
Comment 1 Jay Shaughnessy 2011-11-01 14:38:44 EDT
maser commit         : 943c020ba2c50878efbf134def1db714d09507a3
release_jon3.x commit: e3f2d0fb110f7bda3e4fbf4f14a6b829f1bcefbb

Avoided the whole navigation issue completely by changing the approach.
Instead of going deeper into sub-pages that need to navigate back to
the snapshot view, change the snapshot view to inline the drift
detail using another level of expanding rows.  This seems much nicer
because the page already carries so much context that the amount of
data that remains to be shown is quite small.  So the use ever even
navigates off the snapshot view and can see as many expanded detail 
views as he likes.
- Also, figured out how to compress vertically, making the page more
compact and much nicer to look at.
Comment 2 Mike Foley 2012-02-07 14:19:19 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.