Bug 749647 - [GD5446_KVM] KDE fails to start in side a VM using the cirrus driver and 'raster' Qt renderer
[GD5446_KVM] KDE fails to start in side a VM using the cirrus driver and 'ras...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
16
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
[cat:others] AcceptedBlocker
: Patch, Triaged, Upstream
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-27 15:12 EDT by Martin Kho
Modified: 2013-10-03 20:21 EDT (History)
21 users (show)

See Also:
Fixed In Version: qt-4.8.0-0.23.rc1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-29 02:30:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kdm.log (15.27 KB, text/plain)
2011-10-27 15:15 EDT, Martin Kho
no flags Details
var/log/messages (777.14 KB, text/plain)
2011-10-27 15:16 EDT, Martin Kho
no flags Details
Xorg.0.log (27.13 KB, text/plain)
2011-10-27 15:16 EDT, Martin Kho
no flags Details
dmesg (32.93 KB, text/plain)
2011-10-27 15:17 EDT, Martin Kho
no flags Details
Xorg.0.log (27.05 KB, text/plain)
2011-10-27 23:02 EDT, Andre Robatino
no flags Details
/var/log/messages (66.38 KB, text/plain)
2011-10-27 23:03 EDT, Andre Robatino
no flags Details
.xsession-errors (20.93 KB, text/plain)
2011-10-27 23:05 EDT, Andre Robatino
no flags Details
dmesg from final TC3 guest (34.25 KB, text/plain)
2011-10-28 06:45 EDT, Martin Kho
no flags Details
kdm.log from final TC3 guest (1.50 KB, text/plain)
2011-10-28 06:46 EDT, Martin Kho
no flags Details
messages from final TC3 guest (90.30 KB, text/plain)
2011-10-28 06:47 EDT, Martin Kho
no flags Details
Xorg.0.log from final TC3 guest (27.05 KB, text/plain)
2011-10-28 06:47 EDT, Martin Kho
no flags Details
xsession-errors from final TC3 guest (21.33 KB, text/plain)
2011-10-28 06:49 EDT, Martin Kho
no flags Details

  None (edit)
Description Martin Kho 2011-10-27 15:12:58 EDT
Description of problem:
Booting the F16 Beta, Final TC2 KDE x86_64 live image inside a virt-manager VM - host
F15, F16, using the cirrus video adapter - results in KDE crashing right at
the end of startup (after it displays the KDE logo in the bootsplash sequence) giving a black screen.

Booting in 'basic graphics mode' - i.e. using vesa instead of the cirrus
driver - works.

Version-Release number of selected component (if applicable):
xorg-x11-drv-cirrus-1.3.2-10.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot the live CD
2. Log in
3. After the initialisation plasma crashes
  
Actual results:
Black screen

Expected results:
Running plasma-desktop

Additional info:
This bug is possible related to bug #731245. The cirrus-driver is the default when installing a new VM.
Comment 1 Martin Kho 2011-10-27 15:15:21 EDT
Created attachment 530548 [details]
kdm.log
Comment 2 Martin Kho 2011-10-27 15:16:11 EDT
Created attachment 530549 [details]
var/log/messages
Comment 3 Martin Kho 2011-10-27 15:16:48 EDT
Created attachment 530550 [details]
Xorg.0.log
Comment 4 Martin Kho 2011-10-27 15:17:57 EDT
Created attachment 530551 [details]
dmesg
Comment 5 Adam Williamson 2011-10-27 16:57:56 EDT
er, kdm.log shows a backtrace in qxl, not cirrus. are you sure this is using cirrus? are you sure you have the right logs?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Oliver Henshaw 2011-10-27 17:10:05 EDT
As with the qxl bug, this only happens with the (new) default of "QT_GRAPHICSSYSTEM=raster" - see bug #731245 comment #32.
Comment 7 Martin Kho 2011-10-27 17:13:25 EDT
Hi,

Arch, I'll create a new kdm.log from TC3 final. Sorry :-(


Martin Kho
Comment 8 Adam Williamson 2011-10-27 18:45:28 EDT
updating the summary, nominating as a blocker, because F15 defaults to cirrus/vnc not qxl/spice, unfortunately :( as we 'support' both F-N and F-N-1 as virt hosts in the criteria, we need both cirrus and qxl drivers to work with raster, so KDE will run on both F15 and F16 KVM host default configs.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Adam Williamson 2011-10-27 18:47:22 EDT
to reproduce this, btw, just create a VM in Fedora 15 virt-manager with all default settings and try to boot an F16 live KDE image. that should be all that's needed.
Comment 10 Adam Williamson 2011-10-27 18:49:21 EDT
To expand on Oliver's comment #6: Qt's default rendering engine changed from 'native' (which uses Xrender) to 'raster' (software rasterization) in Qt 4.8, and that's what 'broke', here (why this works in F15 and not F16). Switching back to 'native' by default would be sub-optimal for reasons discussed in https://bugzilla.redhat.com/show_bug.cgi?id=731245#c85 , so we really want the cirrus driver to be fixed with respect to Qt's 'raster' rendering, that would be the best solution. thanks!
Comment 11 Andre Robatino 2011-10-27 22:45:42 EDT
I can reproduce this using either the 32- or 64-bit TC3 Live KDE image booted in either a 32- or 64-bit F16 KVM guest (both default installs from the respective TC3 DVDs). My host is F15 x86_64. As long as the guest video driver is set to cirrus, it happens, with the display being set to either VNC or Spice. Booting the 64-bit Live always results in a black screen, while booting the 32-bit Live usually results in a crosshatch pattern (though I did see a black screen the first time booting it).
Comment 12 Andre Robatino 2011-10-27 23:01:48 EDT
Attached below are logs associated with the 64-bit TC3 Live KDE image booted in the 64-bit F16 KVM guest, using VNC+cirrus. I got a black screen.
Comment 13 Andre Robatino 2011-10-27 23:02:52 EDT
Created attachment 530603 [details]
Xorg.0.log
Comment 14 Andre Robatino 2011-10-27 23:03:38 EDT
Created attachment 530604 [details]
/var/log/messages
Comment 15 Andre Robatino 2011-10-27 23:05:07 EDT
Created attachment 530605 [details]
.xsession-errors
Comment 16 Adam Williamson 2011-10-28 01:52:46 EDT
Adding CCs for blocker votes. I'm +1 on this, given that cirrus seems to be the default for at least 32-bit VMs in both F15 and F16, and possibly 64-bit in F15.
Comment 17 Martin Kho 2011-10-28 06:45:55 EDT
Created attachment 530639 [details]
dmesg from final TC3 guest
Comment 18 Martin Kho 2011-10-28 06:46:32 EDT
Created attachment 530640 [details]
kdm.log from final TC3 guest
Comment 19 Martin Kho 2011-10-28 06:47:20 EDT
Created attachment 530641 [details]
messages from final TC3 guest
Comment 20 Martin Kho 2011-10-28 06:47:56 EDT
Created attachment 530642 [details]
Xorg.0.log from final TC3 guest
Comment 21 Martin Kho 2011-10-28 06:49:35 EDT
Created attachment 530643 [details]
xsession-errors from final TC3 guest
Comment 22 Martin Kho 2011-10-28 07:00:41 EDT
Hi,

abrt created a core-dump. Is this info interesting? What files?


Martin Kho
Comment 23 Kamil Páral 2011-10-28 08:01:11 EDT
Reproduced. +1 blocker.
Comment 24 Jared Smith 2011-10-28 11:30:47 EDT
+1 blocker
Comment 25 Robyn Bergeron 2011-10-28 12:51:50 EDT
+1 blocker
Comment 26 Adam Williamson 2011-10-28 14:49:44 EDT
Discussed at 2011-10-28 blocker review meeting. Accepted as a blocker per criterion "Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase" as applied to the KDE desktop + cirrus driver combination.
Comment 27 Adam Williamson 2011-10-28 16:19:56 EDT
We have significant progress here. We're pretty sure it's:

https://bugreports.qt.nokia.com/browse/QTBUG-21754

rdieter is working on a Qt build with that patch to test.
Comment 29 Rex Dieter 2011-10-28 18:01:51 EDT
snarf over to qt
Comment 30 Fedora Update System 2011-10-28 18:02:50 EDT
qt-4.8.0-0.23.rc1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qt-4.8.0-0.23.rc1.fc16
Comment 31 Adam Williamson 2011-10-28 18:15:05 EDT
I tested the fix, it looks good. I'm uploading a new live image with the fix included.
Comment 32 Adam Williamson 2011-10-28 18:58:10 EDT
If you want to test the fix for this, grab http://adamwill.fedorapeople.org/adamwkde-20111028-x86_64.iso (sha256sum 97a4d9429ec4e06cbb9d3ebeb010fd044ae66d49abeb58915714bb8f4cb49594 ). It has the fix for this and the fix for the qxl bug, so both qxl and cirrus VMs should work with it. Works for me.
Comment 33 Fedora Update System 2011-10-29 02:30:30 EDT
qt-4.8.0-0.23.rc1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 34 Red Hat Bugzilla 2013-10-03 20:21:29 EDT
Removing external tracker bug with the id '21754' as it is not valid for this tracker

Note You need to log in before you can comment on or make changes to this bug.