Bug 74968 - Raid-1/LVM/lilo doesn't boot. Stops an "LI"
Raid-1/LVM/lilo doesn't boot. Stops an "LI"
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 04:01 EDT by Stuart Inglis
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-03 02:37:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Inglis 2002-10-03 04:01:32 EDT
Description of Problem:

I installed a LVM'ed RAID-1 over hda/hdb. I chose lilo for historical reasons.
On reboot I got to the old "LI" prompt instead of lilo.  I reinstalled exactly
the same way but selected grub instead of lilo. This time everything worked ok. 

Version-Release number of selected component (if applicable):

8.0

How Reproducible:

Only tried lilo once, then went to grub.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Michael Fulbright 2002-10-03 13:32:55 EDT
Was your /boot located on a regular partition or on LVM/RAID?
Comment 2 Stuart Inglis 2002-10-03 15:13:12 EDT
Yes, /, /boot and swap were LVM/RAID1
Comment 3 Jeremy Katz 2002-10-25 15:38:07 EDT
You shouldn't have been able to have /boot on the logical volume -- I get
"bootable partitions cannot be on a logical volume" error when I try.  

Just to be clear, you had

/dev/hda1 - software RAID partition
/dev/hdb1 - software RAID partition
/dev/md0 - RAID 1, physical volume
Volume00 - Volume Group made up of /dev/md0

And then you had /, /boot, and swap on Volume00?
Comment 4 Jeremy Katz 2003-01-03 02:37:43 EST
Closing due to inactivity.  If you have any further information to add to this
bug, please feel free to reopen it.

Note You need to log in before you can comment on or make changes to this bug.