Bug 749688 - Knotes does not display contents of akonadi notes.ics resource
Summary: Knotes does not display contents of akonadi notes.ics resource
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdepim
Version: 16
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-27 22:34 UTC by Peter Gückel
Modified: 2013-01-17 20:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-14 05:07:39 UTC


Attachments (Terms of Use)

Description Peter Gückel 2011-10-27 22:34:41 UTC
Description of problem:
Knotes does not display contents of akonadi notes.ics resource.

Version-Release number of selected component (if applicable):
kdepim-4.7.2-5.fc16.x86_64

How reproducible:
In systemsettings, configure an akonadi resource of type notes (loads data from a notes file) and give it the pathname and name of the notes.ics file to use. Apply and close systemsettings. Start knotes and display all notes. The note will not be shown, even though the notes.ics file is readable in kwrite and is configured correctly in akonadi.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
This worked in kde 4.7.0 (ie., until only about 2 version jumps ago), but ceased to work in 4.7.1 and onward.

Comment 1 Sergey Kondakov 2013-01-17 20:07:51 UTC
any reason for this being silently closed and tagged as not a bug ?

because i did just decided to try out Fedora for myself and stumbled on this behaviour. previously i was able to migrate my KDE settings, including for KNotes, by pointing akonadi from new installation to files left from /home of other distribution into Gentoo, and it worked properly.
but not now, not in Fedora. doesn't seem normal to me.

Comment 2 Sergey Kondakov 2013-01-17 20:24:58 UTC
ah, i just managed to "fix" it up: removed all other "note"-type resources from akonadi, changed ics's path into bogus one and back, after which it destroyed my note-file, i restored it from backup, and now it reads it.

totally insane and, probably, not Fedora specific. so, it's arguable, if that intentional KDE's design is a bug, but it for sure is not OK, and these actions are not a real fix. even by their design intentions, it should read from all sources.


Note You need to log in before you can comment on or make changes to this bug.