Bug 74971 - diffstat doesn't like diffs from diff -u
Summary: diffstat doesn't like diffs from diff -u
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: diffstat (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-03 08:46 UTC by Joe Orton
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-17 14:17:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2002-10-03 08:46:17 UTC
Description of Problem:
diffstat doesn't seem to like diffs from "diff -u" in 8.0

Version-Release number of selected component (if applicable):
diffstat-1.28-4, diffutils-2.8.1-3

How Reproducible:
Always

Steps to Reproduce:
1. echo foo > /tmp/a
2. echo bar > /tmp/b
3. diff -u /tmp/a /tmp/b | diffstat

Actual Results:
with 8.0, diffstat output is:
 0 files changed

Expected Results:
with 7.3, diffstat output is:
 b |    2 +-
 1 files changed, 1 insertion(+), 1 deletion(-)


Additional Information:
LANG=en_GB.UTF-8 if that affects diff -u output

Comment 1 Tim Waugh 2002-10-03 08:52:33 UTC
I expect it's because of the new-style timestamp format.

Comment 2 Tim Waugh 2002-10-03 09:07:21 UTC
This seems to be fixed upstream (1.31).

Comment 3 Tim Waugh 2002-10-18 13:18:17 UTC
Fixed package is diffstat-1.31-1.


Note You need to log in before you can comment on or make changes to this bug.