Bug 749716 - deltacloud on RHEL fails to start after aeolus-restart-services
deltacloud on RHEL fails to start after aeolus-restart-services
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: deltacloud-core (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: marios
wes hayutin
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-27 22:40 EDT by wes hayutin
Modified: 2012-05-15 16:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 16:32:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2011-10-27 22:40:43 EDT
Description of problem:

[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
 is stopped
[root@qeblade30 ~]# /etc/init.d/deltacloud-core start
[  OK  ] deltacloud-core: [  OK  ]
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
 is stopped
[root@qeblade30 ~]# ps -ef | grep deltacloud
root     19285 13668  0 22:37 pts/0    00:00:00 grep deltacloud
[root@qeblade30 ~]# tail -n 30 /var/log/deltacloud-core/mock.log 
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:151:in `run!'
	from /usr/share/deltacloud-core/bin/deltacloudd:223
	from /usr/bin/deltacloudd:5:in `load'
	from /usr/bin/deltacloudd:5
Starting Deltacloud API :: mock :: http://localhost:3002/api

/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:171:in `chdir': Permission denied - /root (Errno::EACCES)
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:171:in `run_command'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:151:in `run!'
	from /usr/share/deltacloud-core/bin/deltacloudd:223
	from /usr/bin/deltacloudd:5:in `load'
	from /usr/bin/deltacloudd:5
Starting Deltacloud API :: mock :: http://localhost:3002/api

/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:171:in `chdir': Permission denied - /root (Errno::EACCES)
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:171:in `run_command'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:151:in `run!'
	from /usr/share/deltacloud-core/bin/deltacloudd:223
	from /usr/bin/deltacloudd:5:in `load'
	from /usr/bin/deltacloudd:5
Starting Deltacloud API :: mock :: http://localhost:3002/api

/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:171:in `chdir': Permission denied - /root (Errno::EACCES)
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:171:in `run_command'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:151:in `run!'
	from /usr/share/deltacloud-core/bin/deltacloudd:223
	from /usr/bin/deltacloudd:5:in `load'
	from /usr/bin/deltacloudd:5
Starting Deltacloud API :: mock :: http://localhost:3002/api


[root@qeblade30 ~]# rpm -qa | grep deltacloud
deltacloud-core-ec2-0.4.1-3.el6.noarch
rubygem-deltacloud-client-0.4.0-3.el6.noarch
deltacloud-core-0.4.1-3.el6.noarch
deltacloud-core-rhevm-0.4.1-3.el6.noarch
deltacloud-core-vsphere-0.4.1-3.el6.noarch
[root@qeblade30 ~]# rpm -qa | grep aeolus
aeolus-conductor-daemons-0.5.0-0.20111025005411git5ff5abd.el6.noarch
rubygem-ZenTest-4.3.3-2.aeolus.el6.noarch
rubygem-arel-2.0.10-0.aeolus.el6.noarch
aeolus-configure-2.2.0-1.20111024205543gitf9232cc.el6.noarch
aeolus-conductor-0.5.0-0.20111025005411git5ff5abd.el6.noarch
aeolus-conductor-doc-0.5.0-0.20111025005411git5ff5abd.el6.noarch
aeolus-all-0.5.0-0.20111025005411git5ff5abd.el6.noarch
rubygem-aeolus-cli-0.1.0-3.20111024205439gitc3aa990.el6.noarch
rubygem-aeolus-image-0.1.0-4.20111024205454git6b2b696.el6.noarch
rubygem-rack-mount-0.7.1-3.aeolus.el6.noarch
[root@qeblade30 ~]# 


[root@qeblade30 ~]# cat /etc/init.d/deltacloud-core 
#!/bin/sh
#
# deltacloud-core   Deltacloud API Core
# chkconfig: 345 90 60
# description: deltacloud-core is primary server process for the \
#             Deltacloud Core component.

### BEGIN INIT INFO
# Provides: deltacloud-core
# Required-Start: 
# Required-Stop: 
# Default-Start: 3 5 
# Default-Stop: 0 1 2 6 
# Short-Description: Deltacloud Core API deamon
# Description: Deltacloud Core API provides access to different cloud providers \
#   using single REST API 
### END INIT INFO

. /etc/rc.d/init.d/functions

[ -r /etc/sysconfig/deltacloud-core ] && . /etc/sysconfig/deltacloud-core

exec="/usr/bin/deltacloudd"
prog="deltacloud-core"

[ ! -d /var/log/$prog ] && mkdir -p /var/log/$prog

# You can overide these variables using /etc/sysconfig/deltacloud-core
API_ENV="${API_ENV:-production}"
DRIVER="${DRIVER:-mock}"
PORT="${PORT:-3002}"
HOST="${HOST:-localhost}"
DELTACLOUD_USER="${DELTACLOUD_USER:-nobody}"
LOGFILE="${LOGFILE:-/var/log/$prog/$DRIVER.log}"
LOCKFILE="${LOCKFILE:-/var/lock/subsys/$prog}"

[ -r $LOGFILE ] && chown nobody $LOGFILE
[ -r $LOCKFILE ] && chown nobody $LOCKFILE

start() {
    [ -x $exec ] || exit 5

    echo -n $"Starting $prog: "
    daemon --user "$DELTACLOUD_USER" "$exec -i $DRIVER -e $API_ENV --port $PORT -r $HOST >> $LOGFILE 2>&1 &"
    retval=$?

    if [ $retval -eq 0 ] && touch $LOCKFILE ; then
      echo_success
      echo
    else
      echo_failure
      echo
    fi
    return $retval
}

stop() {
    echo -n $"Shutting down $prog: "
    killproc deltacloudd
    retval=$?
    if [ $retval -eq 0 ] && rm -f $LOCKFILE ; then
      echo_success
      echo
    else
      echo_failure
      echo
    fi
    return $retval
}

case "$1" in
    start)
      start
      ;;
    stop)
      stop
      ;;
    restart)
      stop
      start
      ;;
    reload)
      ;;
    force-reload)
      restart
      ;;
    status)
      status -p $PIDFILE $prog
      retval=$?
      ;;
    *)
      echo "Usage: $prog {start|stop|restart|status}"
      exit 1
  ;;
esac

exit $retval
[root@qeblade30 ~]# 



[root@qeblade30 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.1 (Santiago)
[root@qeblade30 ~]#
Comment 1 jrd 2011-10-28 09:12:12 EDT
Marios, is this something you and/or David can do something with?
Comment 2 Hugh Brock 2011-10-28 09:23:48 EDT
This failure will block the release of this sprint to testers. We need it fixed ASAP.
Comment 3 marios 2011-10-28 12:31:58 EDT
duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=743263

basically 2 issues.

init script 'start' was failing due to the permission issue identify in 743263 (as suggested by clalance, adding 'cd /' before invoking the daemon fixes that )

also, the init script 'start' was not setting a PIDFILE which is why status was not playing nicely. Even when deltacloudd was started correctly, 'status' was reporting it as not running. And so if you tried to start it again, it would fail as there was already a process listening on port 3002 (the earlier deltacloudd that 'status' was telling us was dead). Setting the PIDFILE on start and clearing it out on stop fixes this.
Comment 5 wes hayutin 2011-11-11 07:35:59 EST
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
 is stopped
[root@qeblade30 ~]# /etc/init.d/deltacloud-core start
[  OK  ] deltacloud-core: [  OK  ]
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
 is stopped


Starting Deltacloud API :: mock :: http://localhost:3002/api

/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:171:in `chdir': Permission denied - /root (Errno::EACCES)
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:171:in `run_command'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:151:in `run!'
	from /usr/share/deltacloud-core/bin/deltacloudd:223
	from /usr/bin/deltacloudd:5:in `load'
	from /usr/bin/deltacloudd:5
Starting Deltacloud API :: mock :: http://localhost:3002/api

[root@qeblade30 ~]# rpm -qa | grep deltacloud
deltacloud-core-0.4.1-5.el6.noarch
rubygem-deltacloud-client-0.4.0-3.el6.noarch
deltacloud-core-rhevm-0.4.1-5.el6.noarch
deltacloud-core-ec2-0.4.1-5.el6.noarch
deltacloud-core-vsphere-0.4.1-5.el6.noarch
Comment 6 Michal Fojtik 2011-11-11 07:53:37 EST
Seems like the init script change made by Marios disappear somehow from RHEL packages... Going to update the F16 with this fix and ping eggs to rebuild RHEL package with this fix. Thanks for catching this issue Wes!
Comment 7 Michal Fojtik 2011-11-11 11:21:29 EST
https://admin.fedoraproject.org/updates/deltacloud-core-0.4.1-6.fc16

This package update should fix the init script problem. Can you please confirm that?
Comment 8 wes hayutin 2011-11-13 21:04:58 EST
[root@qeblade30 ~]# ps -ef | grep deltacloud
root     15526 15499  0 21:02 pts/0    00:00:00 grep deltacloud
[root@qeblade30 ~]# /etc/init.d/deltacloud-core stop
Shutting down deltacloud-core: /etc/init.d/deltacloud-core: line 61: kill: (12317) - No such process
[FAILED]
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
deltacloud-core dead but pid file exists
[root@qeblade30 ~]# rm -Rf /var/lib/d
dav/      dbus/     dhclient/ dnsmasq/  
[root@qeblade30 ~]# less /etc/init.d/deltacloud-core 
[root@qeblade30 ~]# rm -Rf /var/run/deltacloud-core-mock.pid 
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
deltacloud-core dead but subsys locked
[root@qeblade30 ~]# /etc/init.d/deltacloud-core start
[  OK  ] deltacloud-core-mock: [  OK  ]
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
deltacloud-core (pid  15553) is running...
[root@qeblade30 ~]# ps -ef | grep deltacloud
nobody   15553     1  6 21:03 ?        00:00:00 thin server (localhost:3002) [deltacloud-mock]                                                                                                      
root     15561 15499  0 21:03 pts/0    00:00:00 grep deltacloud
[root@qeblade30 ~]# /etc/init.d/deltacloud-core stop
Shutting down deltacloud-core: [  OK  ]
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
deltacloud-core is stopped
[root@qeblade30 ~]# aeolus-restart-services 

Stoping ntpd ...
 Success: Shutting down ntpd: [  OK  ]

Stoping imagefactory ...
 Success: Stopping imagefactory: [  OK  ]

Stoping conductor-dbomatic ...
[  OK  ]: Shutting down conductor-dbomatic: [  OK  ]

Stoping aeolus-conductor ...
 Success: Shutting down aeolus-conductor: [  OK  ]

Stoping libvirtd ...
 Success: Stopping libvirtd daemon: [  OK  ]

Stoping deltacloud-core ...
 FAILURE: Shutting down deltacloud-core: [FAILED]

Stoping qpidd ...
 Success: Stopping Qpid AMQP daemon: [  OK  ]

Stoping httpd ...
 Success: Stopping httpd: [  OK  ]

Stoping postgresql ...
 Success: Stopping postgresql service: [  OK  ]

Stoping iwhd ...
[  OK  ]: Stopping iwhd daemon:  [  OK  ]

Stoping mongod ...
 Success: Stopping mongod: [  OK  ]

Starting mongod ...
 Success: Starting mongod: [  OK  ]

Starting iwhd ...
 Success: waiting for mongod to listen on localhost:27017[  OK  ]
Starting iwhd daemon: [  OK  ]

Starting postgresql ...
 Success: Starting postgresql service: [  OK  ]

Starting httpd ...
 Success: Starting httpd: [  OK  ]

Starting qpidd ...
 Success: Starting Qpid AMQP daemon: [  OK  ]

Starting deltacloud-core ...
[  OK  ]: Starting deltacloud-core-mock: [  OK  ]

Starting libvirtd ...
 Success: Starting libvirtd daemon: [  OK  ]

Starting aeolus-conductor ...
touch: missing file operand
Try `touch --help' for more information.
 Success: Starting aeolus-conductor: [  OK  ]

Starting conductor-dbomatic ...
[  OK  ]: Starting conductor-dbomatic: [  OK  ]

Starting imagefactory ...
/usr/lib/python2.6/site-packages/oauth2/__init__.py:29: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
 Success: Starting imagefactory: [  OK  ]

Starting ntpd ...
 Success: Starting ntpd: [  OK  ]

Statusing mongod ...
 Success: mongod (pid 15741) is running...
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
deltacloud-core dead but pid file exists
Comment 9 Michal Fojtik 2011-11-14 04:14:37 EST
Wes can you please remove /var/run/deltacloud-core* and try it again? Restart work perfectly for me on RHEL6.
Comment 10 wes hayutin 2011-11-14 10:09:30 EST
(In reply to comment #9)
> Wes can you please remove /var/run/deltacloud-core* and try it again? Restart
> work perfectly for me on RHEL6.

If you look carefully at comment #8 you will see thats exactly what I do..
[root@qeblade30 ~]# rm -Rf /var/run/deltacloud-core-mock.pid 
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
Comment 11 Michal Fojtik 2011-11-14 10:51:57 EST
OK after few minutes of insanely trying to figure out what is wrong (with rage face) I found this in log:

>> Writing PID to /var/run/deltacloud-core-mock.pid
>> Changing process privilege to nobody:nobody
>> Exiting!
/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/daemonizing.rb:158:in `delete': Permission denied - /var/run/deltacloud-core-mock.pid (Errno::EACCES)
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/daemonizing.rb:158:in `remove_pid_file'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/daemonizing.rb:59:in `daemonize'
/usr/share/deltacloud-core/bin/../lib/deltacloud/drivers/mock/mock_driver.rb:96:in `initialize': Please set either the DELTACLOUD_MOCK_STORAGE or USER environment variable (RuntimeError)
	from /usr/share/deltacloud-core/bin/../lib/deltacloud/drivers.rb:69:in `new'
	from /usr/share/deltacloud-core/bin/../lib/deltacloud/drivers.rb:69:in `driver'
	from /usr/share/deltacloud-core/bin/../server.rb:52
	from /usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:1211:in `configure'
	from (__DELEGATE__):3:in `send'
	from (__DELEGATE__):3:in `configure'
	from /usr/share/deltacloud-core/bin/../server.rb:48
	from /usr/share/deltacloud-core/bin/../config.ru:23:in `load'
	from /usr/share/deltacloud-core/bin/../config.ru:23
	from /usr/lib/ruby/gems/1.8/gems/rack-1.3.0/lib/rack/builder.rb:51:in `instance_eval'
	from /usr/lib/ruby/gems/1.8/gems/rack-1.3.0/lib/rack/builder.rb:51:in `initialize'
	from /usr/share/deltacloud-core/bin/../config.ru:1:in `new'
	from /usr/share/deltacloud-core/bin/../config.ru:1

So seems like the user deltacloud-core is trying to run on (nobody) is not allowed to write into /var/run directory... 
Seems like we will need to create /var/run/deltacloud-core directory and change owner to 'nobody'. Any better ideas?
Comment 12 Michal Fojtik 2011-11-14 13:07:16 EST
So this is the fixed init script which should work both in RHEL and Fedora:
Also there is a very small change in deltacloudd (line 221, replace API_PROVIDER with API_DRIVER in order to have proper name for log...). Wes I'll build a new RPM tomorrow morning and push it to Koji.

Meanwhile I made modifications on 'qeblade31' so you can test if it works.

#!/bin/bash -l
#
# deltacloud-core   Deltacloud API Core
# chkconfig: 345 90 60
# description: deltacloud-core is primary server process for the \
#             Deltacloud Core component.

### BEGIN INIT INFO
# Provides: deltacloud-core
# Required-Start:
# Required-Stop:
# Default-Start: 3 5
# Default-Stop: 0 1 2 6
# Short-Description: Deltacloud Core API deamon
# Description: Deltacloud Core API provides access to different cloud providers \
#   using single REST API
### END INIT INFO

. /etc/rc.d/init.d/functions

[ -r /etc/sysconfig/deltacloud-core ] && . /etc/sysconfig/deltacloud-core

exec="/usr/bin/deltacloudd"
prog="deltacloud-core"

[ ! -d /var/log/$prog ] && mkdir -p /var/log/$prog

# You can overide these variables using /etc/sysconfig/deltacloud-core
API_ENV="${API_ENV:-production}"
DRIVER="${DRIVER:-mock}"
PORT="${PORT:-3002}"
HOST="${HOST:-localhost}"
DELTACLOUD_USER="${DELTACLOUD_USER:-nobody}"
LOGFILE="${LOGFILE:-/var/log/$prog/$DRIVER.log}"
LOCKFILE="${LOCKFILE:-/var/lock/subsys/$prog}"
PIDFILE="${PIDFILE:-/var/run/deltacloud/deltacloud-core-$DRIVER.pid}"

[[ ! -d /var/run/deltacloud ]] && mkdir /var/run/deltacloud
chown $DELTACLOUD_USER /var/run/deltacloud
[ -r $LOGFILE ] && chown nobody $LOGFILE
[ -r $LOCKFILE ] && chown nobody $LOCKFILE

start() {
    [ -x $exec ] || exit 5
    USER=${DELTACLOUD_USER}
    cd /
    echo -n $"Starting $prog-$DRIVER: "
    $exec -i ${DRIVER} -e ${API_ENV} --user ${DELTACLOUD_USER} --daemon --pid ${PIDFILE} --port ${PORT} --host ${HOST}
    retval=$?

    if [ $retval -eq 0 ] && touch $LOCKFILE ; then
      echo_success
      echo
    else
      echo_failure
      echo
    fi
    return $retval
}

stop() {
    echo -n $"Shutting down $prog: "
    if [ -f $PIDFILE ]; then
      kill -3 `cat $PIDFILE`
      retval=$?
      if [ $retval -eq 0 ] && rm -f $LOCKFILE $PIDFILE; then
        echo_success
        echo
      else
        echo_failure
        echo
      fi
      return $retval
    else
      echo_failure
      echo
      return 1
    fi
}

case "$1" in
    start)
      start
      ;;
    stop)
      stop
      ;;
    restart)
      stop
      start
      ;;
    reload)
      ;;
    force-reload)
      restart
      ;;
    status)
      status -p $PIDFILE $prog
      retval=$?
      ;;
    *)
      echo "Usage: $prog {start|stop|restart|status}"
      exit 1
  ;;
esac

exit $retval
Comment 13 wes hayutin 2011-11-15 11:04:17 EST
root@qeblade30 ~]# ps -ef | grep deltacloud
nobody   11196     1  0 08:20 ?        00:00:47 thin server (localhost:3002) [deltacloud-mock]                                                                                                                 
root     23656 23608  0 11:00 pts/3    00:00:00 grep deltacloud
[root@qeblade30 ~]# /etc/init.d/deltacloud-core stop
Shutting down deltacloud-core: [  OK  ]
[root@qeblade30 ~]# ps -ef | grep deltacloud
root     23684 23608  0 11:01 pts/3    00:00:00 grep deltacloud
[root@qeblade30 ~]# /etc/init.d/deltacloud-core start
Starting deltacloud-core-mock: [  OK  ]
[root@qeblade30 ~]# ps -ef | grep deltacloud
nobody   23698     1 23 11:01 ?        00:00:00 thin server (localhost:3002) [deltacloud-mock]                                                                                                                 
root     23701 23608  0 11:01 pts/3    00:00:00 grep deltacloud
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
deltacloud-core (pid  23698) is running...
[root@qeblade30 ~]# aeolus-restart-services 

Stoping ntpd ...
 Success: Shutting down ntpd: [  OK  ]

Stoping imagefactory ...
 Success: Stopping imagefactory: [  OK  ]

Stoping conductor-dbomatic ...
[  OK  ]: Shutting down conductor-dbomatic: [  OK  ]

Stoping aeolus-conductor ...
 Success: Shutting down aeolus-conductor: [  OK  ]

Stoping libvirtd ...
 Success: Stopping libvirtd daemon: [  OK  ]

Stoping deltacloud-core ...
 Success: Shutting down deltacloud-core: [  OK  ]

Stoping qpidd ...
 Success: Stopping Qpid AMQP daemon: [  OK  ]

Stoping httpd ...
 Success: Stopping httpd: [  OK  ]

Stoping postgresql ...
 Success: Stopping postgresql service: [  OK  ]

Stoping iwhd ...
[  OK  ]: Stopping iwhd daemon:  [  OK  ]

Stoping mongod ...
 Success: Stopping mongod: [  OK  ]

Starting mongod ...
 Success: Starting mongod: [  OK  ]

Starting iwhd ...
 Success: waiting for mongod to listen on localhost:27017[  OK  ]
Starting iwhd daemon: [  OK  ]

Starting postgresql ...
 Success: Starting postgresql service: [  OK  ]

Starting httpd ...
 Success: Starting httpd: [  OK  ]

Starting qpidd ...
 Success: Starting Qpid AMQP daemon: [  OK  ]

Starting deltacloud-core ...
 Success: Starting deltacloud-core-mock: [  OK  ]

Starting libvirtd ...
 Success: Starting libvirtd daemon: [  OK  ]

Starting aeolus-conductor ...
touch: missing file operand
Try `touch --help' for more information.
 Success: Starting aeolus-conductor: [  OK  ]

Starting conductor-dbomatic ...
[  OK  ]: Starting conductor-dbomatic: [  OK  ]

Starting imagefactory ...
/usr/lib/python2.6/site-packages/oauth2/__init__.py:29: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
 Success: Starting imagefactory: [  OK  ]

Starting ntpd ...
 Success: Starting ntpd: [  OK  ]

Statusing mongod ...
 Success: mongod (pid 23901) is running...
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
deltacloud-core (pid  24072) is running...
[root@qeblade30 ~]# ps -ef | grep deltacloud
nobody   24072     1  6 11:01 ?        00:00:01 thin server (localhost:3002) [deltacloud-mock]                                                                                                                 
root     24274 23608  0 11:01 pts/3    00:00:00 grep deltacloud
[root@qeblade30 ~]# /etc/init.d/deltacloud-core stop
Shutting down deltacloud-core: [  OK  ]
[root@qeblade30 ~]# aeolus-restart-services 

Stoping ntpd ...
 Success: Shutting down ntpd: [  OK  ]

Stoping imagefactory ...
 Success: Stopping imagefactory: [  OK  ]

Stoping conductor-dbomatic ...
[  OK  ]: Shutting down conductor-dbomatic: [  OK  ]

Stoping aeolus-conductor ...
 Success: Shutting down aeolus-conductor: [  OK  ]

Stoping libvirtd ...
 Success: Stopping libvirtd daemon: [  OK  ]

Stoping deltacloud-core ...
 FAILURE: Shutting down deltacloud-core: [FAILED]

Stoping qpidd ...
 Success: Stopping Qpid AMQP daemon: [  OK  ]

Stoping httpd ...
 Success: Stopping httpd: [  OK  ]

Stoping postgresql ...
 Success: Stopping postgresql service: [  OK  ]

Stoping iwhd ...
[  OK  ]: Stopping iwhd daemon:  [  OK  ]

Stoping mongod ...
 Success: Stopping mongod: [  OK  ]

Starting mongod ...
 Success: Starting mongod: [  OK  ]

Starting iwhd ...
 Success: waiting for mongod to listen on localhost:27017[  OK  ]
Starting iwhd daemon: [  OK  ]

Starting postgresql ...
 Success: Starting postgresql service: [  OK  ]

Starting httpd ...
 Success: Starting httpd: [  OK  ]

Starting qpidd ...
 Success: Starting Qpid AMQP daemon: [  OK  ]

Starting deltacloud-core ...
 Success: Starting deltacloud-core-mock: [  OK  ]

Starting libvirtd ...
 Success: Starting libvirtd daemon: [  OK  ]

Starting aeolus-conductor ...
touch: missing file operand
Try `touch --help' for more information.
 Success: Starting aeolus-conductor: [  OK  ]

Starting conductor-dbomatic ...
[  OK  ]: Starting conductor-dbomatic: [  OK  ]

Starting imagefactory ...
/usr/lib/python2.6/site-packages/oauth2/__init__.py:29: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
 Success: Starting imagefactory: [  OK  ]

Starting ntpd ...
 Success: Starting ntpd: [  OK  ]root@qeblade30 ~]# ps -ef | grep deltacloud
nobody   11196     1  0 08:20 ?        00:00:47 thin server (localhost:3002) [deltacloud-mock]                                                                                                                 
root     23656 23608  0 11:00 pts/3    00:00:00 grep deltacloud
[root@qeblade30 ~]# /etc/init.d/deltacloud-core stop
Shutting down deltacloud-core: [  OK  ]
[root@qeblade30 ~]# ps -ef | grep deltacloud
root     23684 23608  0 11:01 pts/3    00:00:00 grep deltacloud
[root@qeblade30 ~]# /etc/init.d/deltacloud-core start
Starting deltacloud-core-mock: [  OK  ]
[root@qeblade30 ~]# ps -ef | grep deltacloud
nobody   23698     1 23 11:01 ?        00:00:00 thin server (localhost:3002) [deltacloud-mock]                                                                                                                 
root     23701 23608  0 11:01 pts/3    00:00:00 grep deltacloud
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
deltacloud-core (pid  23698) is running...
[root@qeblade30 ~]# aeolus-restart-services 

Stoping ntpd ...
 Success: Shutting down ntpd: [  OK  ]

Stoping imagefactory ...
 Success: Stopping imagefactory: [  OK  ]

Stoping conductor-dbomatic ...
[  OK  ]: Shutting down conductor-dbomatic: [  OK  ]

Stoping aeolus-conductor ...
 Success: Shutting down aeolus-conductor: [  OK  ]

Stoping libvirtd ...
 Success: Stopping libvirtd daemon: [  OK  ]

Stoping deltacloud-core ...
 Success: Shutting down deltacloud-core: [  OK  ]

Stoping qpidd ...
 Success: Stopping Qpid AMQP daemon: [  OK  ]

Stoping httpd ...
 Success: Stopping httpd: [  OK  ]

Stoping postgresql ...
 Success: Stopping postgresql service: [  OK  ]

Stoping iwhd ...
[  OK  ]: Stopping iwhd daemon:  [  OK  ]

Stoping mongod ...
 Success: Stopping mongod: [  OK  ]

Starting mongod ...
 Success: Starting mongod: [  OK  ]

Starting iwhd ...
 Success: waiting for mongod to listen on localhost:27017[  OK  ]
Starting iwhd daemon: [  OK  ]

Starting postgresql ...
 Success: Starting postgresql service: [  OK  ]

Starting httpd ...
 Success: Starting httpd: [  OK  ]

Starting qpidd ...
 Success: Starting Qpid AMQP daemon: [  OK  ]

Starting deltacloud-core ...
 Success: Starting deltacloud-core-mock: [  OK  ]

Starting libvirtd ...
 Success: Starting libvirtd daemon: [  OK  ]

Starting aeolus-conductor ...
touch: missing file operand
Try `touch --help' for more information.
 Success: Starting aeolus-conductor: [  OK  ]

Starting conductor-dbomatic ...
[  OK  ]: Starting conductor-dbomatic: [  OK  ]

Starting imagefactory ...
/usr/lib/python2.6/site-packages/oauth2/__init__.py:29: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
 Success: Starting imagefactory: [  OK  ]

Starting ntpd ...
 Success: Starting ntpd: [  OK  ]

Statusing mongod ...
 Success: mongod (pid 23901) is running...
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
deltacloud-core (pid  24072) is running...
[root@qeblade30 ~]# ps -ef | grep deltacloud
nobody   24072     1  6 11:01 ?        00:00:01 thin server (localhost:3002) [deltacloud-mock]                                                                                                                 
root     24274 23608  0 11:01 pts/3    00:00:00 grep deltacloud
[root@qeblade30 ~]# /etc/init.d/deltacloud-core stop
Shutting down deltacloud-core: [  OK  ]
[root@qeblade30 ~]# aeolus-restart-services 

Stoping ntpd ...
 Success: Shutting down ntpd: [  OK  ]

Stoping imagefactory ...
 Success: Stopping imagefactory: [  OK  ]

Stoping conductor-dbomatic ...
[  OK  ]: Shutting down conductor-dbomatic: [  OK  ]

Stoping aeolus-conductor ...
 Success: Shutting down aeolus-conductor: [  OK  ]

Stoping libvirtd ...
 Success: Stopping libvirtd daemon: [  OK  ]

Stoping deltacloud-core ...
 FAILURE: Shutting down deltacloud-core: [FAILED]

Stoping qpidd ...
 Success: Stopping Qpid AMQP daemon: [  OK  ]

Stoping httpd ...
 Success: Stopping httpd: [  OK  ]

Stoping postgresql ...
 Success: Stopping postgresql service: [  OK  ]

Stoping iwhd ...
[  OK  ]: Stopping iwhd daemon:  [  OK  ]

Stoping mongod ...
 Success: Stopping mongod: [  OK  ]

Starting mongod ...
 Success: Starting mongod: [  OK  ]

Starting iwhd ...
 Success: waiting for mongod to listen on localhost:27017[  OK  ]
Starting iwhd daemon: [  OK  ]

Starting postgresql ...
 Success: Starting postgresql service: [  OK  ]

Starting httpd ...
 Success: Starting httpd: [  OK  ]

Starting qpidd ...
 Success: Starting Qpid AMQP daemon: [  OK  ]

Starting deltacloud-core ...
 Success: Starting deltacloud-core-mock: [  OK  ]

Starting libvirtd ...
 Success: Starting libvirtd daemon: [  OK  ]

Starting aeolus-conductor ...
touch: missing file operand
Try `touch --help' for more information.
 Success: Starting aeolus-conductor: [  OK  ]

Starting conductor-dbomatic ...
[  OK  ]: Starting conductor-dbomatic: [  OK  ]

Starting imagefactory ...
/usr/lib/python2.6/site-packages/oauth2/__init__.py:29: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
 Success: Starting imagefactory: [  OK  ]

Starting ntpd ...
 Success: Starting ntpd: [  OK  ]

Statusing mongod ...
 Success: mongod (pid 24472) is running...
[root@qeblade30 ~]# ps -ef | grep deltacloud
nobody   24648     1  2 11:02 ?        00:00:01 thin server (localhost:3002) [deltacloud-mock]                                                                                                                 
root     24839 23608  0 11:03 pts/3    00:00:00 grep deltacloud
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
deltacloud-core (pid  24648) is running...
[root@qeblade30 ~]# 


[root@qeblade30 ~]# rpm -qa | grep deltacloud
rubygem-deltacloud-client-0.4.0-3.el6.noarch
deltacloud-core-ec2-0.4.1-7.el6.noarch
deltacloud-core-rhevm-0.4.1-7.el6.noarch
deltacloud-core-0.4.1-7.el6.noarch
deltacloud-core-vsphere-0.4.1-7.el6.noarch
[root@qeblade30 ~]# rpm -qa | grep aeolus
aeolus-conductor-doc-0.6.0-0.20111114172747gitde62906.el6.noarch
rubygem-rack-mount-0.7.1-3.aeolus.el6.noarch
rubygem-aeolus-cli-0.1.0-3.20111114114625git42b14c0.el6.noarch
rubygem-aeolus-image-0.1.0-4.20111024205454git6b2b696.el6.noarch
aeolus-conductor-daemons-0.6.0-0.20111114172747gitde62906.el6.noarch
aeolus-conductor-0.6.0-0.20111114172747gitde62906.el6.noarch
rubygem-arel-2.0.10-0.aeolus.el6.noarch
aeolus-configure-2.3.0-0.20111111160331git9bde372.el6.noarch
aeolus-all-0.6.0-0.20111114172747gitde62906.el6.noarch
rubygem-ZenTest-4.3.3-2.aeolus.el6.noarch

[root@qeblade30 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.1 (Santiago)





Statusing mongod ...
 Success: mongod (pid 24472) is running...
[root@qeblade30 ~]# ps -ef | grep deltacloud
nobody   24648     1  2 11:02 ?        00:00:01 thin server (localhost:3002) [deltacloud-mock]                                                                                                                 
root     24839 23608  0 11:03 pts/3    00:00:00 grep deltacloud
[root@qeblade30 ~]# /etc/init.d/deltacloud-core status
deltacloud-core (pid  24648) is running...
[root@qeblade30 ~]#
Comment 14 Michal Fojtik 2011-11-16 15:45:46 EST
Wes does it mean this bug is fixed? Or need some additional fiddling? I assume the deltacloud-core is being properly started. Then you stopped it manually and then restarted it. It fails to stop the service, since  it's was already stopped. Then it was started successfully again. Is this behavior we expect ?
Comment 15 wes hayutin 2011-11-16 16:04:20 EST
(In reply to comment #14)
> Wes does it mean this bug is fixed? Or need some additional fiddling? I assume
> the deltacloud-core is being properly started. Then you stopped it manually and
> then restarted it. It fails to stop the service, since  it's was already
> stopped. Then it was started successfully again. Is this behavior we expect ?

lol.. now ur just paranoid.. this bug is in verified state... meaning qe marked it as a pass!!
Comment 16 Michal Fojtik 2011-11-18 14:52:04 EST
Thanks ;-) Yeah I had bad night thinking about this broken init script :))
Comment 17 wes hayutin 2011-11-27 20:17:21 EST
removing bugs from ce-sprint from the tracker.. you can find these bugs by querying the "qa whiteboard" for ce-sprint-60
Comment 18 errata-xmlrpc 2012-05-15 16:32:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0587.html

Note You need to log in before you can comment on or make changes to this bug.