This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 74982 - Toshiba Libretto L1 PCMCIA problems during install
Toshiba Libretto L1 PCMCIA problems during install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 08:14 EDT by Sven Neuhaus
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sven Neuhaus 2002-10-03 08:14:16 EDT
Description of Problem:
I can't do a network install on my Toshiba Libretto L1 notebook because there
are problems with PCMCIA.

The installer only offers me "hard disk installation" after I boot from the
PCMCIA and PCMCIAdd floppy images (off a Sony USB floppy drive).

Here is the partial, hand copied output from the console 4 with the PCMCIA error
messages:

...
<4>PCI: No IRQ known for interrupt pin A of device 00:12.0. Please try using
pci=biosirq
<4>Yenta IRQ list 0000, PCI irq0
<4>Socket status: 30000020
<6>cs: cb_alloc(bus 1): vendor 0x10ec, device 0x8139
<4>PCI: Enabling device 01:00.0 (0000 -> 0003)
<4>PCI: No IRQ known for interrupt pin A of device 00:12.0. Please try using
pci=biosirq
<30>Oct 3 14:00:43 cardmgr[55]: starting, version is 3.1.31
<27>Oct 3 14:00:43 cardmgr[55]: config error, file 'config' line 1053: syntax error
<30>Oct 3 14:00:43 cardmgr[55]: config error, file 'config' line 2129: no
function binding
<30>Oct 3 14:00:43 cardmgr[55]: watching 1 sockets
<30>Oct 3 14:00:43 cardmgr[55]: Card services release does not match
<6>cs: IO port probe 0x0c00-0x0cff: clean.
<6>cs: IO port probe 0x0100-0x04ff: excluding 0x1e0-0x1e7 0x408-0x40f
0x480-0x48f 0x4d0-0x4d7
<6>cs: IO port probe 0x0a00-0x0aff: clean.
<28>Oct 3 14:00:43 cardmgr[55]: could not open /var/run/cardmgr.pid:
<28>Oct 3 14:00:43 cardmgr[55]: fopen(stabfile) failed:
<30>Oct 3 14:00:43 cardmgr[55]: socket 0: CardBus hotplug device
<28>Oct 3 14:00:43 cardmgr[55]: fopen(stabfile) failed:
<30>Oct 3 14:00:43 cardmgr[55]: exiting

--------

I tried booting with "linux pci=biosirq" but that got me a kernel panik.

I think it uses a Toshiba TOPIC100 CardBus bridge.

I tried installing with 2 different CardBus fast ethernet cards:

* Ambicom AMB8100
* LevelOne FPC-0106TX

If you need further information about the Toshiba Libretto L1, let me know
(hardware etc).
Comment 1 Jeremy Katz 2002-10-05 09:38:58 EDT
Based on the kernel messages given, I'm pretty sure you have to use pci=biosirq
to get the interrupt routing to work so that we can probe and use any cardbus
devices.
Comment 2 Sven Neuhaus 2002-10-07 03:40:23 EDT
OK, I tried that and got a kernel panic. I'll try it again and write down the
exact kernel panic message (it probably belongs on the linux kernel mailinglist).
Comment 3 Need Real Name 2002-10-23 23:18:58 EDT
The same PCI bridge-related issue with a Libretto L5/080 TNKW with an
ACPI-compliant PCI bus and ALi M1533 PCI-to-ISA bridge. 16 and 32-bit cards can
be inserted and show up with "cardctl status" but all drivers report  IRQ 0 for
the device. 32-bit ethernet cards even show up in the ifconfig list with the
correct MAC-address but can not be configured with ifconfig.
Comment 4 pc 2003-05-08 18:45:48 EDT
I have a libretto 100ct and I also get this problem. I've tried 7.2, 8.0 and 9.0
each displaying the same error. Since the pcmcia floppy that is the only floppy
device with the libretto and doesn't work after booting, I've used autoboot for
these three distributions.

Please note that using pci=biosirq doesn't have any effect. (It didn't kernel
panic for me)

I don't get the problem when I use the pcmcia boot disk with 6.1 and 6.2. Both
nfs install fine.

I'm using a 3com 3cxfe575bt ethernet card. But I believe it's the pcmcia that's
the issue.
Comment 5 Bugzilla owner 2004-09-30 11:39:59 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.