Bug 749874 - Please build for EPEL 6
Summary: Please build for EPEL 6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ctpl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-28 18:40 UTC by Jonathan Underwood
Modified: 2012-01-05 20:31 UTC (History)
1 user (show)

Fixed In Version: ctpl-0.3.2-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-05 20:31:56 UTC


Attachments (Terms of Use)

Description Jonathan Underwood 2011-10-28 18:40:54 UTC
Description of problem:
Hi - would you be able to push a build for EL6 - we need ctpl in order to be able to build the geany-plugins package.

Comment 1 Dominic Hopf 2011-10-28 21:45:08 UTC
Of course. Requested el6 branch with #615091. :)

Comment 2 Dominic Hopf 2011-10-29 21:26:28 UTC
Hi Jonathan,

the scratch-builds I tried this morning unfortunately failed. I just noticed in koji you most likely already saw this. I'm a bit confused about the man page issue and run out of ideas what the cause for this build  failure could be. Do you have any idea what may could cause this?

Regs,
Dom

Comment 3 Jonathan Underwood 2011-10-30 09:37:43 UTC
Yes, I just noticed this as well, and can't quite work out why it's failing either. It looks like the man page simply isn't being installed during %install. Will have a look more closely later.

Comment 4 Jonathan Underwood 2011-11-02 23:42:36 UTC
OK, the reason is this. During configure we see:

configure: WARNING: The ctpl command-line utility will not be built because of the following error: Requested 'gio-2.0 >= 2.24' but version of GIO is 2.22.5


So, the command line ctpl isn't built. Looking at the Makefile.am in the data directory, in this case the man page isn't installed either. I suppose this makes sense - no need to install a man page for a command line tool that isn't installed.

So, the question is: is this package useful without the ctpl command line tool? And does the geany-plugins package need that command line tool?

Comment 5 Dominic Hopf 2011-11-03 21:24:50 UTC
Just talked back to Colomban (the upstream developer) to make sure I'm not telling something wrong. The ctpl command line tool is not needed to run GeanyGenDoc - which is in fact the only plugin which makes use of the library ctpl provides as well.

There is no support for disabling the build of the CLI tool, yet. Thus we would have to remove the CLI stuff from the package? The main CTPL package would more or less become some kind of meta package then, wouldn't it?

Comment 6 Dominic Hopf 2011-11-04 22:20:21 UTC
Well, Colomban was quite fast with adding some build features:

http://git.tuxfamily.org/ctpl/ctpl/?p=gitroot/ctpl/ctpl.git;a=commitdiff;h=fdf8e8a8e5a190ff03aefbd9dc80bcc083a2854b

:)

Comment 7 Jonathan Underwood 2011-11-05 11:30:44 UTC
If he's a responsive maintainer it might be worth asking him if he would add support for gio 2.22.5 since that's going to be on production systems for a long time to come (it being in RHEL 6) - it would be worth finding out what is the reason for requiring gio 2.24.

Comment 8 Dominic Hopf 2011-11-05 16:33:18 UTC
The reason for the requirement to Gio 2.24 is GCharsetConverter. Colomban
mentioned two possible ways to drop or rather reduce this requirement:

1) remove charset support (bad, wouldn't be CTPL 0.3)
2) include a copy of GCharsetConverter

1) wouldn't be an option I guess, and he won't do 2) upstream, but we maybe
could do it in the package.

So if I see this right there are two possibilities to get the support for
GeanyGenDoc, either we resign the CTPL command line utility, or we ship an own
copy of GCharsetConverter.

I tend to suggest the copy of GCharsetConverter, what do you think?

Comment 9 Jonathan Underwood 2011-11-06 01:04:02 UTC
Yes, I agree - adding a patch to the package to add in GCharsetConverter would be the best option if it's not too tricky to do. Will try and look at it tomorrow, but maybe you and/or Colomban will beat me to it :)

Comment 10 Dominic Hopf 2011-11-06 15:09:10 UTC
Here is a try to do this:

http://dmaphy.fedorapeople.org/ctpl/ctpl-0.3.2-4.el6.src.rpm

The build unfortunately fails with:

gcharsetconverter.h:24:2: error: #error "Only <gio/gio.h> can be included directly."
gcharsetconverter.h:30:28: error: gio/gconverter.h: No such file or directory
In file included from ctpl.c:34:


This would mean we would have to extract more or less the whole Gio stuff from glib2 and ship it with ctpl. Not sure if that still would fit with the guidelines. :s

Comment 11 Dominic Hopf 2011-11-10 18:56:52 UTC
Just to keep you up-to-date: I won't get around to continue on this until beginning of next week.

Comment 12 Fedora Update System 2011-12-18 16:38:23 UTC
ctpl-0.3.2-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ctpl-0.3.2-4.el6

Comment 13 Fedora Update System 2011-12-20 20:05:45 UTC
ctpl-0.3.2-4.el6 has been pushed to the Fedora EPEL 6 testing repository.

Comment 14 Fedora Update System 2012-01-05 20:31:56 UTC
ctpl-0.3.2-4.el6 has been pushed to the Fedora EPEL 6 stable repository.


Note You need to log in before you can comment on or make changes to this bug.