Bug 749887 - [abrt] kernel: WARNING: at drivers/block/floppy.c:1041 setup_rw_floppy+0x188/0x241 [floppy]()
Summary: [abrt] kernel: WARNING: at drivers/block/floppy.c:1041 setup_rw_floppy+0x188/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:85804743262f3164bee416f18d8...
: 744885 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-28 19:17 UTC by Zdenek Svecar
Modified: 2011-11-17 23:28 UTC (History)
6 users (show)

Fixed In Version: kernel-2.6.41.1-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-02 18:19:50 UTC
Type: ---


Attachments (Terms of Use)
File: smolt_data (2.16 KB, text/plain)
2011-10-28 19:17 UTC, Zdenek Svecar
no flags Details

Description Zdenek Svecar 2011-10-28 19:17:49 UTC
libreport version: 2.0.6
abrt_version:   2.0.4.981
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.0-1.fc16.i686 root=/dev/mapper/vg_p4u800x-lv_root ro rd.md=0 rd.dm=0 KEYTABLE=us quiet rd.lvm.lv=vg_p4u800x/lv_swap SYSFONT=latarcyrheb-sun16 rhgb rd.lvm.lv=vg_p4u800x/lv_root rd.luks=0 LANG=en_US.UTF-8
kernel:         undefined
reason:         WARNING: at drivers/block/floppy.c:1041 setup_rw_floppy+0x188/0x241 [floppy]()
time:           Fri Oct 28 18:34:28 2011

smolt_data:     Binary file, 2210 bytes

backtrace:
:WARNING: at drivers/block/floppy.c:1041 setup_rw_floppy+0x188/0x241 [floppy]()
:Hardware name: P4U800-X
:floppy_disable_hlt() scheduled for removal in 2012
:Modules linked in: msdos fat floppy fuse fcoe libfcoe libfc scsi_transport_fc 8021q scsi_tgt garp stp llc ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 ip6table_filter xt_state nf_conntrack ip6_tables snd_intel8x0 snd_ac97_codec ac97_bus snd_cs4236 snd_wss_lib snd_opl3_lib snd_hwdep joydev snd_seq snd_pcm snd_mpu401 snd_mpu401_uart snd_rawmidi snd_timer snd_seq_device ppdev snd soundcore uli526x parport_pc parport ns558 gameport snd_page_alloc i2c_ali15x3 serio_raw i2c_ali1563 uinput i2c_ali1535 microcode pata_acpi ata_generic sata_inic162x pata_ali radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 0, comm: swapper Not tainted 3.1.0-1.fc16.i686 #1
:Call Trace:
: [<c043c959>] warn_slowpath_common+0x7c/0x91
: [<f7d38c09>] ? setup_rw_floppy+0x188/0x241 [floppy]
: [<f7d38c09>] ? setup_rw_floppy+0x188/0x241 [floppy]
: [<c043c9f9>] warn_slowpath_fmt+0x33/0x35
: [<f7d38c09>] setup_rw_floppy+0x188/0x241 [floppy]
: [<f7d34118>] ? vdma_dma_setup+0x46/0x46 [floppy]
: [<c0447f56>] run_timer_softirq+0x14b/0x221
: [<c048de37>] ? __rcu_process_callbacks+0x64/0x242
: [<f7d38a81>] ? fd_watchdog+0x99/0x99 [floppy]
: [<c0441b4c>] __do_softirq+0xa2/0x17b
: [<c0441aaa>] ? ftrace_define_fields_irq_handler_entry+0x71/0x71
: <IRQ>  [<c0441da8>] ? irq_exit+0x45/0x98
: [<c0418c26>] ? smp_apic_timer_interrupt+0x69/0x76
: [<c08112e1>] ? apic_timer_interrupt+0x31/0x38
: [<c0408920>] ? mwait_idle+0x6d/0x97
: [<c0401f91>] ? cpu_idle+0x97/0xb1
: [<c07f30e5>] ? rest_init+0x5d/0x5f
: [<c0ab978a>] ? start_kernel+0x34d/0x353
: [<c0ab91c6>] ? loglevel+0x2b/0x2b
: [<c0ab90a9>] ? i386_start_kernel+0xa9/0xaf

comment:
:Enabling floppy - this works in RHEL6, I just replicated the procedure
:1)  mkdir /media/floppy0
:2) create file 
:/etc/sysconfig/modules/floppy.modules 
:with content:
:#!/bin/sh
:
:if [ ! -c /dev/floppy ] ; then
:        exec /sbin/modprobe floppy >/dev/null 2>&1
:fi
:
:3) chmod +x /etc/sysconfig/modules/floppy.modules 
:4) test it: 
:mount -t msdos /dev/fd0 /media/floppy0
:
:5) if all goes well, add to /etc/fstab:
:/dev/fd0 			/media/floppy0 		auto 	rw,noauto,user,sync 	0 0
:
:Check with mount -a before you reboot.
:
:After reboot, it is not possible to mount diskette via Places -> Diskette drive
:
:and this is how this problem has happened.

event_log:
:2011-10-28-19:12:22> Smolt profile successfully saved
:2011-10-28-19:16:39> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2011-10-28-19:17:42  Kernel oops has not been sent due to Couldn't connect to server
:2011-10-28-19:17:42* (exited with 1)

Comment 1 Zdenek Svecar 2011-10-28 19:17:53 UTC
Created attachment 530730 [details]
File: smolt_data

Comment 2 Josh Boyer 2011-10-28 19:29:57 UTC
This isn't a bug.  It's just a stupid warning about a deprecated interface.

I'll fix this up to not be quite so drastic.

Comment 3 Josh Boyer 2011-10-28 20:22:02 UTC
OK, this traceback should be gone in the next build.

Comment 4 Fedora Update System 2011-11-01 19:58:28 UTC
kernel-2.6.40.8-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.8-4.fc15

Comment 5 Fedora Update System 2011-11-01 22:59:14 UTC
kernel-3.1.0-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.1.0-7.fc16

Comment 6 Fedora Update System 2011-11-02 06:54:55 UTC
Package kernel-2.6.40.8-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.40.8-4.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15230
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-11-02 18:19:50 UTC
kernel-3.1.0-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Josh Boyer 2011-11-07 19:55:39 UTC
*** Bug 744885 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2011-11-12 00:07:29 UTC
kernel-2.6.41.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.41.1-1.fc15

Comment 10 Fedora Update System 2011-11-17 23:28:11 UTC
kernel-2.6.41.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.